Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УНФ 1.6 как разрешить ставить цену 0.00 в заказе

УНФ 1.6 как разрешить ставить цену 0.00 в заказе
Я
   I_learn_1c
 
28.04.18 - 13:22
Подскажите пожалуйста.

Нужно снять ограничение для заказа, чтобы позволяло ставить цену 0.00.
В форме  для колонки цены АвтоОтметкаНезаполненного=Нет, записывать позволяет, при проведении ошибка незаполненности. Отладчиком прохожу все не могу понять где этот момент проверки..
 
 
   I_learn_1c
 
1 - 28.04.18 - 13:25
ошибка до обработки проведения
   Вафель
 
2 - 28.04.18 - 13:26
может в метаданных?
   I_learn_1c
 
3 - 28.04.18 - 13:30
(2) как?
   Buster007
 
4 - 28.04.18 - 13:41
для реквизита надо снять проверку заполнения
   shuhard
 
5 - 28.04.18 - 13:43
(0) в типовых две точки - реквизит + общий модуль контроль оформления
   Cyberhawk
 
6 - 28.04.18 - 13:43
(5) УНФ - это тебе не типовая на БСП)
   shuhard
 
7 - 28.04.18 - 13:44
(6) значит одна точка
   I_learn_1c
 
8 - 03.05.18 - 09:48
не помогло.

в реквизите Цена стоит Проверка заполнения - Не проверять
в форме в поле Цена стоит АвтоОтметкаНезаполненного - Нет
   I_learn_1c
 
9 - 03.05.18 - 09:50
может еще где-то отметить нужно?
   shuhard
 
10 - 03.05.18 - 09:54
(9) см (5)
 
 Рекламное место пустует
   I_learn_1c
 
11 - 03.05.18 - 10:09
(10) в УНФ нет модуля Контроль оформления, или чего-то похожего найти не могу
   I_learn_1c
 
12 - 03.05.18 - 10:15
если нажать "Провести и закрыть" то при отладке вот тут на КонецПроцедуры вылетает ошибка о незаполненности. Но что ее вызывает не пойму.
Или еще, если ставлю 0 то поле остается незаполненным, может как то можно разрешить его заполнять 0.00 чтобы было заполнено по факту?


&НаКлиенте
Процедура ПровестиИЗакрыть(Команда)
    
    ОчиститьСообщения();
    
    ПараметрыЗаписи = Новый Структура;
    ПараметрыЗаписи.Вставить("РежимЗаписи",        РежимЗаписиДокумента.Проведение);
    ПараметрыЗаписи.Вставить("РежимПроведения",    РежимПроведенияДокумента.Неоперативный);
    ПараметрыЗаписи.Вставить("ПринудительноЗакрытьФорму", Истина);
    
    Записать(ПараметрыЗаписи);
    СтатистикаИспользованияФормКлиент.ПриИнтерактивномДействии(ЭтотОбъект, Элементы.ФормаПровестиИЗакрыть, "Нажатие");
    
КонецПроцедуры
   I_learn_1c
 
13 - 03.05.18 - 10:29
в заказе в ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты) закомментить это... почему я сразу не додумалась. Но все равно спасибо всем за советы)

//Если НЕ ЗначениеЗаполнено(Стр.Цена) Тогда

        //    ТекстСообщения = СтрШаблон(

        //        ТекстКолонкаНеЗаполненаШаблон,

        //        МетаданныеДокумента.ТабличныеЧасти.Запасы.Реквизиты.Цена.Синоним,

        //        Стр.НомерСтроки,

        //        МетаданныеДокумента.ТабличныеЧасти.Запасы.Синоним,

        //    );

        //    УправлениеНебольшойФирмойСервер.СообщитьОбОшибке(ЭтотОбъект, ТекстСообщения, "Запасы", Стр.НомерСтроки, "Цена", Отказ);

        //КонецЕсли;
   shuhard
 
14 - 03.05.18 - 10:36
(13) [Но все равно спасибо всем за советы)]
не за что =)
   yanikolay
 
15 - 03.05.18 - 10:42
(0) Как вариант - скидка 100%
   MakaMaka
 
16 - 03.05.18 - 10:51
(0) а зачем? Зачем ставить цену 0?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Я не хочу быть самым богатым человеком на кладбище. Засыпать с чувством, что за день я сделал какую-нибудь потрясающую вещь — вот что меня интересует. Стив Джобс, 1996 г.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует