Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

запись в регистр

запись в регистр
Я
   _barracuda_
 
26.04.18 - 10:43
всем хорошего дня.
Вопросик:При записи формы перестраховываюсь(бывает по пока не ясным причинам не заполняются некторые реквизиты в регистре) так вот при закрытии формы подстарховываюсь и перезаписываю регистры:

НаборЗаписейЗанятыхМест = РегистрыСведений.НомераНаСкалде.СоздатьНаборЗаписей();
НаборЗаписейЗанятыхМест.Отбор.ДатаНачала.Установить(Строка.ДатаНачала);
НаборЗаписейЗанятыхМест.Отбор.ДатаОкончания.Установить(Строка.ДатаОкончания);
НаборЗаписейЗанятыхМест.Отбор.Склад.Установить(Строка.Склад);
НаборЗаписейЗанятыхМест.Отбор.НомерНаСкладе.Установить(Строка.НомерНаСкладе);
НаборЗаписейЗанятыхМест.Отбор.Ответственный.Установить(Строка.Ответственный);
НаборЗаписейЗанятыхМест.Прочитать();
Для каждого Запись Из НаборЗаписейЗанятыхМест Цикл
Запись.Стоимость = Сум;
Запись.НомерСтрокиВТабл=Ном;
КонецЦикла;
НаборЗаписейЗанятыхМест.Записать();


Вопрос.как быть если отбор вообще не сработал и данной записи нет в регистре.получается обновлять нечего а надо записать впервые запись.Спасибо
 
 
   PR
 
1 - 26.04.18 - 10:44
А где вопрос-то?
   Рэйв
 
2 - 26.04.18 - 10:49
(0)Используй менджер записи.
пример:
//---------

Курс = РегистрыСведений.КурсыВалют.СоздатьМенеджерЗаписи();
Курс.Валюта = ВыбВалюта;
Курс.Период = ТекущаяДата();
Курс.Прочитать();
Если Не Курс.Выбран() Тогда
    Курс.Период = ТекущаяДата();
    Курс.Валюта = ВыбВалюта;
    Курс.Курс = 41.35;
    Курс.Кратность = 1;
КонецЕсли;
Если ВвестиЧисло(Курс.Курс, "Введите курс на сегодня",15,5) Тогда
    Курс.Записать();
КонецЕсли;
 

(С) СП
   _barracuda_
 
3 - 26.04.18 - 11:15
(2) ругается что период не заполнен.хотя мне этот период вообще заполнять никак не нужно было ранее
   1Сергей
 
4 - 26.04.18 - 11:26
Если НаборЗаписейЗанятыхМест.Количество() = 0 Тогда
    Запись = НаборЗаписейЗанятыхМест.Добавить();
...
   systemstopper
 
5 - 26.04.18 - 11:34
(0) да пиши от балды чё хочешь, так гарантированно что-то будет

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует