Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Штрих-М Обнуление сумм после печати чека

Штрих-М Обнуление сумм после печати чека
Я
   DenisVich
 
26.04.18 - 10:03
Здравствйте. Есть чек электронно МИР например. Распечатали чек. Потом печатаем наличными чек, но сумма с предыдущего чека при обнулении summ1..summ4 не обнуляется. В чем может быть причина? Спасибо.
 
 
   DenisVich
 
1 - 26.04.18 - 10:03
Т.е. следущий чек наличными берет пропорционально сумму - берет ее из предыдущего чека.
   Kigo_Kigo
 
2 - 26.04.18 - 10:05
Была такая бяка, вылечилось сменой прошивки
   piter3
 
3 - 26.04.18 - 10:05
Может код такой,А не ккм
   piter3
 
4 - 26.04.18 - 10:06
(2) ого,штрих тоже отжигает значит
   DenisVich
 
5 - 26.04.18 - 10:06
ФискальныйРегистраторОбъект.Summ1=0;
    ФискальныйРегистраторОбъект.Summ2=0;
    ФискальныйРегистраторОбъект.Summ3=0;
    ФискальныйРегистраторОбъект.Summ4=0;
   DenisVich
 
6 - 26.04.18 - 10:07
Остальными суммовыми итогами не пользуемся.
   DenisVich
 
7 - 26.04.18 - 10:08
Остальными суммовыми итогами не пользуюсь. Других нету других типов чеков. Прошивка последняя.
   Kigo_Kigo
 
8 - 26.04.18 - 10:14
Может не надо предварительно обнулять, тем более это идет в теле открытого чека
Если ВидОплаты = "Наличными" тогда
ФискальныйРегистраторОбъект.Summ1=Получено;
    ФискальныйРегистраторОбъект.Summ2=0;
    ФискальныйРегистраторОбъект.Summ3=0;
    ФискальныйРегистраторОбъект.Summ4=0;
ИначеЕсли ВидОплаты = "Электроно";

ФискальныйРегистраторОбъект.Summ1=0;
    ФискальныйРегистраторОбъект.Summ2=ПоБанку;
    ФискальныйРегистраторОбъект.Summ3=0;
    ФискальныйРегистраторОбъект.Summ4=0;
Иначе
Сообщить("Не указан вид оплаты")
КонецЕсли;
   DenisVich
 
9 - 26.04.18 - 10:15
(8) Так потом идет:
    Если ТипКарты = Перечисления.ТипыКарт.Mastercard Тогда
        ФискальныйРегистраторОбъект.Summ4=Сумма; 
    ИначеЕсли ТипКарты = Перечисления.ТипыКарт.Visa Тогда
        ФискальныйРегистраторОбъект.Summ3=Сумма; 
    ИначеЕсли ТипКарты = Перечисления.ТипыКарт.МИР Тогда            
        ФискальныйРегистраторОбъект.Summ2=Сумма;
    КонецЕсли;
    ФискальныйРегистраторОбъект.StringForPrinting=ПечатьСтроки;
    ФискальныйРегистраторОбъект.CloseCheck();
    ОтветДрайвера();
   Kigo_Kigo
 
10 - 26.04.18 - 10:18
(9) Вот именно, обнуляй в потом, а не перед, возможно это и есть загвоздка

Если ТипКарты = Перечисления.ТипыКарт.Mastercard Тогда
ФискальныйРегистраторОбъект.Summ1=0;    ФискальныйРегистраторОбъект.Summ2=0;
    ФискальныйРегистраторОбъект.Summ3=0;
        ФискальныйРегистраторОбъект.Summ4=Сумма; 
    ИначеЕсли ТипКарты = Перечисления.ТипыКарт.Visa Тогда
ФискальныйРегистраторОбъект.Summ1=0;
    ФискальныйРегистраторОбъект.Summ2=0;
    
        ФискальныйРегистраторОбъект.Summ3=Сумма; 
ФискальныйРегистраторОбъект.Summ4=0;
    ИначеЕсли ТипКарты = Перечисления.ТипыКарт.МИР Тогда
ФискальныйРегистраторОбъект.Summ1=0;            
        ФискальныйРегистраторОбъект.Summ2=Сумма;
ФискальныйРегистраторОбъект.Summ3=0;
    ФискальныйРегистраторОбъект.Summ4=0;
    КонецЕсли;
 
 Рекламное место пустует
   Kigo_Kigo
 
11 - 26.04.18 - 10:19
А то обнуление убери

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует