Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Передать в параметр СписокЗначений в ПКО Конвертация 2.1

Передать в параметр СписокЗначений в ПКО Конвертация 2.1
Я
   Игорь_МММ
 
25.04.18 - 21:08
нужно передать список групп которым принадлежит элемент Номенклатуры:
Материалы->Плитные->ДСП , передать надо на сторону приемника, чтобы по этим группам присвоить значения ВидНоменклатуры и НоменклатурнуюГруппу, так как их нет в источнике.
пытаюсь засунуть этот список в параметр в ПКО Номенклатура: сделал КС , источник и приемник пустые, передавать в параметр СписокГрупп
СписокГрупп = Новый СписокЗначений; 
ЭлемРодитель = Источник.Родитель;
Если НЕ ЭлемРодитель.Пустая() Тогда
    СписокГрупп.Добавить(ЭлемРодитель.Наименование);
Иначе
    СписокГрупп.Добавить("");
КонецЕсли;

Пока НЕ ЭлемРодитель.Пустая() Цикл
    ЭлемРодитель=ЭлемРодитель.Родитель;     
    Если НЕ ЭлемРодитель.Пустая() Тогда
        СписокГрупп.Добавить(ЭлемРодитель.Наименование);
    КонецЕсли;
КонецЦикла;

В событии ПослеЗагрузки ПараметрыОбъекта=Неопределено. ЧЯДНТ?
можно передать в параметр только источник? Произвольно что-то как передать?
 
 
   VS-1976
 
1 - 25.04.18 - 21:23
(0) Попробуй дописать в коде КС так:
Значение = ЗначениеВСтрокуВнутр( СписокГрупп);

И ПослеЗагрузки

СписокГрупп = ЗначениеИзСтрокиВнутр( ПараметрыОбъекта.Получить( "СписокГрупп" ) );
   Игорь_МММ
 
2 - 25.04.18 - 21:32
(1) девочка сдалась )))) спасибо
   user-ok
 
3 - 25.04.18 - 21:39
нет в источнике и не надо. В приемнике они же по какому-то полю ищутся?
ВидыНоменклатуры и Номенклатурные группы - справочники. ищи по коду
Передавай код в ПКС
в ПКО для вида номенклатуры поиск по коду.
в ПКС для кода Значение = Источник.
Правильней все формировать таки на стороне источника

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует