Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Веб сервис. Service not found.

v7: Веб сервис. Service not found.
Я
   Сержант ВДВ Онегин
 
25.04.18 - 13:43
Решили на сайте организации сделать возможность для каждого сотрудника узнавать по какой причине он получил ту или иную зарплату. И решил воспользоваться веб сервисом.  Создал xdto пакет и веб сервис. В модуле прописал:

[CODE]Функция GetAnswer(DateB, DateE, ID)

    Запрос = Новый Запрос;
    Запрос.Текст = "ВЫБРАТЬ
                   |    КадроваяИсторияСотрудниковСрезПоследних.Сотрудник,
                   |    КадроваяИсторияСотрудниковСрезПоследних.Подразделение
                   |ИЗ
                   |    РегистрСведений.КадроваяИсторияСотрудников.СрезПоследних(&Дата, ) КАК КадроваяИсторияСотрудниковСрезПоследних
                   |ГДЕ
                   |    КадроваяИсторияСотрудниковСрезПоследних.ВидСобытия <> &Увал
                   |    И КадроваяИсторияСотрудниковСрезПоследних.Сотрудник.Код = &Айди";
    
    Запрос.УстановитьПараметр("ДатаНачала", DateB);
    Запрос.УстановитьПараметр("Дата", КонецДня(DateE));
    Запрос.УстановитьПараметр("Айди", ID);
    Запрос.УстановитьПараметр("Увал", Перечисления.ВидыКадровыхСобытий.Увольнение);
    
    ТаблицаРезультат = Запрос.Выполнить().Выгрузить();
    
    EmployeeТип = ФабрикаXDTO.Тип("http://localhost/wsreport";,    "Employee");
    DepartmentТип = ФабрикаXDTO.Тип("http://localhost/wsreport";,  "Department");
    PositionТип = ФабрикаXDTO.Тип("http://localhost/wsreport";,    "Position");
    TableReportТип = ФабрикаXDTO.Тип("http://localhost/wsreport";, "TableReport");
    TableStringТип = ФабрикаXDTO.Тип("http://localhost/wsreport";, "TableString");
    
    TableReport = ФабрикаXDTO.Создать(TableReportТип);

    Для Каждого СтрокаИзТаблицы Из ТаблицаРезультат Цикл
        
        СтрокаТаблицыОтчета = ФабрикаXDTO.Создать(TableStringТип);

        Сотрудник     = ФабрикаXDTO.Создать(EmployeeТип);
        Должность     = ФабрикаXDTO.Создать(PositionТип);
        Подразделение = ФабрикаXDTO.Создать(DepartmentТип);
        
        Если ТипЗнч(СтрокаИзТаблицы.Сотрудник) = Тип("СправочникСсылка.Сотрудники") Тогда
            Сотрудник.Name = СтрокаИзТаблицы.Сотрудник.Наименование;
        Иначе
            Сотрудник.Name = "";
        КонецЕсли;
        Если ТипЗнч(СтрокаИзТаблицы.ПодразделениеОрганизации) = Тип("СправочникСсылка.ПодразделенияОрганизаций") Тогда
            Подразделение.Name = СтрокаИзТаблицы.Подразделение.Наименование;
        Иначе
            Подразделение.Name = "";
        КонецЕсли;

        
        СтрокаТаблицыОтчета.ID = СтрокаИзТаблицы.Сотрудник.Код;
        СтрокаТаблицыОтчета.Employee = Сотрудник;
        СтрокаТаблицыОтчета.Department = Подразделение;        
        TableReport.Content.Добавить(СтрокаТаблицыОтчета);
        
    КонецЦикла;    
    
    Возврат TableReport;
    
КонецФункции[/CODE]


В браузере ввожу http://192.168.61.52/wsreport/ws/ChargingEmployees.1cws выходит ссылка с такой же ссылкой, но когда на нее нажимаю получаю ошибку:

[B]Service not found.
An error occurred processing this request.[/B]

В чем может быть проблема?
 
 
   Сержант ВДВ Онегин
 
1 - 25.04.18 - 13:44
все это происходит на 8.3
   Владимир1С
 
2 - 25.04.18 - 15:25
Админы, перенесите ветку в 1С 8.3 , пожалуйста.
   Сияющий в темноте
 
3 - 25.04.18 - 21:24
насколько я помню,версервис,этл ответ на запрос,а так как вы хотите в ответ страницу,то,наверное,нужно посмотреть в сторону нттп сервиса,и правильно обработать запрос,

у меня только у одного возникает вопрос про авторизацию и персональные данные?
   triviumfan
 
4 - 26.04.18 - 00:15
(3) Зато всё прозрачно =)
   Aleksey
 
5 - 26.04.18 - 02:07
Переходите на ЗУП Корп,  там это реализовано
https://its.1c.ru/db/staff1c#content:34822:hdoc

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует