Вход | Регистрация


Нумератор в пределах месяца для конкретной организации

Нумератор в пределах месяца для конкретной организации
Я
   myr4ik07
 
25.04.18 - 12:07
УТ.
Нумерация должна начинаться с 1 каждый месяц и только для конкретной организации, для всех остальных организаций должна остаться типовая нумерация.

Как это реализовать?
 
 
   cw014
 
1 - 25.04.18 - 12:09
Написать свою
   myr4ik07
 
2 - 25.04.18 - 12:13
снято

Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
    
    СтандартнаяОбработка = Ложь;
    Номер = Нумератор();
    
КонецПроцедуры
   takefive
 
3 - 25.04.18 - 12:14
к префиксу добавлять номер месяца например...
   cw014
 
4 - 25.04.18 - 12:15
Я так думаю, что при периодичности нумератора "Год" наткнешься на такие грабли :-D
   Ненавижу 1С
 
5 - 25.04.18 - 12:16
я за (3)
   myr4ik07
 
6 - 25.04.18 - 12:23
(4) правильно думаешь, сейчас в док нумератор в переделах года, а нужно каждый протсавлять №1 документа, как обойти?
   catena
 
7 - 25.04.18 - 12:41
(6)Префикс добавить, сказали же уже.
   myr4ik07
 
8 - 25.04.18 - 12:54
(7) префикс добавил, в результате ОГ-14, но такожй же номер я не смогу уже присвоить в переделах года
   Serg_1960
 
9 - 25.04.18 - 13:07
(8) Если уж залез в конфигуратор, то копай глубже. Как минимум снимать признак уникальности номеров (писать свою проверку на уникальность номера - программную) + править подписку на событие, где идёт присвоение номеров.
   иубиповец
 
10 - 25.04.18 - 13:10
В (3) же сказали, номер месяца в префикс запулить
те. ОГ1-14 от 21.01
ОГ2-14 от 22.02 и т.д.
:)
Или стандарный номер не трогать, создать реквизит  номер месячный, и для этой организации его заполнять, в печатные формы то же под корректировать вывод из него.
 
 Рекламное место пустует
   myr4ik07
 
11 - 25.04.18 - 13:11
(9) атасец (10 ) да, думал про отдельное поле
   Serg_1960
 
12 - 25.04.18 - 13:17
Ааа... а я подумал, что автора месяц в номере не устраивает.
   catena
 
13 - 25.04.18 - 13:46
(10)По-моему проще наоборот - номер стандартный с префиксом, а пользователю показывать без префикса. Не нужно самостоятельный нумератор мутить, практически все штатною
   xxTANATORxx
 
15 - 25.04.18 - 14:13
номер месяца в префикс добавлять уже предлагали?
   один я дАртаньян
 
16 - 25.04.18 - 14:13
(2) С СФ - не пройдет.
   один я дАртаньян
 
17 - 25.04.18 - 14:15
(6) Меняешь нумератор на день а затем классика:

ПрефиксацияОбъектовБПСобытия
    Процедура УстановитьПрефиксИнформационнойБазыОрганизацииПодразделения
    //{ХХХХ

    //2017 07 19

    //ззззз

    //Задача: У документов установить нумерацию в пределах дня  (длина номера увеличена до 16 знаков)

    //{Добавлено

    Если Источник.Дата>= '20120529' Тогда
        Если ТипЗнч(Источник)=Тип("ДокументОбъект.АвансовыйОтчет") 
            ИЛИ  ТипЗнч(Источник)=Тип("ДокументОбъект.ПриходныйКассовыйОрдер") 
            ИЛИ  ТипЗнч(Источник)=Тип("ДокументОбъект.РасходныйКассовыйОрдер") 
            Или ТипЗнч(Источник)=Тип("ДокументОбъект.РеализацияТоваровУслуг")    Тогда
            элНомерМесяца =СокрЛп(Строка(Месяц(Источник.Дата)));
            элНомерМесяца =?(СтрДлина(элНомерМесяца)<2,"0","")+элНомерМесяца;
            элНомерДня =СокрЛп(Строка(День(Источник.Дата)));
            элНомерДня =?(СтрДлина(элНомерДня)<2,"0","")+элНомерДня;
            Префикс = Префикс+""+элНомерМесяца+элНомерДня+"\";
        КонецЕсли;
    КонецЕсли;
    //Добавлено}

    //ХХХ}

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует