Вход | Регистрация



онлайн-касса Атол fprint 22ПТК подключаю к базе на удаленном сервере

онлайн-касса Атол fprint 22ПТК подключаю к базе на удаленном сервере
Я
   Trance_1C
 
24.04.18 - 11:02
Всем привет!

Пытаюсь подключить к УПП 1.3 аппарат Атол fprint 22ПТК (обработка с драйвером 9.12.0.6076). База установлена на удаленном сервере, хост на котором подключена касса и сервер в одной сети, с сервера тестом драйвера 8.16 я подключался к хосту с кассой, печатал отчет без гашения, т.е. кассу с сервера видно тестом драйвера.
А драйвер из 1С не видит.
Возможно это связано с тем что на хосте с кассой нужно поставить другую версию драйвера?
Тогда какую? под эту обработку с драйвером 1С 9.12.0.6076
 
 
   Trance_1C
 
1 - 24.04.18 - 11:06
сейчас на хосте с кассой и на сервере с базой поставил установщиком версию 8.16.2
для меня не ясен момент, у 1С свой экземпляр драйвера, не тот что установлен в системе, или она использует то что установлено - 8.16.2?
   Trance_1C
 
2 - 24.04.18 - 11:10
АТОЛ:ККТ с передачей данных в ОФД (54-ФЗ) 9.х" до версии 9.12.0.6076

Вот для этого драйвера, какой драйвер нужно ставить на компьютере с кассой?
   Trance_1C
 
3 - 24.04.18 - 11:26
неужели через виндовый терминал никто кассу не настраивал в клиент-серверном режиме?
   Trance_1C
 
4 - 24.04.18 - 11:28
ладно, завтра попробую на хост с кассой 9е драйвера накатить, может в этом проблема...
   dezss
 
5 - 24.04.18 - 11:30
Если обработка с драйвером 9.х, то и на хост надо ставить 9.х.
Это же очевидно. В обработке только dll-ка для работы с кассой через систему, а самой системе тоже дрова нужны.
   Trance_1C
 
6 - 24.04.18 - 11:33
Ок, буду пробовать, еще заметил после установки драйвера в каталоге C:\Program Files (x86)\ATOL\Drivers8\1Cv82\FR-ATOL_54FZ.zip

появляется эта длл в архиве FR-ATOL_54FZ
Это зачем?
   Trance_1C
 
7 - 24.04.18 - 11:34
т.е. это как я понимаю и есть длл драйвера для обработки 1С только она у меня получается старой версии?
   dezss
 
8 - 24.04.18 - 11:40
(6) забей на нее, это старая...когда поставишь 9.х, появится папка Drivers9, там более кошерные дрова. Но я их не пробовал юзать.
   dezss
 
9 - 24.04.18 - 11:41
(7) это для ФФД 1.0, насколько я понимаю. Возможно, с поддержкой тегов 1.05, не проверял, так что ставь 9.х.
   karpik666
 
10 - 24.04.18 - 13:54
(0) раз вы сейчас ставите только ККТ, то значит будете работать на ФФД 1.05, компонента для АТОЛ для печати по ФФД 1.05 работает только на драйверах 9, нужно поставить 9.12.1 - 32-х битные, как на сервере, так и на клиенте, тогда должно все заработать.
Возможна у вас УПП не обновленная, тогда для работы подойдет платное решение http://catalog.mista.ru/public/590993/ , там можно скачать архив компонент для работы с АТОЛ, там самые актуальные.
 
 Рекламное место пустует
   Trance_1C
 
11 - 25.04.18 - 07:21
УПП обновленная, 1.3.105, обработки обслуживания обновил с сайта.
Поставил на сервер с базой драйвер 8.16, и 9.12, на клиенте также.
В базе у меня две обработки обслуживания Атол ККТ, одна с драйвером 9.12, а вторая 8.16.
Удалось в базе подключить кассу с обработкой обслуживания 8.16, чеки печатает.
Но т.к. у меня касса пока не фискализована, ФН оттуда я пока выдернул для тестов, на чеке пишет "Чек недействителен".
С обработкой обслуживания которая использует драйвер 9х кассу не удалось подключить, обработка ее не видит.
   Trance_1C
 
12 - 25.04.18 - 07:42
У драйвера 8.16 есть утилита "Управление драйверами", с ее помощью служба "FDSVC", запускается и мониторит порт 6220, но проблема в том что подключиться к кассе удаленно например к компьютеру 192.168.0.99:6220
Можно только драйвером 8.16 а 9й драйвер не может подключиться к удаленной кассе, или может для 9го есть своя утилита "Управление драйверами"?????
   Trance_1C
 
13 - 25.04.18 - 07:52
   Trance_1C
 
14 - 25.04.18 - 08:14
(10) атоловские драйвера поддерживают работу кассы в клиент-серверном режиме, что позволит подключиться к одной кассе нескольким кассирам, что мне и нужно.
   karpik666
 
15 - 25.04.18 - 08:24
(12) не работает, потому что не поставили, нужно ставить 9.12.1 32х битные. А вообще уточните у Атол есть ли такая возможность для драйверов 10 версии, в принципе можно использовать компоненту для них
   Tatitutu
 
16 - 25.04.18 - 09:10
(10)
"компонента для АТОЛ для печати по ФФД 1.05 работает только на драйверах 9"

- не вводите людей в заблуждение
   Trance_1C
 
17 - 25.04.18 - 09:14
(12) А существующая обработка будет поддерживать 10ю версию?
   Trance_1C
 
18 - 25.04.18 - 09:15
(16) Если с обработкой которая использует 8.16 в формате 1.05 будет печатать то отлично, потому-что у меня с этой обработкой печать чеков идет.
   Trance_1C
 
19 - 25.04.18 - 09:15
(15) именно такие и поставил и на клиенте и на сервере
   Trance_1C
 
20 - 25.04.18 - 09:16
вместе с ними 8.16, и там и там, и только драйвер 8.16 открывает порт 6220 и публикует кассу как сетевую на хосте.
   Trance_1C
 
21 - 25.04.18 - 09:18
так стоит мне заморачиваться с 9м драйвером, если печать чеков идет с обработкой на 8.16?
   karpik666
 
22 - 25.04.18 - 09:19
(16) очень интересно, и где я ввожу в заблуждение? Компонента 1С для работы с АТОЛ, ее последняя версия сейчас только NATIVE, и работает только на драйверах АТОЛ 9-й версии, есть COM компонента, вот она для драйверов 8-й версии, однако она не поддерживает ревизию интерфейса 2002, и потому передает информацию только для ФФД 1.0. Если работать с драйверами АТОЛ напрямую, то можно использовать и версию 8 для работы с ФФД 1.05, однако я про драйвера ничего и не говорил.
   Сияющий в темноте
 
23 - 25.04.18 - 09:22
он не кассу публикует,а службу управления оборудованием,и все оборудование,которое через нее подключено,становится доступным
главное,чтобы антивирус эту службу не убил,так как она,по сути,троян,т.к.выполняет любые действия по команде подключенного клиента и без всякой авторизации
   karpik666
 
24 - 25.04.18 - 09:24
(21) если планируете использовать ФФД 1.05, то да. В стандартной обработка от 1С сейчас не использует драйвера 10-й версии, пока их можно опробовать только в обработке, которую я привел выше.
также можно поискать решения. которые работают с драйверами напрямую как выход.
   Trance_1C
 
25 - 25.04.18 - 09:28
При установке драйвера, есть галочка "Интеграционная компонента подключаемого оборудования 1Сv83"
это архив с длл которые лежат после установки в папке 
"C:\Program Files\ATOL\Drivers9\KKT\1Cv83\ATOL_KKT_9.zip"

Именно эта длл загружается в макет обработки обслуживания которая затем добавляется в справочник обоработок обслуживания в базе?
Например у обработки "ATOLkkt.epf" в макете сохранена длл, это она?
   Trance_1C
 
26 - 25.04.18 - 09:29
пробовал зарегистрировать эту длл командой regsvr32, не регистрируется, пишет ошибку точки входа...
   karpik666
 
27 - 25.04.18 - 09:33
(25) да, это они, это Native компоненты, они не регистрируются командной regsvr32
   Trance_1C
 
28 - 25.04.18 - 09:39
Я пробовал заменить эту длл в макете обработки с драйвером 9.12, в ей длл версии 9.12.0.6076, а новая 9.12.1.6236  при открытии ничего не изменилось, в заголовке все равно пишет старую версию.
   karpik666
 
29 - 25.04.18 - 09:45
(28) возможно закешировалась, точно не помню, но кажется в типовой в макете с компонентой находится zip архив
   Trance_1C
 
30 - 25.04.18 - 10:01
да закешировалась, добавил новую обработку в справочник и в диалоге тестирования оборудования номер версии длл обновился, и показывает 9.12.1.6236
т.е. длл подгрузилась и вернула свою версию. Но мне это не помогло, удаленная касса по-прежнему не видится...
   Trance_1C
 
31 - 25.04.18 - 10:03
В документации есть ссылка на документ который не могу найти:

Если необходимо, то в поле Компьютер: укажите сетевое имя ПК, к COM-порту которого
подключена ККТ. Если поле пустое, то считается, что ККТ подключена к данному ПК.
Эта настройка используется только при сетевом использовании ККТ и требует
конфигурирования ОС (см. документ «Драйверы торгового оборудования. Руководство и
подключение», Приложение 3 (документ входит в комплект поставки)).
   Trance_1C
 
32 - 25.04.18 - 10:04
см. документ «Драйверы торгового оборудования. Руководство и
подключение», Приложение 3 (документ входит в комплект поставки).
   Trance_1C
 
33 - 25.04.18 - 10:04
В комплект какой поставки он входит? у меня касса пришла в коробке без какой-либо документации, на сайте у них такого нет.
 
 
   Trance_1C
 
34 - 25.04.18 - 10:06
Вот мне как раз и нужно сетевое использование ККТ, кто нибудь видел этот документ: «Драйверы торгового оборудования. Руководство и
подключение», Приложение 3
   karpik666
 
35 - 25.04.18 - 10:15
   Trance_1C
 
36 - 25.04.18 - 11:08
на форме атол нашел ветку с подобным вопросом, саппорт атола пишет что 9й драйвер вообще не поддерживает работу с удаленным портом 6220, т.е. клиент-серверная модель работы с кассой невозможна.
http://forum.atol.ru/index.php?showtopic=33567

Придется брать сервер ККМ http://catalog.mista.ru/public/544687/
   Trance_1C
 
37 - 25.04.18 - 11:09
Еще раз переспрошу если у меня ФФД ККТ 1.05
(формат фискальных данных)
Точно нельзя с драйвером 8.16 чеки печатать? что с ними не так?
   karpik666
 
38 - 25.04.18 - 11:15
(37) а вы уверены, что сервер ккм не работает на этих драйверах?
Просто компонента, которая работает как буфер между Атолом и 1С с ними не работает, вот и вся проблема.
Уточните лучше у АТОЛ 10 версия драйверов поддерживает порт 6220?
   Trance_1C
 
39 - 25.04.18 - 11:45
9я и 10я не поддерживают, там даже при установке нет таких утилит.
   Trance_1C
 
40 - 25.04.18 - 11:52
(38) С сервером ККМ пока не ясно, поддерживает ли он вообще ффд 1.05 у него на страничке об этом ни слова, ясно что печать чеков будет, а будут чеки с полями ффд 1.05 или нет неизвестно.
Не понял, какая компонента - буфер между атолом и 1С?
в драйвере 8.16 есть утилита которая поднимает службу "FDSVC" и обеспечивает сетевой интерфейс на порту 6220 благодаря которому и была возможна клиент-серверная модель, эта утилита привязана к версии драйвера. Как говорят в атол, драйвер 8.16 и драйвер 9.1 это разные продукты, там разная архитектура, 10, это тоже другой продукт...
   Trance_1C
 
41 - 25.04.18 - 11:53
поэтому не получается поднять службу "FDSVC" средствами драйвера 8.16 и пулять туда чеки из 9.1
   karpik666
 
42 - 25.04.18 - 12:40
(40) современная 1с не работает напрямую с драйверами, а работает через шины, которые предоставляю производители оборудовани, в данном случае сама эта шина завязана на драйверах 9-й версии, поэтому и не работает. Шина для 8-й версии работает только для ффд 1.0, поэтому также не подходит.
Вам стоит поискать решения, которые напрямую работают с драйверами без этих компонент.
   ildary
 
43 - 25.04.18 - 12:52
(42) извините, почему шина драйвера 8 не работает для ФФД 1.05? Или речь идет только о 1с8? Потому что в 7.7 драйвер 8 работает с ФФД 1.05
   karpik666
 
44 - 25.04.18 - 13:08
(43) Драйвера Атол 8 работают с ФФД 1.05, не работает сама компонента, которая используется в 1С для подключения и печати через АТОЛ, компоненты разработаны по данному формату https://its.1c.ru/db/metod8dev#content:4829:hdoc:chapter270 , и к сожалению для АТОЛ 8 версии нет компоненты, которая работает по формат ФФД 1.05
   Trance_1C
 
45 - 26.04.18 - 07:08
Коллеги подскажите кто знает, если касса прошита на ФФД 1.05, т.е. у нее в "Информация о ККТ" указано 
ФФД ККТ  1.05
с нее можно печатать чеки в ФФД 1.0? что и позволяет делать 8.16 драйвер, эти чеки пока в законе до 01.01.2019, так что я мог бы и в этом формате ее запустить.
   Trance_1C
 
46 - 26.04.18 - 08:30
(43) А в какой типовой конфигурации 77 обработка для 8.16 драйвера работает в формате ФФД 1.05?
   Trance_1C
 
47 - 26.04.18 - 08:31
Торговля и склад? она что еще поддерживается?!
   Сияющий в темноте
 
48 - 26.04.18 - 09:34
Восьмой драйвер умеет ффд105,поэтому все вопросы к 1с,можно,конечно и самому дописать
   Kigo_Kigo
 
49 - 26.04.18 - 10:44
(44) Есть в последней ТиС
 
 Рекламное место пустует
   Trance_1C
 
50 - 27.04.18 - 04:54
Переключил кассу на канал обмена по Ethernet и это решило мою проблему, в режиме TCP/IP (клиент) кассу видят обе версии драйвера и 8.16, и 9.1, я думаю и 10ка увидит.
К сожалению, печать чека идет очень медленно, это связано с тем что у меня доступ к базе через интернет, база на VPS за границей.
   karpik666
 
51 - 27.04.18 - 11:00
(50) говорят, что 9-я версия сама по себе глючная, на всякий случай попробуйте 10-ю
   dezss
 
52 - 27.04.18 - 11:12
(51) Кто говорит (я вроде слышал, что такое говорили про 10)?
Для меня это очень актуальный вопрос.
А есть компонента для 1с, которая работает через дрова 10.х, без работы напрямую с драйвером?
   karpik666
 
53 - 27.04.18 - 11:36
(52) вот здесь https://forum.infostart.ru/forum81/topic189867/
компонента есть, она лежит в драйверах АТОЛ, но стандартные обработки ее не поддерживают,я там выше приводил ссылку, что компоненту можно подключить к платной обработке http://catalog.mista.ru/public/590993/, достаточно добавив ее в каталог с компонентами, и сменив название по шаблону.
   dezss
 
54 - 27.04.18 - 11:41
(53) да я уже написал под 9.х, мне стандартных не надо
просто для справки и для перехода, если будет критично...
   dezss
 
55 - 27.04.18 - 11:44
(53) хм...хз...у меня такой задержки нет.
хотя компонента та же.
   Сияющий в темноте
 
56 - 27.04.18 - 12:18
Если печать идет медленно и канал фиговый,то придется дописывать отправку xml с данными чека на компьютер,куда подключить регистратор,и уюе там пусть он этот чек печатает,будет явно быстрее,но нужно немного попрограммировать
   dezss
 
57 - 27.04.18 - 12:23
(56) думаешь, отправка кодом будет быстрее, чем отправка драйвером?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует