Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Подскажите как получить итоги по каждому счету отдельно?

v7: Подскажите как получить итоги по каждому счету отдельно?
Я
   sysadminlk
 
20.04.18 - 15:24
Процедура Сформировать()
    
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");       
    Ит.ИспользоватьСубконто(ВидыСубконто.Подразделение,,1);
    
    Счета = СоздатьОбъект("СписокЗначений");
    Счета.ДобавитьЗначение(СчетПоКоду("76.1"));
    Счета.ДобавитьЗначение(СчетПоКоду("46.2"));
    Ит.ИспользоватьСубконто(ВидыСубконто.Контрагенты,,1);
    Ит.ВыполнитьЗапрос(, ТекущаяДата(), Счета,,,1,"Операция" );
    Ит.ВыбратьСубконто(1); 
    Пока Ит.ПолучитьСубконто(1)=1 Цикл
        Ит.ВыбратьСубконто(2);
        Пока Ит.ПолучитьСубконто(2)=1 Цикл
            Если СокрЛП(Строка(Ит.Субконто(2))) <>"Comp" Тогда
                Продолжить;
            КонецЕсли;
            сал1=Ит.СКД("76.1")-Ит.СКК("76.1"); 
            сал2=Ит.СКД("46.2")-Ит.СКК("46.2");
            Сообщить(""+сал1+" -- "+сал2+" -- "+Ит.Субконто(2)+"");
        КонецЦикла;
    КонецЦикла;
    
КонецПроцедуры

Почему получается что сал1 и сал2 одинаковые и это сумма по обоим счетам? Подскажите как получить итоги по каждому счету отдельно?
 
 
   Cool_Profi
 
1 - 20.04.18 - 15:26
Создать тз (счет, сал1, сал2) и в неё пихать
   sysadminlk
 
2 - 20.04.18 - 15:28
:(( я думал можно как-то одним запросом разрулить
   Провинциальный 1сник
 
3 - 20.04.18 - 15:32
ВыбратьСчета()
И потом цикл ПолучитьСчет()
   sysadminlk
 
4 - 20.04.18 - 16:23
(3) спасибо!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует