Вход | Регистрация

  1  2
1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: 1С 7.7 и онлайн кассы (online кассы) (закон 54-ФЗ) ЧАСТЬ 3

v7: 1С 7.7 и онлайн кассы (online кассы) (закон 54-ФЗ) ЧАСТЬ 3
Я
   Санта Клаус
 
20.04.18 - 15:00
предыдущая ветка здесь:https://www.forum.mista.ru/topic.php?id=794196&page=1


Добрый день!
Есть такой вопрос: в этом году нужно будет обновлять прошивку ФР, так понял, для того, чтобы с НГ работала передача данных. Как сказали в сервисном центре, с новой прошивкой будет работать только драйвер Атол 9.х.

Вопросы:

- в 7.7 будет ли работать на старом драйвере FprnM1C82_54FZ.dll, или нужно ждать новый. Может он уже вышел. Кто заморачивался?

- в 1С 8.х нужно ли обновлять релизы до актуального, чтобы работала с драйвером 9.х?
 
 
   Peng
 
101 - 04.07.18 - 10:21
Прошу помощи! Сам уже заколебался.
Имеется ТиС + Атол30Ф, с обработкой frATOL54_comm, аппарат работает, только не могу заставить печатать "без НДС".
Решил попробовать frATOL54_comm_105.ert, с ним фискальник подключается, но печатать не хочет, пишет что: "Фискальный регистратор: ошибка при печати чека. Нет связи". Подскажите что не так делаю?
   Peng
 
102 - 04.07.18 - 10:25
Такая же ошибка с обработкой fr_comm.ert. Хотя тут же меняешь frATOL54_comm, чеки начинает печатать
   Амулет
 
103 - 04.07.18 - 10:50
(100) В процедурах вашего мышления имеются логические ошибки, которые привели к неверному уяснению содержания нормы закона.

Вывод о применимости данной нормы только для расчетов в сфере ЖКХ является необоснованным.
Этот вид расчетов является самостоятельным основанием для отсрочки на год применения ККТ.

Это вытекает из результатов применения синтаксического метода толкования нормативного акта, в ходе которого должно учитываться, что элементы перечисления разделены запятыми, а слово "расчетов" употреблено повторно (в первом значении перечисления- расчеты с физическими лицами, во втором- расчеты при приеме платы за услуги ЖКХ).
   ildary
 
104 - 05.07.18 - 16:02
Не смог найти возможность победить закрытие смены системным администратором, в итоге сделал так: в настройках кассы в списке кассиров заменил кассира Администратор (пароль 29) на своего кассира (+ИНН), а в обработке frATOL54_comm_105.ert в
процедуре ЗакрытьСмену() заменил строку

Объект.Password = ПарольАдминистратора; 

на
Объект.Password = "29";

теперь открытие смены печатается нужный кассир + ИНН. Осталось победить первый чек.
   Duke1C
 
105 - 16.07.18 - 10:14
Спрошу здесь, чтоб новую тему не создавать:
Обязательно ли по закону печатать в чеке сумму наличных, полученных от клиента и сумму сдачи?
   Garykom
 
106 - 16.07.18 - 12:57
(105) Нет не обязательно, обязательна только сумма расчета
   edw
 
107 - 17.07.18 - 09:18
Вопрос по драйверу DrvFr. У меня 3-4 раза в день выдаёт "СОМ порт занят другим приложением" и продавцы просто перегружают 1С.
  В описании драйвера сказано, что состояние драйвера нужно отслеживать самостоятельно и дожидаться "правильного" состояния. Видимо гоняя в цикле некоторую функцию до получения нормальной связи. Какую функцию надо гонять?
   skillhoster
 
108 - 19.07.18 - 17:36
Привет всем!
Используем Торговлю 77 - 997.
Подключен Атол 22ф, перепрошили на ффд 1.05, поставили драйвера 8.16.3, зарегали компоненту FprnM1C82_54FZ.dll, работаем через FprnM45, все хорошо все работает с обработкой из последнего релиза, которую сделал Атол, единственное -  подшаманили со скидками и номером чека (по умолчанию не вытаскивается в их обработке).

Но вот незадача - ставка НДС печатается в конце чека, это хорошо, но продавцы орут благим матом и требуют ставку и сумму ндс после каждой строки. Перерыл драйвер не нашел - может кто знает, может в какой таблице надо в каком нибудь поле что нибудь подставить, или по рабоче-крестьянски печатать строки через драйвер после каждой регистрации (Объект.Registration())?
   Garykom
 
109 - 19.07.18 - 17:42
(108) >ставка НДС печатается в конце чека, это хорошо, но продавцы орут благим матом и требуют ставку и сумму ндс после каждой строки

покажи картинку со стрелочками что не так
   skillhoster
 
110 - 19.07.18 - 17:46
(101) советую обновиться на 997.
в настройке торг оборудования выбрать модель с 1.05 на конце (из установки 997 из папки equip надо все скопировать в вашу папку equip)
поставить атол не ниже 8.16.1.

и главное - не забыть нажать на кнопку Параметры подключения (на закладке ФР) - и снова правильно указать модель, ком-порт и т.п.

Ну а потом разгребать косяки описанные мной в (108)
 
 Рекламное место пустует
   Kigo_Kigo
 
111 - 19.07.18 - 17:52
(108) А для перепрошивки под 1.05 ФН меняется?
Я так думаю что надо убирать из обработки обслуживания команду .Department = 1(то есть везде указывать)
А для налога использовать
// TaxTypeNumber - Номер налога:

//     0 - Налог из секции
//     1 - НДС 0%

//     2 - НДС 10%
//     3 - НДС 18%

//     4 - НДС не облагается
//     5 - НДС с расчётной ставкой 10%

//     6 - НДС с расчётной ставкой 18%
driver.TaxTypeNumber = 4;
   Kigo_Kigo
 
112 - 19.07.18 - 17:54
сейчас настроенно в 1с именно налог из секции, вот по секции в целом и выдает итог НДС, я так думаю, есди для каждого товара командой TaxTypeNumber  указывать налог, то должно получиться
   skillhoster
 
113 - 20.07.18 - 09:21
(112) сейчас вот так прописано

Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл
            
    Объект.Name = СписокТоваров.ТовНаим;
    Объект.Price = СписокТоваров.Цена;
    Объект.Quantity = СписокТоваров.Количество;
    Если СписокТоваров.СтавкаНДС = "none" Тогда
        Объект.TaxTypeNumber = 4;
    ИначеЕсли СписокТоваров.СтавкаНДС = "18" Тогда
        Объект.TaxTypeNumber = 3;
    ИначеЕсли СписокТоваров.СтавкаНДС = "10" Тогда
        Объект.TaxTypeNumber = 2;
    ИначеЕсли СписокТоваров.СтавкаНДС = "0" Тогда
        Объект.TaxTypeNumber = 1;        
    КонецЕсли;

    Если ПризнВозврата = 0 Тогда
        Если Объект.Registration() <> 0 тогда
            ОписаниеРезультата = Объект.ResultDescription;
            Возврат Рез;
        КонецЕсли;
    Иначе    
        Если Объект.Return() <> 0 тогда
            ОписаниеРезультата = Объект.ResultDescription;
                 Возврат Рез;
        КонецЕсли;
    КонецЕсли;
            
КонецЦикла;


(109) скан будет чуть позже
   skillhoster
 
114 - 20.07.18 - 09:38
   Сияющий в темноте
 
115 - 20.07.18 - 12:45
Не знаю как Атол,но Штрих в последней прошивке добавил печать налогов,которой в декабрьской просто не было
   Garykom
 
116 - 20.07.18 - 12:58
(114) Справа ваш чек без ставок НДС для каждой позиции так?

У вас форма чека в ККТ (там внутри шаблоны задаются и есть их редактор) настроена нестандартная или какая то галочка типа "выводить ставки НДС для позиций" снята.

Нестандартную форму(шаблон) чека для экономии бумаги делают, чтобы чеки покороче были.
   skillhoster
 
117 - 20.07.18 - 16:03
(116) да вот в том и дело что ищут пожарные ищет милиция "выводить ставки НДС для позиций" и никак не могут найти. самый прикол в том, что до перепрошивки, и до обновления драйвера ставка ндс и сумма ндс печатались под каждой строкой, цто божатся что ничего не трогали.
   skillhoster
 
118 - 20.07.18 - 16:23
(115) вот у меня тоже теплится надежда, что может в прошивке дело, может все решится скоро само собой
   Garykom
 
119 - 20.07.18 - 16:31
(117) TemplateEditor
Редактор шаблонов для онлайн-касс
   Garykom
 
120 - 20.07.18 - 16:32
(119) Это у атол, про другие не в курсе.
Могли при прошивке другие шаблоны залить.
   skillhoster
 
121 - 20.07.18 - 16:45
(119) это наверное 9-е или 10-е дрова нужны да? в восьмых что то не нашел.
   Garykom
 
122 - 20.07.18 - 17:08
(121) редактор шаблонов отдельно от дров качается с сайта атол
   Garykom
 
123 - 20.07.18 - 17:09
(121) в дровах только номер шаблона в настройках указываем
   Масянька
 
124 - 20.07.18 - 17:29
(117) В таблицах во всех рылся?
У штриха запихнули в рег. настройки (таблица 17, поле 16 печать в каждой операции).
   skillhoster
 
125 - 20.07.18 - 17:35
(122) спасибо, буду курить редактор
   skillhoster
 
126 - 20.07.18 - 17:36
(124) где бы надыбать описание таблиц атола
   Масянька
 
127 - 20.07.18 - 17:38
А у Штриха есть :) (это специально для (123)).
   Масянька
 
128 - 20.07.18 - 17:38
(126) В инете поройся. У меня нет.
   hhhh
 
129 - 20.07.18 - 17:40
(126) в законе четко указано, что сумма НДС печатается в итоге. ТО что нужно в каждой строчке, в законе нет. Поэтому в атоле вы ничего не найдете. Придется самим вручную ваять чек.
   Garykom
 
130 - 20.07.18 - 17:41
(129) Там проблема что ставки НДС для товаров-позиций не указаны
   hhhh
 
131 - 20.07.18 - 17:43
(130) да, не прочитал. Ставка нужна.
   Масянька
 
132 - 20.07.18 - 17:44
Меня (лично) бесит буква налога.
Какой идиот это придумал?
   Garykom
 
133 - 20.07.18 - 17:55
(132) буква чего? налога?
 
 
   Масянька
 
134 - 20.07.18 - 17:56
(133) Да!
Строчка с товаров и после суммы _А (_Г).
   Said_We
 
135 - 20.07.18 - 20:30
shtrihfr_comm.ert для версии драйвера 4.14 существует?
   Сияющий в темноте
 
136 - 20.07.18 - 22:56
Букву налога придумали болгары,а так как Штрих м на них вырос,то и все так и осталось.
   Сияющий в темноте
 
137 - 20.07.18 - 22:58
и у атол и у штрих м сначала налоги печатались,потом кто то решил,что они не нужны,и они стали печататься в конце,а потом их вернули,смотрите последнюю прошивку атола,они там должны быть
   Said_We
 
138 - 21.07.18 - 14:12
shtrihfr_comm.ert для версии драйвера 4.14 существует?
   skillhoster
 
139 - 21.07.18 - 15:41
(138) от штриха есть только frSHTRIH54_comm.ert с поддержкой 54 фз. на ккт с ффд 1.05 юзать не пробовал ее, скорее всего не будет работать должным рбразом. по идее ШТРИХ должны выпустить обновление, как сделал АТОЛ.
   skillhoster
 
140 - 21.07.18 - 15:47
(137) ок учту, потому-что в шаблоне чека все норм, все типовое. похоже дело действительно в прошивке.
   Said_We
 
141 - 21.07.18 - 15:55
(139) И как народ запускает онлайн кассы на 77?
   skillhoster
 
142 - 21.07.18 - 16:04
(141) о, да легко. у атола сначала была обработка по типу как сделано в 8 с формированием xml файла, а в последней версии напрямую к объекту драйвера обращается. все шевелится работает отправляется в офд. и поверьте она за 3 минуты читается и понимается с экрана без отладки в отличие от )))
дешево и сердито
   Said_We
 
143 - 21.07.18 - 17:25
(142) Не пойму. В 1с8 чаще всего поменяли кассовый аппарат и не заметили, а тут что-то делать нужно?
   Злопчинский
 
144 - 21.07.18 - 17:29
(141) как обычно. поставил, настройки указал, в нетиповом пару строк вписал и все...
http://catalog.mista.ru/public/603118/
   Said_We
 
145 - 21.07.18 - 18:18
(144) Ща взял чистую машину. Установил туда 4.14. Запустил деммо версию для 7.5, которая идет с этим драйвером. Сконвертировал в 77. Запустил в режиме предприятие. Написала что драйвера найдены. Закрыл, запустил заново. И уже драйвера не найдены.
Там отчет "Старт" В нем две кнопки.

По нажатию на первую кнопку:
FR = СоздатьОбъект("AddIn.DrvFR"); 
{Отчет.Старт.Форма.Модуль(5)}: Неудачная попытка создания объекта (AddIn.DrvFR)

По нажатию на вторую кнопку:
Ошибка при загрузке компоненты C:\Program Files (x86)\SHTRIH-M\DrvFR 4.14\Samples\1C\1C 7.5\DrvFR.dll. Компонента не загружена.
Внешняя компонента Драйвера фискального регистратора - DrvFR.dll не найдена
   skillhoster
 
146 - 22.07.18 - 09:16
(145) смотрите подключение в обработке frSHTRIH54_comm.ert

там работает через AddIn.SMDrvFR1C20
   skillhoster
 
147 - 22.07.18 - 09:19
(143) ))))))) вот никогда такого не было с последними нововведениями, то неправильные ставки налогов, то не воспринимает скидки, то одно, то другое, то поставьте у атола девятые драйвера, то перепрошейте кассу, а потом ой не та прошивка, новая будет скоро.
но когда-нибудь, согласен, так и будет - что замена кассы не будет вести к катастрофическим последствиям.
   skillhoster
 
148 - 22.07.18 - 09:28
(145) а, пардон вы хотите через DrvFr - тогда на всякий случай сделайте regsvr32 к файлу компоненты, и скопируйте DrvFR.dll, DrvFR.lic, sqlite3.dll в каталог бд или в bin платформы. должно помочь.
   Масянька
 
149 - 23.07.18 - 08:33
(145) DrvFR.dll - это (по крайней мере для новых касс) dll из драйвера на кассу.
Сначала ставишь драйвер (она и регистрирует dll), а потом 3 файлика копируешь в bin.
У меня используется для штриха elves.ert. Для начального запуска - переписать 1-2 строчки. Далее - простор для извращенной фантазии :)))
И кушаешь печеньки (как любит говорить Ё :) ).
 
 Рекламное место пустует
   ildary
 
150 - 23.07.18 - 10:42
Удалось победить непечать ИНН кассира в первом после открытия чека (драйвер Атол 8.16, обработка frATOL54_comm_105.ert), надо просто повторно его установить после открытия смены, примерно так:

        // входим в режим регистрации (типовой код)

        Объект.Mode = 1;
        Если Объект.SetMode() <> 0 тогда
            ОписаниеРезультата = Объект.ResultDescription;
            Возврат Рез;
        КонецЕсли;
                //Добавленный код

        Если СессияОткрыта <> -1  Тогда
            
            Объект.OpenSession();
            
            Если ПустоеЗначение( ИННКассира ) = 0 Тогда// почему то сбивается

                
                Объект.AttrValue = ИННКассира;
                Объект.AttrNumber = 1203;
                Объект.WriteAttribute();
                
            КонецЕсли;
            
        КонецЕсли;
   Said_We
 
151 - 23.07.18 - 17:46
(149) драйвер устанавливается, но при попытке вручную его зарегистрировать regsvr32 драйвер не регистрируется. Нет говорит такого файла. А файл есть.
   Масянька
 
152 - 23.07.18 - 17:51
(151) Да, не надо его регистрировать вручную!!!!
Поставили драйвер - драйвер кассу видит - dll скопировали в bin эски.
   Kigo_Kigo
 
153 - 23.07.18 - 18:47
(152) Или в базу, я вообще все файлы из каталога bin штриха копирую, за исключением папок, ДДЛ-ку надо регистрировать на win 7-ке и выше так,копируем все файлы в папку с базой, без них она не зарегистрируется, делаем бат файл, в него пишем строку регистрации, путь к базе обязательно в двойных кавычках и запускаем от имени администратора, жолжно все взлететь
   Said_We
 
154 - 23.07.18 - 23:35
Делал я и в базу. И в бин и в корневик на с. Без разницы. Службу драйвера перезапуска.
   Масянька
 
155 - 24.07.18 - 08:31
(154) И так...
1. Установил драйвер -> проверить, что кассу видит.
2. Три файла (DrvFR.dll, DrvFR.lic и 1sqlite.dll) из папки с драйвером копируем в Bin эски.
3. Настраиваем торговое оборудование (примерно так - https://pastenow.ru/c9cba6cf7c4499b6d20fa3fa46c23ace) -> жмем "Подключить" (!!!!).
   skillhoster
 
156 - 25.07.18 - 16:43
Народ, как всем известно наше дорогое (в буквальном смысле этого слова) правительство планирует вернуть ставку НДС в 20% с первого квартала 2019. Есть какие-то предположения, слухи, инсайд - обойдется все заменой драйверов, или все придется опять шить?
   Масянька
 
157 - 25.07.18 - 16:44
(156) Слухи: шить. Там в аппарате сидит.
Подчеркиваю - слухи.
   Said_We
 
158 - 25.07.18 - 16:55
(155) Да всё это делал. Но реально уже не знаю после какого раза переустановки, перезапуска и перезагрузки заработало.
Сейчас работает. Предположу, что дело в винде.
В (145) "Взял чистую машину" - это условно чистая машина. Машина на которой не стоял драйвер ККМ никогда. Другой под рукой не было.
   Garykom
 
159 - 25.07.18 - 16:58
(157) Радуйся если просто шить а не замена ФН причем внеочередная.
   ildary
 
160 - 25.07.18 - 16:58
(157) Получается что в декабре две засады - НДС20% и запрет с января ФФД1.0.
   ildary
 
161 - 25.07.18 - 16:59
(159) Помнится, некоторые сети магазинов покупали кассы с памятью на 3 года.
   Garykom
 
162 - 25.07.18 - 17:02
(161) Если ставки НДС приколочены намертво в ФН то фигня, если же приколочены то проблема даже кто на ЕНВД.

Точнее тем кто комиссией торгует потому что там надо ИНН комитента  указывать его СНО и ставку НДС.
   Garykom
 
163 - 25.07.18 - 17:02
(162) *не приколочены намертво в ФН
   Масянька
 
164 - 25.07.18 - 17:04
(159) (160) Кто-то обещал, что будет легко?
   Сияющий в темноте
 
165 - 25.07.18 - 21:14
Фн,то вынесет новые поля,но в ФФД написано ставка НДС 18%,понятно,что туда можно 20 записать без проблем,но будет несоответствие.
ФН помнит только тег и его тип,так что,возможно,замены фн удастся избежать
   Said_We
 
166 - 27.07.18 - 02:35
Для DrvFR.dll какой метод или свойство указывает ФИО кассира, что бы в ОФД передался нормально параметр "CashierName"?

Или при открытии по паролю определяет кассира прописанного в параметрах драйвера и берет его? Если так, то это же бред. Продавцы меняются чаще чем есть возможность пароли менять.
   Aleksey
 
167 - 27.07.18 - 04:27
(166) Это для какого? (атол, штрих, вики, шмики)
   skillhoster
 
168 - 27.07.18 - 08:25
(166)

Объект.AttrValue = Кассир;
Объект.AttrNumber = 1021;
Объект.WriteAttribute();
   skillhoster
 
169 - 27.07.18 - 08:34
(166)
Объект.AttrValue = ИННКассира;
Объект.AttrNumber = 1203;
Объект.WriteAttribute();
   Said_We
 
170 - 27.07.18 - 08:47
(167) Для Штриха.
(168, 169) Это для Штриха?
   Said_We
 
171 - 27.07.18 - 08:48
(169) ИНН кассира для чего?
   tgu82
 
172 - 27.07.18 - 09:06
(170) По-моему это для Атола. Для штриха похоже вроде бы
   Санта Клаус
 
173 - 27.07.18 - 10:01
Подскажите, кто знает, по такому вопросу:
Сейчас надо пробивать Расход по кассе не только Возвраты, но и  оплату за услуги сторонним ИП, например.
В обработке есть только параметр, кот. выдает на кассе Возврат прихода. Можно ли в 7.7 пробить операцию Расхода, отличную от возврата, или надо ждать обновления драйвера? И вообще, в ФР Атол есть несколько операций расхода?
   Said_We
 
174 - 27.07.18 - 11:07
(172) Для Штриха я нашел только методы "WriteTable" и "ReadTable".

Метода "WriteAttribute()" не нашел.
   Масянька
 
175 - 27.07.18 - 11:22
(174) Как вариант (не пробовала):
1. таблицы (в драйвере) - 2. Пароли кассиров и админов: завести кассира (ФИО) и пароль.
2. в обработке передавать пароль кассира, а не админа.
   skillhoster
 
176 - 27.07.18 - 12:08
(170) Атол
   skillhoster
 
177 - 27.07.18 - 12:14
(166)
Объект.Пароль = 30;
Объект.НомерТаблицы = 2;
Объект.НомерПоля    = 2;  
Объект.ПолучитьСтруктуруПоля();
Объект.НомерРяда = Пароль;
Объект.ЗначениеПоляСтрока = "Кассир: "+ОбщиеПараметры.Кассир;
Объект.ЗаписатьТаблицу();
   skillhoster
 
178 - 27.07.18 - 12:15
(166) (177) это для штриха
   skillhoster
 
179 - 27.07.18 - 12:20
(173) есть предположение (для атола), надо ручками дописывать код обработки, используя методы beginItem() и endItem()
в них можно гибко настроить предмет расчета тип расчета и т.п. по ФФД 1.05. надо курить описание драйвера в общем.
   Масянька
 
180 - 27.07.18 - 12:29
(175) Именно - попробовала - арбайтэн.
В обработке печати в ПечататьЧек - пароль кассира.
В глобальнике в глФРПечататьЧек -         Параметры.Установить("ПарольПользователя", "1"); - ну, тут нужен пароль кассира, как в драйвере (мне вилы было искать где его менять).
   Масянька
 
181 - 27.07.18 - 12:29
(178) А оно работает?
   Санта Клаус
 
182 - 27.07.18 - 13:10
(179) нашел , вроде бы

"PaymentType"

Тип расчета
1 - Приход 
2 - Возврат прихода
3 - Расход 
4 - Возврат расхода

3 значение подходить, надо пробовать печатать
   Said_We
 
183 - 27.07.18 - 14:49
(177) А где-нибудь есть перечень таблиц с их номерами? Или только конфигурацией с примерами для 7.5 ил и 7.7 смотреть?
   Масянька
 
184 - 27.07.18 - 15:17
(183) Да поставь пароль кассира в обработку печати чека и пользователю пароль пропиши, как в драйвере.
У меня в семерке взлетело - был сис. админ, а стал "Кассир 1".
   Said_We
 
185 - 27.07.18 - 15:31
(184) Вопрос не в этом. Тут при входе все пользователи входят под одним пользователем 1С, но при открытии каждого чека выбирают себя в списке продавцов. Т.е. пронумерованный список продавцов у меня всегда есть. Идея была прописать этот список продавцов в ККМ и в зависимости кто продает отправлять на печать не Кассир 1, а реального продавца. Передать системный администратор или Кассир 1 для налоговой одинаково не правильно. Они рекомендации уже рисуют ИНН продавца передавать. Если ещё получше подумают, то будут СНИЛС вместо ИНН требовать. ИНН у многих нет, а СНИЛС почти у всех есть и его можно для продавцов обязать при себе иметь. ИНН большая портянка и не заламинированная. :-)
Цель налоговой понятная. Пенсионный возраст повысили, а денег ещё хочется. Много продавцов работают нелегально и с них не платятся налоги.
   Said_We
 
186 - 27.07.18 - 15:34
В примере есть такой код:

Процедура ЗапросСтруктурыПоля()
    FR.Password=Password;
    FR.TableNumber=Table;
    FR.FieldNumber=Field;
    FR.GetFieldStruct();
    ОтветДрайвера();
    Если Число(ResultCode)=0 Тогда
        FieldName=FR.FieldName;
        FieldType=FR.FieldType;
        FieldSize=FR.FieldSize;  
        Если FR.FieldType=1 Тогда
            MinValue=FR.MinValueOfField;
            MaxValue=FR.MaxValueOfField;
        КонецЕсли;    
    Иначе
        FieldName="";
        FieldType="";
        FieldSize="";
        MinValue="";
        MaxValue="";
    КонецЕсли;        
    ОтветДрайвера();
КонецПроцедуры 


Вылетает он с ошибкой драйвера на переменную ELVIS.
   Said_We
 
187 - 27.07.18 - 15:36
Собственно и следующий код с той же ошибкой:

Процедура ЗапросСтруктурыТаблицы()
    FR.Password=Password;
    FR.TableNumber=Table;
    FR.GetTableStruct();
    ОтветДрайвера();
    Если Число(ResultCode)=0 Тогда
        TableName=FR.TableName;
        RowNumber=FR.RowNumber;
        FieldNumber=FR.FieldNumber;
    Иначе
        TableName="";
        RowNumber="";
        FieldNumber="";
    КонецЕсли;        
    ОтветДрайвера();
КонецПроцедуры
   ildary
 
188 - 27.07.18 - 15:37
(185) у сис.администратора (в дровах атола 8.16) нельзя установить ИНН.
   Said_We
 
189 - 27.07.18 - 15:43
(188) У штриха в 4.14 в таблице я не вижу такой колонки.
   Масянька
 
190 - 27.07.18 - 15:45
(185) Я бы тебя стукнула...
Вот здесь - https://pastenow.ru/d4ab2b8c96b25c228d645453f323cfd5 - пропиши своих кассиров (ФИО + пароль).
При выборе кассира (где они там у тебя выбирают) - получаешь пароль (пароли в эске и в таблице на скрине должны совпадать) и передаешь его (пароль) в обработку печати чека.
   tgu82
 
191 - 27.07.18 - 16:33
(190) Наверное вопрос идиотский - раньше вроде бы чтобы поставить другого кассира надо было по предыдущему закрывать  смену. Поэтому мы назначаем кассира на день и он бьет весь день. А сейчас как с этим? Все ж в ОФД идет. Ну бил 3 часа один кассир затем сменился. Как правильно смеенить кассира в течении дня или это вообще по фигу?
   Масянька
 
192 - 27.07.18 - 16:38
(191) Честно - не знаю.
Раньше - да, закрытие смены, открытие новой смены новым кассиром.
Сейчас ...
А у меня: смена открылась админом, а потом чек печатнулся с кассиром 1.
Бред такой...
   Said_We
 
193 - 27.07.18 - 17:04
(190) Ну хочется же всегда большего. Хотелось админа освободить от этих телодвижений с настройками в драйвере при смене кассира или добавления нового и т.д. В 1С поменяли или добавили и он уже сразу в ККМ правильно бьется.
   Kigo_Kigo
 
194 - 27.07.18 - 17:26
(191) У штриха есть 2 путяяяя
1-й вбить кассиров в таблицу кассиров ККТ и в зависимость какой пароль передать, он будет менять кассира, пофига когда это делаеться
2-й перед пробитием чека писать ФИО кассира в первое поле, пример гуглица, этот способ нонадежней- в плане текучки кассиров
   Said_We
 
195 - 27.07.18 - 17:45
(194) Чем писать во втором варианте?
Если вариант как в (186) и (187), то с ошибкой вылетает. При этом на какой-то Элвес. Что за элвес не понятно. ККТ модель не элвис, а ФРК.
   skillhoster
 
196 - 27.07.18 - 21:47
(182) PaymentType - это когда делаешь чек через xml пакет, т.е. не напрямую с драйвером, как в последней обработке для атола frATOL54_comm_105.ert используя объект FprnM45, а по старому, через обработку frATOL54_comm.ert и объект ATOL_KKM_1C82_54FZ.

в объекте FprnM45 нет поля PaymentType по моему.
   skillhoster
 
197 - 27.07.18 - 21:48
(181) да - взято из рабочей базы, в которой работают напрямую с drvfr.dll
   skillhoster
 
198 - 27.07.18 - 21:53
(187)
пробуй
Объект.Пароль = 30;
Объект.НомерТаблицы = 2;
Объект.НомерПоля    = 2;  
Объект.ПолучитьСтруктуруПоля();
Объект.НомерРяда = Пароль;
Объект.ЗначениеПоляСтрока = "Кассир:" + СокрЛП(Кассир);
Объект.ЗаписатьТаблицу();

в Кассира предварительно запихиваешь текущего пользователя, в Пароль - пароль пользователя для доступа к ккм.

грубо говоря код в таблицу записывает имя кассира (пользователя под которым печатается чек) а потом когда ты действительно пробиваешь чек по переданному паролю (номер ряда) вытаскивает уже записанное имя пользователя из таблицы. в штрихе по другому не получится, если хочешь чтобы выдавались разные кассиры при печати с одной ккт в одной смене.
   Said_We
 
199 - 27.07.18 - 23:14
(198) Собственно в (187) я так и написал, только англоязычный вариант. Не получает не структуру таблицы, не структуру поля.
  1  2

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует