Вход | Регистрация


Вопрос по БП Корп

Вопрос по БП Корп
Я
   1ctube
 
20.04.18 - 11:05
День добрый. В БП Корп (3.0.52.39) есть документ "списание с расчетного счета" и при виде операции "уплата налогов" можно заполнить "Отражение в бухгалтерском учете". Вопрос: это общая форма? Не справочник? Тогда ни как нельзя будет его заполнять программно?
 
 
   shuhard
 
1 - 20.04.18 - 12:21
(0) а какая связь между формой отражения и реквизитом для хранения ?
программно можно
   1ctube
 
2 - 26.04.18 - 12:06
(1) Ну вот: на форме документа "списание с расчетного счета" есть поле надписи "ПорядокОтраженияБУ"  с событием :

&НаКлиенте
Процедура ПорядокОтраженияБУНажатие(Элемент, СтандартнаяОбработка)
    
    Если НЕ ТолькоПросмотр Тогда
        ЗаблокироватьДанныеФормыДляРедактирования();
    КонецЕсли;
    
    СписаниеСРасчетногоСчетаФормыКлиент.ПорядокОтраженияБУНажатие(ЭтотОбъект, Элемент, СтандартнаяОбработка);
    
КонецПроцедуры

Открываю: СписаниеСРасчетногоСчетаФормыКлиент.ПорядокОтраженияБУНажатие(ЭтотОбъект, Элемент, СтандартнаяОбработка);

И вижу такой код:
Процедура ПорядокОтраженияБУНажатие(Форма, Элемент, СтандартнаяОбработка) Экспорт
    
    Объект = Форма.Объект;
    
    СтандартнаяОбработка = Ложь;
    
    ПараметрыФормы = Новый Структура;
    ПараметрыФормы.Вставить("ТолькоПросмотр", Форма.ТолькоПросмотр);
    
    ПараметрыФормы.Вставить("Период",      Объект.Дата);
    ПараметрыФормы.Вставить("Организация", Объект.Организация);
    ПараметрыФормы.Вставить("Счет",        Объект.СчетУчетаРасчетовСКонтрагентом);
    ПараметрыФормы.Вставить("Субконто1",   Объект.СубконтоДт1);
    ПараметрыФормы.Вставить("Субконто2",   Объект.СубконтоДт2);
    ПараметрыФормы.Вставить("Субконто3",   Объект.СубконтоДт3);
    ПараметрыФормы.Вставить("Направление", "Дт");
    
    Если Объект.СчетУчетаРасчетовСКонтрагентом = ПредопределенноеЗначение(
            "ПланСчетов.Хозрасчетный.НДСНалоговогоАгента") Тогда
        ПараметрыФормы.Вставить("АдресТаблицыНалоговыйАгентНДСВХранилище", 
            СписаниеСРасчетногоСчетаФормыВызовСервера.ПоместитьРасшифровкуНалоговыйАгентНДСВХранилище(Объект));
    КонецЕсли;
        
    ПараметрыФормы.Вставить("СуммаПоПлатежномуПоручению", Объект.СуммаДокумента);
    ПараметрыФормы.Вставить("НазначениеПлатежа",          Объект.НазначениеПлатежа);
    ПараметрыФормы.Вставить("ДокументСсылка",             Объект.Ссылка);
    
    ОткрытьФорму("ОбщаяФорма.ПорядокОтраженияБУ", ПараметрыФормы, Форма);
    
КонецПроцедуры

И можно ли тогда заполнить программно эту форму : "ПорядокОтраженияБУ" ? Например там есть реквизит "Регистрация в налоговом органе" и его нужно заполнить программно

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует