Вход | Регистрация


УФ. В общий модуль отправить весь объект формы на изменение ТЧ

УФ. В общий модуль отправить весь объект формы на изменение ТЧ
Я
   bolobol
 
20.04.18 - 10:12
Добрый день!

Я что-то запутался и запамятовал...

Нужно, при изменении реквизита формы - обойти ТЧ и по-редактировать данные одной колонки. Процедура изменения нужна в общем модуле Сервер+ВызовСервера.

&НаКлиенте
Процедура ПриИзмененииРеквизита(Элемент)
 ОбщийМодульСерверВызовСервера.ПоредактироватьТЧ(Объект);
КонецПроцедуры

Ошибка: Нельзя изменять поле, содержащее объект данных формы

А как тогда?

Прошу помочь опомниться! ))
 
 
   Тихий омут
 
1 - 20.04.18 - 10:14
Может поможет РеквизитФормыВЗначение и потом обратно?
   bolobol
 
2 - 20.04.18 - 10:15
Только через &НаСервере в модуле формы, через РеквизитВОбъект..., или как там?
   VladZ
 
3 - 20.04.18 - 10:15
Тип объекта у "Объект" какой?
   bolobol
 
4 - 20.04.18 - 10:17
(3) Для любого Объекта предполагается работать.
   МимохожийОднако
 
5 - 20.04.18 - 10:22
(2) Да
   FIXXXL
 
6 - 20.04.18 - 10:27
как вариант "отдаешь" всю форму в общий модуль
а там Форма.Объект.ТЧ и делаешь что необходимо
   bolobol
 
7 - 20.04.18 - 10:36
Спасибо за участие! Похоже, просыпаться начал...

Вопрос меняется в сторону сути:

(6)
ОбщийМодульСерверВызовСервера.ПоредактироватьТЧ(ЭтотОбъект или ЭтаФорма);

Приводит к: Отсутствует отображение для типа 'УправляемаяФорма'

Тогда как всю форму отдать?
   Тихий омут
 
8 - 20.04.18 - 10:38
(7) и плавно возвращаемся к (1) с учетом того, что сам в (2) написал
   Вафель
 
9 - 20.04.18 - 10:40
нужно на форме на сервере вызывать процедуру серверную
   bolobol
 
10 - 20.04.18 - 10:43
Короче, напрямки в общий модуль, да со всем объектом - никак... Хм...
 
 Рекламное место пустует
   Вафель
 
11 - 20.04.18 - 10:44
(10) почему необходимо именно с клиента?
   hhhh
 
12 - 20.04.18 - 10:44
(7) ты вызывай с сервера, типа

&НаКлиенте
Процедура ПриИзмененииРеквизита(Элемент)
   ПриИзмененииРеквизитаНаСервере();
КонецПроцедуры

&НаСервере
 Процедура ПриИзмененииРеквизитаНаСервере()
ОбщийМодульСерверВызовСервера.ПоредактироватьТЧ(Объект);
КонецПроцедуры
   bolobol
 
13 - 20.04.18 - 10:49
Да вот из-за необходимости дополнительной процедуры как в (12) - задался вопросом, ибо... вдруг! ))

И конвертации реквизитавобъект и обратно не потребовалось - и так работает, странно, нет?
   Вафель
 
14 - 20.04.18 - 10:50
(13) ничего странного. фориа и объект - это не совсем обычные переменные
   bolobol
 
15 - 20.04.18 - 10:59
Так-то да.
Вот и каша в животе
   bolobol
 
16 - 20.04.18 - 11:08
Я тут ещё, заодно:

Элементы.ТЧКолонкаСоСсылками1.ТолькоПросмотр= Истина;
Элементы.ТЧКолонкаСоСсылками1.ГиперссылкаЯчейки= Истина;

- не открывает ссылку нажатием на видимую гиперссылку в ТЧ

Что надобно сделать?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует