Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Вывод списка табличной части документа в отчет сводно ,возможно ли?

Вывод списка табличной части документа  в отчет сводно ,возможно ли?
Я
   karagach
 
19.04.18 - 14:12
Приветствую  коллеги ! 1с 8 .3

Столкнулся с такой ситуацией . 

в документе можно вывести таб часть в список -таблицу значений 

хотелось бы написать отчет для вывода всех таб частей за выбранный период . возможно ли?
 
 
   Fish
 
1 - 19.04.18 - 14:12
Возможно. Пиши.
   olegves
 
2 - 19.04.18 - 14:13
(0) можно, пиши
   karagach
 
3 - 19.04.18 - 14:14
уже пишу в скд . но хотелось бы методом вывод списка .  где посмотреть  его код?
   Fish
 
4 - 19.04.18 - 14:15
(3) "где посмотреть  его код?" - Где-нибудь в исходниках у программистов платформы 1С. Но он не на 1С будет :)
   karagach
 
5 - 19.04.18 - 14:16
стандартная команда  вывод списка табличной части .
то .что мне нужно . но  кода нет . там компановщиком форму строит?
   olegves
 
6 - 19.04.18 - 14:16
(3) в декомпиляторе
   karagach
 
7 - 19.04.18 - 14:17
вот так всегда) придется свое  лепить . хотя можно было  оттуда дернуть и не тратить время
   karagach
 
8 - 19.04.18 - 14:18
еще вопрос можно эту команду вызвать . допустим .чтобы она в форму выводила  за период  данные тч документов .
   Fish
 
9 - 19.04.18 - 14:19
(7) О. Придумал. Рисуешь форму, на неё выводишь, например, динамический список со своим отчётом. А дальше - стандартно - вывести список. Профит :)
   karagach
 
10 - 19.04.18 - 14:20
(9) обычные формы
 
 Рекламное место пустует
   olegves
 
11 - 19.04.18 - 14:24
(7) ты здесь времени больше потратил, чем нужно для написания кода на СКД
   PR
 
12 - 19.04.18 - 14:26
(0) Да
   karagach
 
13 - 19.04.18 - 14:29
(11) на скд его не напишешь .  в тч совсем другие поля
   karagach
 
14 - 19.04.18 - 14:30
допустим  в тч  день .  в скд это будет  31 разных полей.
   karagach
 
15 - 19.04.18 - 14:31
потом эти дни надо будет суммировать . проверять на  заполненность , смотреть где явки выходы .выходные отгулы и т д .  

а списком все наглядно выводит без гемора
   Chameleon1980
 
16 - 19.04.18 - 19:38
блин. Ты сам-то понимаешь чего хочешь?

Знание предметной области, ИМХО, никакое.
   karagach
 
17 - 21.04.18 - 21:20
(16)я хочу  в форму вывода списка  добавить свой заголовок и

поля шапки документа  . а он просто мне список дает . возможно ли то .чего я хочу ? (16)  у тебя блин знание предметной области никакое  извини ...
   karagach
 
18 - 21.04.18 - 21:37
Михалыч подскажи добр человек)
   karagach
 
19 - 21.04.18 - 21:40
убежал)
   Chameleon1980
 
20 - 21.04.18 - 22:03
вывести список - внутренний механизм.
собирай что нужно запросом, например, и выводи на здоровье как угодно и сколько угодно
   karagach
 
21 - 21.04.18 - 22:38
(20) оно ежу понятно . но я уже описал . что в тч документа поля одни .а в запросе  совсем другие значения. поэтому тут извращаться .

в тч  допустим  явка 11 ч .  в  данных таблицы  этого не будет .
   karagach
 
22 - 21.04.18 - 22:42
придется в запрос каким то образом такие расчеты прикручивать :

    // Подсчет для итоговой колонки

                    НакопленоДней = СоответствиеРасчетаИтоговДней[ВидВремени];
                    НакопленоЧасов = СоответствиеРасчетаИтоговЧасов[ВидВремени];
                    Если НакопленоДней = Неопределено ИЛИ НакопленоЧасов = Неопределено Тогда
                        НакопленоДней = 0;
                        НакопленоЧасов = 0;
                    КонецЕсли;
                    СоответствиеРасчетаИтоговДней.Вставить(ВидВремени, НакопленоДней + 1);
                    СоответствиеРасчетаИтоговЧасов.Вставить(ВидВремени, НакопленоЧасов + КоличествоЧасов);
                КонецЕсли;
                
                Если НЕ ВидВремени.Пустая() Тогда
                    Если ВидВремени.БуквенныйКод = "Я" Тогда
                        ТекстЯчейки = "Я " + КоличествоЧасов + Символы.ПС + ТекстЯчейки;
                    ИначеЕсли ВидВремени = Справочники.КлассификаторИспользованияРабочегоВремени.ВыходныеДни Тогда
                        ТекстЯчейки = ТекстЯчейки + ВидВремени.БуквенныйКод + " " + Символы.ПС;
                    Иначе
                        ТекстЯчейки = ТекстЯчейки + ВидВремени.БуквенныйКод + " " + КоличествоЧасов + Символы.ПС;
                    КонецЕсли;
                КонецЕсли;
            КонецЦикла;    
            ТекстЯчейки = Лев(ТекстЯчейки, СтрДлина(ТекстЯчейки)-1);
            ТекущаяЯчейка = ОформлениеСтроки.Ячейки["День"+СтрокаИндексДня];
            Если ТекущаяЯчейка.Значение <> ТекстЯчейки Тогда
                ТекущаяЯчейка.Значение = ТекстЯчейки;
            КонецЕсли;
        КонецЦикла;
   karagach
 
23 - 04.05.18 - 14:37
бля
   karagach
 
24 - 04.05.18 - 14:38
Запрос = Новый Запрос;
    Запрос.Текст ="ВЫБРАТЬ РАЗЛИЧНЫЕ
                  |    ТабельУчетаРабочегоВремениОрганизации.НомерСтроки,
                  |    ТабельУчетаРабочегоВремениОрганизации.Сотрудник,
                  |    ТабельУчетаРабочегоВремениОрганизации.КодУпр,
                  |    ТабельУчетаРабочегоВремениОрганизации.КодБух,
                  |    ТабельУчетаРабочегоВремениОрганизации.Специальность КАК Специальность,
                  |    ТабельУчетаРабочегоВремениОрганизации.Подразделение,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов1,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов2,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов3,
                  |    ТабельУчетаРабочегоВремениОрганизации.Ссылка.ВремяРабот,
                  |    ТабельУчетаРабочегоВремениОрганизации.Ссылка.Дата КАК Дата1,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени1.БуквенныйКод КАК День1,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени2.БуквенныйКод КАК День2,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени3.БуквенныйКод КАК День3,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени4.БуквенныйКод КАК День4,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени5.БуквенныйКод КАК День5,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени6.БуквенныйКод КАК День6,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени7.БуквенныйКод КАК День7,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени8.БуквенныйКод КАК День8,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени9.БуквенныйКод КАК День9,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени10.БуквенныйКод КАК День10,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени11.БуквенныйКод КАК День11,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени12.БуквенныйКод КАК День12,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени13.БуквенныйКод КАК День13,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени14.БуквенныйКод КАК День14,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени15.БуквенныйКод КАК День15,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени16.БуквенныйКод КАК День16,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени17.БуквенныйКод КАК День17,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени18.БуквенныйКод КАК День18,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени19.БуквенныйКод КАК День19,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени20.БуквенныйКод КАК День20,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени21.БуквенныйКод КАК День21,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени22.БуквенныйКод КАК День22,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени23.БуквенныйКод КАК День23,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени24.БуквенныйКод КАК День24,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени25.БуквенныйКод КАК День25,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени26.БуквенныйКод КАК День26,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени27.БуквенныйКод КАК День27,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени28.БуквенныйКод КАК День28,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени29.БуквенныйКод КАК День29,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени30.БуквенныйКод КАК День30,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйВидВремени31.БуквенныйКод КАК День31,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов4,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов5,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов6,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов7,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов8,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов9,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов10,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов11,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов12,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов13,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов14,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов15,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов16,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов17,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов18,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов19,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов20,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов21,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов22,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов23,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов24,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов25,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов26,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов27,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов28,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов29,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов30,
                  |    ТабельУчетаРабочегоВремениОрганизации.ПервыйЧасов31,
                  |    ТабельУчетаРабочегоВремениОрганизации.Ссылка.Номер,
                  |    ТабельУчетаРабочегоВремениОрганизации.Ссылка.ВидТабеля,
                  |    ТабельУчетаРабочегоВремениОрганизации.ДолжностьОрганизации
                  |ИЗ
                  |    Документ.ТабельУчетаРабочегоВремениОрганизации.ОтработанноеВремя КАК ТабельУчетаРабочегоВремениОрганизации
                  |ГДЕ
                  |    ТабельУчетаРабочегоВремениОрганизации.Ссылка = &Ссылка
                  |    И ТабельУчетаРабочегоВремениОрганизации.Ссылка.Дата = &Дата"; 
    
    Запрос.УстановитьПараметр("Ссылка",Ссылка);
     Запрос.УстановитьПараметр("Дата",Дата);  

    Результат = Запрос.Выполнить();

    Выборка = Результат.Выбрать();
        
         ТабДокумент = Новый ТабличныйДокумент;
         ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Акт";
     
         Макет = ПолучитьМакет("Табель");
         Выборка.Следующий();
         ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
         ОбластьСтрока = Макет.ПолучитьОбласть("Строка"); 
        //ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");

              
         ОбластьЗаголовок.Параметры.Заполнить(Выборка);
         ТабДокумент.Вывести(ОбластьЗаголовок);    
         
         
    Пока Выборка.Следующий() Цикл
       
         ОбластьСтрока.Параметры.Заполнить(Выборка);
         ТабДокумент.Вывести(ОбластьСтрока);
 
    КонецЦикла;

     ТабДокумент.Вывести(ОбластьСтрока);     
    //ТабДокумент.Вывести(ОбластьПодвал);    

     ТабДокумент.Показать();


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует