Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Доработка ТиС в плане 54 ФЗ

v7: Доработка ТиС в плане 54 ФЗ
Я
   alexdomovoi
 
19.04.18 - 12:19
Добрый день! подскажите что придумать стоит АТОЛ 11Ф база ТИС в ней находится и товар с системой налогообложения ОСН и с УСН, может есть уже готовые реализованные дополнения, что бы из одной базы продавать товар какой под ОСН, какой под УСН, с учетом если продавец знает какой товар относится к системе налогообложения. Спасибо!
 
 
   Kigo_Kigo
 
1 - 19.04.18 - 12:28
Есть решение
   Kigo_Kigo
 
2 - 19.04.18 - 12:29
   Kigo_Kigo
 
3 - 19.04.18 - 12:29
вкраце команда
 ФР.TaxType = 4;  // 2 - УСН Доход,  4 - УСН Доход-Расход, 8 - ЕНВД 

Дополню: 16 - ЕСХН, 32 - ПСН
   Kigo_Kigo
 
4 - 19.04.18 - 12:31
ФР.TaxType = 0;
ОСН
   alexdomovoi
 
5 - 19.04.18 - 12:32
(4) как с вами связаться?
   Kigo_Kigo
 
6 - 19.04.18 - 12:33
Система налогообложения меняется в любой момент, но применяется на весь чек
   hhhh
 
7 - 19.04.18 - 12:35
(5) одновременно не может быть ОСН и УСН. Вы наверно перепутали.
   Kigo_Kigo
 
8 - 19.04.18 - 12:37
(5) kigoryazan@gmail.com
   alexdomovoi
 
9 - 19.04.18 - 12:37
(7) я не про одновременно, база одна и товар который идет по УСН продавец пробивал бы по УСН, и чек шел только на УСН, а товар который по ОСН, пробивал бы чек по ОСН
   Builder
 
10 - 19.04.18 - 12:37
У атола это ставилось вот так, может щас уже поправили чего, но этот вариант работает.

Объект.AttrNumber=1055;
Объект.AttrValue=СистемаНалогообложения;
Объект.WriteAttribute();
 
 Рекламное место пустует
   ildary
 
11 - 19.04.18 - 12:39
(10) именно так сделано в последней версии.
   hhhh
 
12 - 19.04.18 - 12:39
(9) я имею в виду что у организации в году может быть только одна система, если у вас осн, по чтобы перейти на усн - это только в конце года. пишете заявление, у вас с 1 января усн.
   piter3
 
13 - 19.04.18 - 12:40
ЕНВД и ОСН.Или ЕНВД и УСН.Пипец
   Builder
 
14 - 19.04.18 - 12:44
(13) Таки да, ОСН и УСН вместе не бывает :)
   ildary
 
15 - 19.04.18 - 12:48
Уважаемые специалисты, скажите пожалуйста, почему может быть такая проблема: 2 ККТ (разные организации) в одной базе ТиС. Всё вроде бы работает правильно. Чек выходит, инофрмация уходит в ОФД, но при выполнении строки

НомерЧека = Объект.НомерЧека;

в обработке fr_comm.ert иногда в чек проставляется номер чека из другой ККТ. Например

Первая ККТ - номера идут 10, 11, 12, вторая: 100, 101, 102

но в ПКО отбитых по первой ККТ номера чеков проставляются как 10, 102, 11. Код простой и в целом типовой (добавлена только установка номера устройства и кассир.
   ildary
 
16 - 19.04.18 - 12:49
Вдогонку - точнее в ПКО номера чеков выглядят так: 10, 102, 12, как будто чек 11 пропущен.
   Aleksey
 
17 - 19.04.18 - 12:49
(9) Это как? У каждой фирмы свой ККМ. Т.е. нельзя на одном аппарате пробивать чеки разных фирм
   ildary
 
18 - 19.04.18 - 12:53
(17) Я не пробиваю на одной ККМ чеки разных фирм: аппараты жёстко привязаны к фирме и перед печатью проверяется фирма документа и принудительно меняется номер устройства:

Объект.CurrentDeviceNumber = НомерУстройства;
   ildary
 
19 - 19.04.18 - 12:54
Более того - для самопроверки оператора выдается предупреждение "Вы будете отбивать чек по <Название организации>" с возможностью отказа перед печатью.
   ildary
 
20 - 19.04.18 - 13:04
Открыл ОФД (Платформа), заглянул в подробности чека и вижу в нём два номера чека: первый - номер за день, второй - какой-то тоже оторванный от реальности. Сравнил fr_comm.ert и frATOL54_comm_105.ert - вижу, что во втором строки запоминания чека вообще нет. Получается, что теперь атол вообще не возвращает корректный номер чека? В описании Drivers8_Frnm_PM.pdf - это поле упоминается.
   alexdomovoi
 
21 - 19.04.18 - 13:05
Ситуация такая ИП магазин есть обычный товар и есть масла для мотора, так вот масла сейчас продают по ОСН, а надо по упращенке (доход-расход), так вот с 1 июля основной товар будет продаваться уже по вмененке, а масла так и останутся на упращенке. С одним кассовым аппаратом это возможно? Или это просто нереально у одного ИП?
   Builder
 
22 - 19.04.18 - 13:11
(21) Возможно, но разными чеками.
   alexdomovoi
 
23 - 19.04.18 - 13:12
(22) напишите мне ваш емейл я еще с вами посоветуюсь
   Kigo_Kigo
 
24 - 19.04.18 - 13:13
(21) (23) Читай по ссылке во втором посте
   Kigo_Kigo
 
25 - 19.04.18 - 13:13
я это реализовал
   Kigo_Kigo
 
26 - 19.04.18 - 13:13
дописать в обработке 4 строчки
   Builder
 
27 - 19.04.18 - 13:19
(23) Советуйтесь тут :)
Алгоритм примерно такой - разделить таблицу с товарами на 2 таблицы - УСН и ЕНВД, пробить каждую таблицу своим чеком, установив нужную систему налогов.
   alexdomovoi
 
28 - 19.04.18 - 13:23
(27) ясно я просто по старой теме так и не доделал то что вы предлагали,https://www.forum.mista.ru/topic.php?id=811161 теперь походу к 1 июля уже надо все переводить, а не только УСН
   piter3
 
29 - 19.04.18 - 13:23
(28) УСН с 1.07.2017.Доброе утро
   Builder
 
30 - 19.04.18 - 13:31
(28) Йо...
Всего то 4 месяца прошло....
   alexdomovoi
 
31 - 19.04.18 - 13:32
(30) ))) да так и есть
   Aleksey
 
32 - 19.04.18 - 13:33
(31) ТОлько не забудь что тебе протокол 1.05 нужен уже, ибо с 01.01.19 1.0 не катит
   alexdomovoi
 
33 - 19.04.18 - 13:36
(32) поточнее
 
 
   Kigo_Kigo
 
34 - 19.04.18 - 13:38
(33) Использовать обработку обслуживания frATOL54_comm_105.ert
   monsterZE
 
35 - 20.04.18 - 10:04
Народ, залейте, плиз, одну ЕРТ куда-нибудь. Глянуть что там. =)
   Злопчинский
 
36 - 20.04.18 - 10:06
   monsterZE
 
37 - 20.04.18 - 10:13
(36) пасиб конечно, но мне нужна только выше указанная ерт =)
   piter3
 
38 - 20.04.18 - 10:13
(33) 1.0 фсе
   monsterZE
 
39 - 20.04.18 - 10:14
(38) с чего бы это? до 19 года не все.
   piter3
 
40 - 20.04.18 - 10:18
(39) О том и речь
   ildary
 
41 - 20.04.18 - 10:27
(39) а вы попробуйте купить ФР с протоколом 1.0
   piter3
 
42 - 20.04.18 - 10:32
(41) Кстати продадут остатки))
   Kigo_Kigo
 
43 - 20.04.18 - 10:36
(35) напиши мне на почту, адрес выше
   monsterZE
 
44 - 20.04.18 - 16:12
Смотрю 1С отказалась от варианта с XML в 1.0.5
или есть еще вариант обработки по ХМЛ? =)
Т.к. мне попадалось следующее:
<?xml version="1.0" encoding="UTF-8"?>
<CheckPackage>
    <Parameters PaymentType="1" TaxVariant="3" CashierName="Консультант - эксперт Яценко" CustomerEmail="" CustomerPhone=""/>
    <Positions>
        <FiscalString Name="Омыватель стекол &quot;ZIMA&quot; -30*С (5 л)(шт)" Quantity="1" PriceWithDiscount="130" SumWithDiscount="130" DiscountSum="" Department="2" Tax="none" SignMethodCalculation="6" SignCalculationObject="1" TaxSum=""/>
    </Positions>
    <Payments Cash="0" ElectronicPayment="130" Credit="0" AdvancePayment="0" CashProvision="0"/>
</CheckPackage>
   monsterZE
 
45 - 20.04.18 - 16:12
и
        Если Не ПустаяСтрока(ОбщиеПараметры.КассирИНН) Тогда 
            ЗаписьXML.ЗаписатьАтрибут("CashierVATIN", XMLСтрока(ОбщиеПараметры.КассирИНН));
        КонецЕсли;
        Если Не ПустаяСтрока(ОбщиеПараметры.ОтправительEmail) Тогда
            ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(ОбщиеПараметры.ОтправительEmail));
        КонецЕсли;

    Если ВерсияФФД > 0 Тогд// Атрибуты с ФФД 1.0.5

                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными));
                ЗаписьXML.ЗаписатьАтрибут("Credit"           , XMLСтрока(СуммаПостоплатой));
                ЗаписьXML.ЗаписатьАтрибут("AdvancePayment"   , XMLСтрока(СуммаПредоплатой));
                ЗаписьXML.ЗаписатьАтрибут("CashProvision"    , XMLСтрока(СуммаПредоставлением));
            Иначе
                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными + СуммаПостоплатой + СуммаПредоплатой + СуммаПредоставлением));
            КонецЕсли;
            ЗаписьXML.ЗаписатьКонецЭлемента();
        КонецЕсли;
   sanyaka
 
46 - 25.04.18 - 08:40
Использовали доработанную frATOL54_comm.ert с офд 1.0.
Сейчас будем переходить на 1.05. Посмотрел frATOL54_comm_105.ert получается уходим от xml.
На сколько понял, теперь нужно со скидками разбираться. Раньше указывали в xml кол-во, цена (без скидки), сумма с учетом скидок. Сейчас же суммы не будет, будет отдельный общий параметр скидки Объект.Percents = Скидка; Это в рублях или процентах? Можно ли как-то сумму общую задать ?

Касса по сети работала. Как передать ip, port ?

Передавать email, tel тож в обработке не написано...

Ну и главное это оплата наличными, по карте...

Короче нужно доки читать... Мож кто-нить уже проходил этот путь или есть примеры?


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует