Вход | Регистрация


Помогите разобраться с проведением приобретения товаров в УТ 11.4

Помогите разобраться с проведением приобретения товаров в УТ 11.4
Я
   Обфускация
 
18.04.18 - 08:57
Документ создается программно. Но не проводится. Если перевыбрать договор, то начинает проводиться. Пока не проводится, выдает такую ошибку. Чего может не хватать?


{ОбщийМодуль.ОбщегоНазначенияУТКлиент.Модуль(1798)}: Ошибка при вызове метода контекста (Записать)
    Результат = Форма.Записать(ПараметрыЗаписи);
по причине:
Запись не верна! Значение поля "Распоряжение" не может быть пустым! (Регистр накопления: Движение товаров; Номер строки: 1)
 
 
   cw014
 
1 - 18.04.18 - 09:00
Програмно не заполняется поле "Распоряжение" из договора. Будет исправлено в следующем релизе... возможно
   Обфускация
 
2 - 18.04.18 - 09:19
Поле Распоряжение где находится, как понять? В приобретении нет такого реквизита.
   saaken
 
3 - 18.04.18 - 09:26
зато в регистре есть
   cw014
 
4 - 18.04.18 - 09:27
(2) А у тебя в модуле "ОбщегоНазначенияУТКлиент" на строке 1798 идет запись именно приобретения?
   Обфускация
 
5 - 18.04.18 - 09:30
(4)
вот что там
Функция ОбработатьЗаписьОбъектаВФорме(Форма, ПараметрыЗаписи, Отказ = Ложь) Экспорт
    
    ДействиеПослеЗаписи = Неопределено;
    Если ПараметрыЗаписи.Свойство("ДействиеПослеЗаписи", ДействиеПослеЗаписи) Тогда
        ПараметрыЗаписи.Удалить("ДействиеПослеЗаписи");
    КонецЕсли;
    
    Результат = Ложь;
    
    Если Отказ Тогда
        Возврат Результат;
    КонецЕсли;
    
    НачатьЗамерВремениЗаписиОбъекта(Форма, ПараметрыЗаписи);
    Форма.НеВыполнятьПроверкуПередЗаписью = Истина;
    
    Отказ = Истина;
    ПараметрыЗаписи.Вставить(
        "ПринудительноЗакрытьФорму", Форма.ПринудительноЗакрытьФорму);
    ПараметрыЗаписи.Вставить("НовыйОбъект", Не ЗначениеЗаполнено(Форма.Объект.Ссылка));
    Результат = Форма.Записать(ПараметрыЗаписи);
    
    Форма.ПринудительноЗакрытьФорму = Ложь;
    Форма.НеВыполнятьПроверкуПередЗаписью = Ложь;
    
    Если Результат И ДействиеПослеЗаписи <> Неопределено Тогда
        ВыполнитьОбработкуОповещения(ДействиеПослеЗаписи, Результат);
    КонецЕсли;
    
    Возврат Результат;
    
КонецФункции
   cw014
 
6 - 18.04.18 - 09:33
(5) Ну я код не просил. Я задал вопрос, что именно там записывается.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует