Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибки определения элементов

Ошибки определения элементов
Я
   ilyuza95
 
16.04.18 - 23:27
Выходят 3 ошибки:
{Справочник.Планировщик.Форма.Форма.Форма(22,4)}: Переменная не определена (Элемент)
 <<?>>Элемент.Планировщик.Элементы.Добавить(ВыборкаДетальныеЗаписи.ДатаНачала,ВыборкаДетальныеЗаписи.ДатаОконания); (Проверка: Сервер)
{Справочник.Планировщик.Форма.Форма.Форма(23,4)}: Переменная не определена (Элемент)
 <<?>>Элемент.Текст=ВыборкаДетальныеЗаписи.Наименование; (Проверка: Сервер)
{Справочник.Планировщик.Форма.Форма.Форма(24,5)}: Переменная не определена (Элемент)
 <<?>>Элемент.Значение=ВыборкаДетальныеЗаписи.Ссылка; (Проверка: Сервер)

Подскажите, пожалуйстаБ что именно неправилно в этом коде:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    НН=НачалоНедели(ТекущаяДата());
    КН=КонецНедели(ТекущаяДата());
    ТП=Планировщик.ТекущиеПериодыОтображениях[0];
    ТП.Начало=ТП.Начало+9*60*60;
    ТП.Конец=ТП.Начало+11*60*60-1;
    Запрос = Новый Запрос;
    Запрос.Текст =
    
       "ВЫБРАТЬ
     |    Планировщик.Наименование,
     |    Планировщик.ДатаНачала,
     |    Планировщик.ДатаОкончания,
     |    Планировщик.Ссылка
     |ИЗ
     |    Справочник.Планировщик КАК Планировщик";
     
     РезультатЗапроса = Запрос.Выполнить();
     ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
     Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         Элемент.Планировщик.Элементы.Добавить(ВыборкаДетальныеЗаписи.ДатаНачала,ВыборкаДетальныеЗаписи.ДатаОконания);
         Элемент.Текст=ВыборкаДетальныеЗаписи.Наименование;
             Элемент.Значение=ВыборкаДетальныеЗаписи.Ссылка;
        КонецЦикла;
        
    КонецПроцедуры
    
&НаКлиенте
Процедура ПланировщикПриОкончанииРедактирования(Элемент, НовыйЭлемент, ОтменаРедактирования)

    ПланировщикПриОкончанииРедактированияНаСервере(НовыйЭлемент);

КонецПроцедуры

&НаСервере
Процедура ПланировщикПриОкончанииРедактированияНаСервере(НовыйЭлемент)
    ВыделенныйЭлемент=Элементы.Планировщик.ВыделенныеЭлементы[0];
    Если НовыйЭлемент Тогда
    
        НовыйОбъект=Справочники.Планировщик.СоздатьЭлемент();
        НовыйОбъект.ДатаНачала=ВыделенныйЭлемент.Начало;
        НовыйОбъект.ДатаОкончания=ВыделенныйЭлемент.Конец;
        НовыйОбъект.Наименование=ВыделенныйЭлемент.Текст;
        НовыйОбъект.Записать();
        
        ВыделенныйЭлемент.Значения=НовыйОбъект.Ссылка;
    Иначе
        СуществующийОбъект=ВыделенныйЭлемент.Значение.ПолучитьОбъект();
        СуществующийОбъект.ДатаНачала=ВыделенныйЭлемент.Начало;
        СуществующийОбъект.ДатаОкончания=ВыделенныйЭлемент.Конец;
        СуществующийОбъект.Наименование=ВыделенныйЭлемент.Текст;
        СуществующийОбъект.Записать();
    
    КонецЕсли; 
    

КонецПроцедуры

&НаКлиенте
Процедура ПланировщикПриСменеТекущегоПериодаОтображения(Элемент, ТекущиеПериодыОтображения, СтандартнаОбработка)

    СтандартнаОбработка=Ложь;
    ТП=ТекущиеПериодыОтображения[0];
    ТПО=Планировщик.ТекущиеПериодыОтображения[0];
    
    Если НачалоДня(ТПО.Начало)=НачалоДня(ТП.Конец) Тогда
    
        ТПО.Начало=НачалоДня(ТП.Начало)+9*60*60;
        ТПО.Конец=ТПО.Начало+11*60*60-1;
    
    Иначе
        ТПО.Начало=НачалоДня(ТП.Конец)+9*60*60;
        ТПО.Конец=ТПО.Начало+11*60*60-1;
    КонецЕсли; 

КонецПроцедуры
 
 
   Darych
 
1 - 16.04.18 - 23:31
не определена переменная элемент
   vicof
 
2 - 16.04.18 - 23:32

   Darych
 
3 - 16.04.18 - 23:35
"  Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
         Элемент.Планировщик.Элементы.Добавить(ВыборкаДетальныеЗаписи.ДатаНачала,ВыборкаДетальныеЗаписи.ДатаОконания);
         Элемент.Текст=ВыборкаДетальныеЗаписи.Наименование;
             Элемент.Значение=ВыборкаДетальныеЗаписи.Ссылка;
        КонецЦикла;"

это ты где "выдрал"?
   ilyuza95
 
4 - 16.04.18 - 23:38
Нашла ошибку, извините за беспокойство:)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует