Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не изменяется родитель у справочника номенклатура

↓ [Serg_1960, 16.04.18 - 11:20]
Не изменяется родитель у справочника номенклатура
Я
   sidalexsandr
 
16.04.18 - 11:04
Не изменяется родитель у справочника номенклатура. Вот код:
Выборка = Справочники.БП_ПрейскурантНаРаботы.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        // пропустить товар, который вне групп

        Если Выборка.Наименование = "Компенсация командировочных затрат инженера выездного ремонта" Тогда
            Продолжить;
        КонецЕсли;
        
        Если Выборка.Ссылка.ЭтоГруппа = Истина Тогда
            // группы уже созданы пропустить группы

            Продолжить;
        КонецЕсли;                 
                                
        
        ТекРод = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Родитель, Истина);                     
            
        Сообщить("Выборка.Наименование = " + Выборка.Наименование);     
        Сообщить("ТекРод = " + ТекРод);
        // Найти по Артикул

        ТекТов = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", Выборка.Работа.Артикул);     
        ТекТоварчик = ТекТов.ПолучитьОбъект();
        ТекТоварчик.Родитель = ТекРод.Ссылка;
        ТекТоварчик.Записать();                       
                
        
    КонецЦикла;
 
 
   Cool_Profi
 
1 - 16.04.18 - 11:08
А отладчичек ничегошеньки не поговаривает?
   catena
 
2 - 16.04.18 - 11:09
Это уже третья тема по одному и тому же куску кода. Наверное, надо что-то в консерватории менять.
   chelentano
 
3 - 16.04.18 - 11:09
Очевидно, что ТекРод не найден
   GrVas
 
4 - 16.04.18 - 11:09
Разве родителем может быть другой справочник?
   GrVas
 
5 - 16.04.18 - 11:11
(4) ошибся 
не азметил строку  ТекРод = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Родитель, Истина);
   GrVas
 
6 - 16.04.18 - 11:12
наверно она джолжна быть 
 ТекРод = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Родитель.Наименование, Истина);
   Buster007
 
7 - 16.04.18 - 11:16
(2) а сколько было тем, что не рассчитывается отпуск из-за незаполненного производственного календаря из года в год?)
   Serg_1960
 
8 - 16.04.18 - 11:19
Прочитав "ТекРод = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Родитель, Истина);" долго смеялся. Спасибо, а то с утра настроение было никакое.

Замените эту смешную строку на "ТекРод = Выборка.Родитель;" или вообще ничего не пишите - Родитель и без этого всегда доступен.

PS: строки далее не комментирую - они годятся только если в качестве бреда.
   1sanekmaloi1
 
9 - 16.04.18 - 11:21
(6)(8) С чего вы взяли что у него там ссылка?
   1sanekmaloi1
 
10 - 16.04.18 - 11:24
(9)Отбой.Первую строку не увидел.
 
 Рекламное место пустует
   Serg_1960
 
11 - 16.04.18 - 11:30
(10) Угу. "Выборка.Ссылка.ЭтоГруппа" - справочник иерархический. Но даже если бы не эта строка, то "Родитель" - предопределенное свойство справочника.
   sidalexsandr
 
12 - 16.04.18 - 12:19
Сделал поиск по  коду и все заработало

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует