Вход | Регистрация


Как получить заголовок поля формы, если он берется из реквизита?

Как получить заголовок поля формы, если он берется из реквизита?
Я
   RomaH
 
16.04.18 - 10:56
Т.е. добавил на форму (в конфигураторе) реквизит

перетянул его на форму - создалось поле ввода с пустым заголовком

как получить заголовок реквизита?

ибо я перебираю в цикле элементы формы - из них генерю такс
 
 
   RomaH
 
1 - 16.04.18 - 10:59
пытаюсь сделать вот такое:

Функция ПолучитьТекстРезультата()
    
    Результат = Новый Массив;
    
    Для Каждого ПолеФормы Из Элементы Цикл
        
        Если Не ТипЗнч(ПолеФормы) = Тип("ПолеФормы") Тогда
            Продолжить;
        КонецЕсли;
        
        Если Не ПолеФормы.Вид  = ВидПоляФормы.ПолеПереключателя Тогда 
            Продолжить;
        КонецЕсли;

        Результат.Добавить(ПолеФормы.Заголовок + ": " + ЭтаФорма[ПолеФормы.ПутьКДанным]);
        
    КонецЦикла;
    
    Возврат СтрСоединить(Результат,Символы.ПС);
    
КонецФункции


   RomaH
 
2 - 16.04.18 - 10:59
но вот тут пусто
ПолеФормы.Заголовок
   RomaH
 
3 - 16.04.18 - 11:06
или может подскажете как добраться до коллекции реквизитов формы
   Darych
 
4 - 16.04.18 - 12:09
так задай заголовок в конфигураторе...
   RomaH
 
5 - 16.04.18 - 12:36
(4) это долго
   RomaH
 
6 - 16.04.18 - 12:38
(4) у меня 100 форм таких, с количеством реквизитов до 100

получается - создаю реквизит формы
кидаю его на форму - и туда надо копипасту сделать из заголовка реквизита в заголовок поля - лишние действия
   Darych
 
7 - 16.04.18 - 22:04
(6) ну да.. а ты хочешь и рыбку и т д д?
   RomaH
 
8 - 17.04.18 - 07:41
(7) ты вот зачем это пишешь?
   Darych
 
9 - 17.04.18 - 08:09
(7) чтобы до тебя дошло, что если заголовок пуст, то хрен ты чего получишь. Вот зачем ты наркотики употребляешь?
   FIXXXL
 
10 - 17.04.18 - 08:58
(0) "прочитай" синоним самого реквизита
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует