Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Медленная печать чека из УТ 11.3

Медленная печать чека из УТ 11.3
Я
   FadeevaElena
 
15.04.18 - 10:37
Уважаемые коллеги!

Вдруг в какой-то день касса начинает работать очень медленно. Если внутрь поставить мини-лог, то тормозит на строке кода:

МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПоИдентификатору(Новый ОписаниеОповещения("НачатьПодключениеОборудованиеПоИдентификаторуЗавершение", ЭтотОбъект, Оборудование), УникальныйИдентификатор, Оборудование);

Висит на этом минуту-две, потом все быстро.

Лечится форматом С компа, переустановкой всего оборудования.
Просто переустановить кассу не помогает без формата С.

А сегодня в магазине праздник и вот это случилось!

Меня уволят нафик!

Хелп!
Может где-то что-то почистить, быстро переустановить?
Вижу что много у кого такое случалось, да и у нас не в первый раз, форматировали компы касс.
Но сейчас я переустановить не могу, воскресенье, в ЦТО выходной и банк свой эквайринговый терминал удаленно не установит, а я только формат С сделать смогу, всегда все эти службы всё делали.
 
 
   МимохожийОднако
 
1 - 15.04.18 - 11:43
(0) "переустановить кассу не помогает без формата С.
...Меня уволят нафик!" Обалдеть...
Трудно было позавчера написать об этом?
   Mkamha
 
3 - 15.04.18 - 12:21
(0) удалить базу в SQL, пересоздать, оставить на ночь на индексацию, утром проверить.
Включить выключить кассу. Поставить SSD.
   isa2net
 
4 - 17.04.18 - 17:54
(0) как подключена касса: юсб, езернет, модель ккт, дрова , база файловая, где лежит, работаете из рмк?
   cw014
 
5 - 17.04.18 - 17:56
МенеджерОборудованияКлиент.НачатьПодключениеОборудованиеПоИдентификатору - а F11 дает что нибудь на этой строке в отладке?
   isa2net
 
6 - 17.04.18 - 17:58
(5) так там в описаниеоповещения указана следующая процедура
   cw014
 
7 - 17.04.18 - 18:00
(6) Я вот не нашел такого метода конфигурации. Да и суффикс "Клиент" намекает, что это вероятнее всего общий модуль как бэ. Может внутри его что-то тормозит?
   isa2net
 
8 - 17.04.18 - 18:17
(7) там примерно это идет
[1c]
Если РезультатПодключения.Результат Тогда  
        ВходныеПараметры  = Неопределено;
        ВыполняемаяКоманда = Параметры.ВыполняемаяКоманда;
        Если (ВыполняемаяКоманда = "CheckFiscalization") И (Параметры.ОповещениеПослеОткрытииЧека <> Неопределено) Тогда
            ОписаниеОповещения = Новый ОписаниеОповещения("НачатьВыполнениеКоманды_ВыполнитьКомандуЗавершение", ЭтотОбъект, Параметры);
            НачатьВыполнениеКомандыПечатиЧека(ОписаниеОповещения, Параметры.ИдентификаторУстройства, ВыполняемаяКоманда, Параметры, Параметры.ВходныеПараметры);
        Иначе
            ОписаниеОповещения = Новый ОписаниеОповещения("НачатьВыполнениеКоманды_ВыполнитьКомандуЗавершение", ЭтотОбъект, Параметры);
            НачатьВыполнениеКоманды(ОписаниеОповещения, Параметры.ИдентификаторУстройства, ВыполняемаяКоманда, Параметры.ВходныеПараметры);
        КонецЕсли;
    Иначе
        Если Параметры.ОповещениеПриЗавершении <> Неопределено Тогда
            ТекстСообщения = НСтр("ru='При подключении оборудования произошла ошибка: %ДополнительноеОписание%'");
            ТекстСообщения = СтрЗаменить(ТекстСообщения, "%ДополнительноеОписание%", РезультатПодключения.ОписаниеОшибки);
            РезультатОперации = ПараметрыВыполненияОперацииНаОборудовании(Ложь, ТекстСообщения);
            РезультатОперации.ИдентификаторУстройства = Параметры.ИдентификаторУстройства;
            ВыполнитьОбработкуОповещения(Параметры.ОповещениеПриЗавершении, РезультатОперации);
        КонецЕсли;
    КонецЕсли;

[/]
   Garykom
 
9 - 17.04.18 - 18:25
(0) Сервер терминалов через инет?

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует