Вход | Регистрация

1С:Предприятие ::

Метки: 

Не устанавливается значение константы в УТ 11

Я
   Dimarik_1
 
13.04.18 - 22:33
Сейчас попробовал в УТ 11 программно установить значение константы.
Объект записывается в базу, но когда заходишь сам вручную проверить (или программно), константа не поменяла своего значения.


почему запись не работает, не понятно



&НаСервере
Процедура ЗаписатьКонстантуНаСервере()
    // Вставить содержимое обработчика.

    
    Константа = "ИспользоватьНесколькоОрганизаций";
        КонстантаМенеджерЗначения = Константы[Константа].СоздатьМенеджерЗначения();
        КонстантаМенеджерЗначения.Значение =Истина;
        ЗаписатьОбъектВИБ(КонстантаМенеджерЗначения, ТипЗнч(КонстантаМенеджерЗначения));

    
КонецПроцедуры

&НаКлиенте
Процедура ЗаписатьКонстанту(Команда)
    ЗаписатьКонстантуНаСервере();
КонецПроцедуры
Процедура ЗаписатьОбъектВИБ(ОбъектКонст, Тип)
        
    Попытка
        
        
        ОбъектКонст.ОбменДанными.Загрузка = Истина;
        Объект.Записать();
        
    Исключение
        
        
        
    КонецПопытки;
    
КонецПроцедуры
 
 
   Fragster
 
1 - 13.04.18 - 22:38
ОбъектКонст.ОбменДанными.Загрузка = Истина;
        Объект.Записать();
записываешь не объектконст, а реквизит формы Объект.
   Fragster
 
2 - 13.04.18 - 22:38
предложение по подсветке глобальных переменных у 1с "записано"
   Доминошник
 
3 - 13.04.18 - 22:53
А зачем дополнительно вызывать ЗаписатьОбъектВИБ?

Ведь достаточно и так:
    Константа = "ИспользоватьНесколькоОрганизаций";
    КонстантаМенеджерЗначения = Константы[Константа].СоздатьМенеджерЗначения();
    КонстантаМенеджерЗначения.Значение =Истина;
    КонстантаМенеджерЗначения.Записать();
   Fragster
 
4 - 13.04.18 - 22:57
да и зачем создавать менеджер значения тоже непонятно, ведь есть
КонстантаМенеджер.<Имя константы> (ConstantManager.<Имя константы>)
Установить (Set)
Синтаксис:

Установить(<Значение>)
Параметры:

<Значение> (обязательный)

Тип: Произвольный.
Новое значение константы.
Описание:

Устанавливает значение константы в базе данных.

Доступность:

Сервер, толстый клиент, внешнее соединение, мобильное приложение(сервер).
Пример:

Константы.Бухгалтер.Установить("Сидоров Петр Иванович");
   Defender aka LINN
 
5 - 13.04.18 - 23:22
(0) Код делает следующее:
1. Создал менеджер значения константы.
2. Присвоил значение.
Далее менеджер спускается в унитаз.
3. Вызывается процедура "ЗаписатьОбъектВИБ", где
4.1 Одному объекту устанавливается "ОбменДанными.Загрузка = Истина"
4.2 Другой объект записывается.

Тебе реально хочется услышать, где ошибка?
   Fragster
 
6 - 13.04.18 - 23:27
(5) еще веселее, когда у формы есть реквизит "результат" ипа число, и в коде типа 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать(); <- вот тут внезапное исключение :)
   Defender aka LINN
 
7 - 13.04.18 - 23:33
(6) Ну, это легко ж отла... Хотя да, о чем это я.


Список тем форума
Рекламное место пустует Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует