Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

НайтиФайлы() ищет только на сервере

НайтиФайлы() ищет только на сервере
Я
   Dendroid92
 
13.04.18 - 15:06
Всем привет!
Использую клиент-серверную архитектуру 1С. Столкнулся с проблемой, что функция НайтиФайлы() начинает искать файлы в каталоге на сервере, а надо на клиенте. Что делаю не так?
 
 
   Cool_Profi
 
1 - 13.04.18 - 15:07
Ну так выполняй её НаКлиенте...
Только учти, что на тонком клиенте она недоступна
   Dendroid92
 
2 - 13.04.18 - 15:11
(1) выполняя на клиенте и у меня как раз тонкий клиент(
   Cool_Profi
 
3 - 13.04.18 - 15:13
Наврал про доступность, каюсь...
Поставь #Если Клиент и сообщить типа я на клиенте.... Проверь
   Вафель
 
4 - 13.04.18 - 15:16
(2) код в студию
   Dendroid92
 
5 - 13.04.18 - 15:16
(3)
&НаКлиенте
Процедура ЗагрузитьФайлыИзКаталога(Команда)
//ПоискИЗаменаФайлов();

СписокДоговоров = ПолучитьСписокДоговоров();
НайденныеФайлы = НайтиФайлы(Объект.ПутьККаталогу, СписокДоговоров[0].Значение + ".pdf");
Если НайденныеФайлы.Количество() > 0 Тогда
    Сообщить("Файл найден!");
КонецЕсли;
КонецПроцедуры

Что тут поменять?
   Вафель
 
6 - 13.04.18 - 15:16
у тебя случайно не веб клиент?
   Вафель
 
7 - 13.04.18 - 15:17
Ты конкретный файл ищещь? но зачем?
   Cool_Profi
 
8 - 13.04.18 - 15:17
(5) Сообщить(Объект.ПутьККаталогу) ?
   Вафель
 
9 - 13.04.18 - 15:19
А может вообще стоит запрет синхронных действий? ошибок не выскакиевает?
   Dendroid92
 
10 - 13.04.18 - 15:21
(6) нет
(7) Потому что нужен конкретный файл из каталога, Новый Файл(<Здесь путь к файлу>) тоже не работает
(9) Как проверить?
 
 Рекламное место пустует
   tesseract
 
11 - 13.04.18 - 15:23
(5) Это синхронный вызов.

    ОповещениеФайлыНайдены = Новый ОписаниеОповещения("ОповещениеФайлыНайдены",ЭтаФорма,Неопределено);
    состояние              = "Поиск файлов";
    НачатьПоискФайлов(ОповещениеФайлыНайдены,ПутьЗагрузки,"*.расширение",Истина);
   Dendroid92
 
12 - 13.04.18 - 15:27
(11) а как процедура ОповещениеФайлыНайдены должна выглядеть?
   tesseract
 
13 - 13.04.18 - 15:29
(12)&НаКлиенте
Процедура ОповещениеФайлыНайдены(ВыбранныеФайлы,ДополнительныеПараметры)  Экспорт
    
    Если ВыбранныеФайлы = Неопределено Тогда 
        Возврат;
    КонецЕсли;    
    
    Если ВыбранныеФайлы.Количество()=0 Тогда 
        Возврат;
    КонецЕсли;    
    
    МассивПомещаемых = Новый Массив();
    
    Для Каждого ФайлЗагрузки Из ВыбранныеФайлы Цикл 
        МассивПомещаемых.Добавить(Новый ОписаниеПередаваемогоФайла(ФайлЗагрузки.ПолноеИмя));
    КонецЦикла;    
    
    ПомещениеФайловЗавершение = Новый ОписаниеОповещения("ОповещениеЗагрузитьФайлы",ЭтаФорма);
    
    НачатьПомещениеФайлов(ПомещениеФайловЗавершение, МассивПомещаемых, , Ложь,УникальныйИдентификатор);

        
КонецПроцедуры
   Dendroid92
 
14 - 13.04.18 - 15:34
(13) Спасибо за помощь, но опять, в файловой версии ищет, на клиент-серверной нет=(
   Dendroid92
 
15 - 13.04.18 - 15:35
(13)

&НаКлиенте
Процедура ЗагрузитьФайлыИзКаталога(Команда)
СписокДоговоров = ПолучитьСписокДоговоров();
ОповещениеФайлыНайдены = Новый ОписаниеОповещения("ОповещениеФайлыНайдены",ЭтаФорма,Неопределено);
состояние              = "Поиск файлов";
НачатьПоискФайлов(ОповещениеФайлыНайдены,Объект.ПутьККаталогу, СписокДоговоров[0].Значение + ".pdf",Истина);
КонецПроцедуры

&НаКлиенте
Процедура ОповещениеФайлыНайдены(ВыбранныеФайлы,ДополнительныеПараметры)  Экспорт
    Если ВыбранныеФайлы.Количество() > 0 Тогда
        Сообщить("Файл найден!");
    КонецЕсли;
КонецПроцедуры

Писал так
   Вафель
 
16 - 13.04.18 - 15:38
Для 1 файла есть Файл.существует
   dezss
 
17 - 13.04.18 - 15:39
показывай пути и имя файла...
   dezss
 
18 - 13.04.18 - 15:39
(17) + попробуй поискать без имени файла
   Dendroid92
 
19 - 13.04.18 - 15:43
(16) Я уже писал, что оба случая на клиент-сервере мне ничего не возвращают, т.к. похоже что оба способа ищут на сервере, где естественно этого пути нет. А мне надо на клиенте искать файлы
   Вафель
 
20 - 13.04.18 - 15:44
(19) не может такого быть
   Dendroid92
 
21 - 13.04.18 - 15:44
(18) какая разница указываю я имя или нет? в файловой версии же все ищет, дело не в имени файла
   dezss
 
22 - 13.04.18 - 15:52
(21) а процедура эта где расположена?
   dezss
 
23 - 13.04.18 - 15:52
(22) + случайно не о общем модуле?
   Вафель
 
24 - 13.04.18 - 15:54
судю потому что там Команда, то в модуле формы
   dezss
 
25 - 13.04.18 - 15:57
(24) ну мало ли...
тогда кэш продуть...
   dezss
 
26 - 13.04.18 - 15:57
(25) + и кстати, проверить (3)
   tesseract
 
27 - 13.04.18 - 15:58
(21) Дело в том, что ты не понимаешь, что делаешь. Префикс &НаКлиенте скорее всего забыл.
   1sanekmaloi1
 
28 - 13.04.18 - 16:26
Если лень разбираться, сделай папку доступной по сети и с сервера ищи, делов то.
   aka AMIGO
 
29 - 13.04.18 - 16:50
А что, ребята, сервер не возвратит имя файла на клиента-то?
Ну, нашел - и нашел.. И возвратил..
ИМХО, конечно
   tesseract
 
30 - 13.04.18 - 16:50
(29) ИСЧО один.
   aka AMIGO
 
31 - 13.04.18 - 16:51
(30) Я понял :)
   Вафель
 
32 - 13.04.18 - 16:53
(27) судя по коду не забыл


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует