Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Как узнать, какие справочники подчинены текущему?

v7: Как узнать, какие справочники подчинены текущему?
Я
   Марк_З
 
13.04.18 - 14:26
Подскажите, пожалуйста: как программно узнать, каке справочники подчинены текущему справочнику (например, какие справочники подчинены спр.Контрагенты)? Где этот реквизит в метаданных?
Наверное, надо читать в метаданных справочники и там должен быть указатель на то, что, типа, "справочник У подчинен справочнику Х". Как этот реквизит/описатель/функция называются?
 
 
   Cool_Profi
 
1 - 13.04.18 - 14:27
владелец, не?
   Марк_З
 
2 - 13.04.18 - 14:34
(1) Про "владельцев" я знаю.
Пишу программку, которая сможет удалять элементы главного справочника (скажем -- Контрагенты) и подчиненных (в данном случае -- Денежные счета). Справочники не заданы явно. И я не знаю, как программке узнать, какие справочники подчинены указанному выбранному.
Т.е. как 1С показывает "список подчиненных справочников" при нажатии на соответствующую кнопку на форме справочника?
   Cool_Profi
 
3 - 13.04.18 - 14:38
(2) ты не поверишь, но тебе нужно перечитать (1)
   Марк_З
 
4 - 13.04.18 - 14:44
(2) Т.е.  Метаданные.Справочник.Вид().Владелец  ?
   ADirks
 
5 - 13.04.18 - 14:44
во, нашёл тут

Функция сзПодчиненныеСправочники(Вид) Экспорт
    сзПодчиненные = СоздатьОбъект("СписокЗначений");
    Для нПодч = 1 По Метаданные.Справочник() Цикл
        МетаСпр = Метаданные.Справочник(нПодч);
        Если МетаСпр.Владелец.Выбран() = 1 Тогда
            Если МетаСпр.Владелец.Вид = Вид Тогда
            КонецЕсли;
            сзПодчиненные.ДобавитьЗначение(МетаСпр.Вид);
        КонецЕсли;
    КонецЦикла;

    Возврат сзПодчиненные;
КонецФункции
   Марк_З
 
6 - 13.04.18 - 14:46
(3,5) СПАСИБО!
   ADirks
 
7 - 13.04.18 - 14:46
вот только похоже, этот код никогда не использовался, ибо косячен  :))

не сразу заметил
   Марк_З
 
8 - 13.04.18 - 14:47
Попробую... )))
   ADirks
 
9 - 13.04.18 - 14:48
д.б. так


            Если МетаСпр.Владелец.Вид = Вид Тогда
                сзПодчиненные.ДобавитьЗначение(МетаСпр.Вид);
            КонецЕсли;
   Duke1C
 
10 - 15.04.18 - 14:09
(2) Таких "программок" вагон и маленькая тележка, или свой лисапед хочется?
 
 Рекламное место пустует

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует