Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Ошибка зацикливание уровней

Ошибка зацикливание уровней
Я
   sidalexsandr
 
13.04.18 - 12:20
Вот сообщение об ошибке:
{ВнешняяОбработка.ГруппыПоОбразцу.Форма.Форма.Форма(123)}: Ошибка при вызове метода контекста (Записать)
            ТекТоварчик.Записать();                       
по причине:
Зацикливание уровней!

Вот текст программы:
Выборка = Справочники.БП_ПрейскурантНаРаботы.Выбрать();
    Пока Выборка.Следующий() Цикл
        
        // 13.04.18 Репнин А.В.

        // пропустить товар, который вне групп

        Если Выборка.Наименование = "Компенсация командировочных затрат инженера выездного ремонта" Тогда
            Продолжить;
        КонецЕсли;
        
        Если Выборка.Ссылка.ЭтоГруппа = Истина Тогда
            // 13.04.18 Репнин А.В.

            // группы уже созданы пропустить группы

            Продолжить;
        КонецЕсли;
        
                                        
            ТекР = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Родитель, Истина);
            Сообщить("Выборка.Наименование = " + Выборка.Наименование);
            ТекРод = ТекР;
            Сообщить("ТекРод = " + ТекРод);
            ТекТов = Справочники.Номенклатура.НайтиПоНаименованию(Выборка.Работа, Истина);
            ТекТоварчик = ТекТов.ПолучитьОбъект();
            ТекТоварчик.Родитель = ТекРод;
            ТекТоварчик.Записать();                       
                
            
    КонецЦикла;
 
 
   PR
 
1 - 13.04.18 - 12:21
Так так, интересно
Не останавливайся
   Рэйв
 
2 - 13.04.18 - 12:25
(0)Мало того, что у тебя в Выборка.Родитель уже есть родитель, так ты его еще и ищешь подставляя вместо наименования...

Занятные грибы.
   Малыш Джон
 
3 - 13.04.18 - 12:54
(2) ну судя по особому пристрастию ТС к наименованию, предположу, что в "Выборка.Родитель" хранится наименование родителя

(0) ты сами то данные выборки проверял?
а то вдруг у тебя в одной строке: Работа = Ном1, Родитель = Ном2, а в другой  - наоборот? Ну или наименования вообще задваиваются?
   DmitriyDI
 
4 - 13.04.18 - 12:57
(0) ты родителю ставишь его же в группу...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует