Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как преобразовать строку в дату или другой вид строки

Как преобразовать строку в дату или другой вид строки
Я
   leepin
 
13.04.18 - 10:38
Есть строка с такими данными:"0001-01-01T12:34:12", как ее преобразовать так чтоб было 00010101123412 ну или полноценно в тип "Дата".
 
 
   Fish
 
1 - 13.04.18 - 10:39
(0) Убрать всё лишнее и преобразовать.
   Aleksey
 
2 - 13.04.18 - 10:39
ВходнойПараметр = "0001-01-01T12:34:12"
ВходнойПараметр = СтрЗаменить(ВходнойПараметр,"-","");
ВходнойПараметр = СтрЗаменить(ВходнойПараметр,":","");
ВходнойПараметр = СтрЗаменить(ВходнойПараметр,"T","");
НашаДата = Дата(ВходнойПараметр)
   PR
 
3 - 13.04.18 - 10:40
Народ тупеет

СтрЗаменить(СтрЗаменить(СтрЗаменить(МояСтрока, "-", ""), "T", ""), ":", "")
   catena
 
4 - 13.04.18 - 10:44
ПрочитатьДатуJSON("0001-01-01T12:34:12", ФорматДатыJSON.ISO)
   Йохохо
 
5 - 13.04.18 - 10:48
Формат(xmlЗначение(тип("дата"), "0001-01-01T12:34:12"),"ДЛФ=DDT")
   RomaH
 
6 - 13.04.18 - 10:58
ЗначениеXML(Тип("Дата"),"0001-01-01T12:34:12")
   Connect
 
7 - 13.04.18 - 10:59
Функция СтрокаДата(НашаСтрока)
    
    НашаСтрока = "0001-01-01T12:34:12";
    
    ВыходнаяСтрока = "";
    
    Для й = 1 По СтрДлина(НашаСтрока) Цикл
        Символ = Сред(НашаСтрока, й, 1);
        Если ЭтоЦифра(Символ) Тогда
            ВыходнаяСтрока = ВыходнаяСтрока + Символ;
        КонецЕсли;
    КонецЦикла; 
    
    Возврат Дата(ВыходнаяСтрока);
    
КонецФункции

Функция ЭтоЦифра(Символ)
    КодСимвола = КодСимвола(Символ);
    Возврат (КодСимвола >= 48 И КодСимвола <= 57)
КонецФункции
   AlexTim03
 
8 - 13.04.18 - 12:13
(6)  - самый верный вариант!
Получится дата.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует