Вход | Регистрация


униерсальный отчет "Цены по контрагенту", в группах номенклатуры цены , как убрать ?

униерсальный отчет "Цены по контрагенту", в группах номенклатуры цены , как убрать ?
Я
   Gen833
 
12.04.18 - 11:06
Отчет "Цены по контрагенту" через универсальный отчет, вывожу номенклатуру (иерархия), напротив цена, все отлично. НО, напротив групп номенклаутры цены, как это убрать? Кто-то сталкивался с подобным? Возможные пути решения данной проблемы?
 
 
   ildary
 
1 - 12.04.18 - 11:13
(0) "Покажи на этой кукле где он тебя трогал". Нужен скриншот неверного отчета с пояснением "где неправильно и как должно быть правильно".
   Gen833
 
2 - 12.04.18 - 11:20
А как сюда скриншот  вставить подскажите  пож.
   lodger
 
3 - 12.04.18 - 11:21
(2) выкладываешь на внешнем хостинге и даешь сюда ссылку.
   Gen833
 
4 - 12.04.18 - 11:22
PREMIUM                                   59,90
Эмаль алкидная белая 0,8кг           59,90
    
    
SNANDART(Smile :))(всех по 6шт)            1 179,75
Алая 0,9кг Эмаль ПФ-115  Smile :)    39,93
Алая 2,8кг эмаль ПФ-115  Smile :)    114,35
Бежевая 0,9кг Эмаль ПФ-115  Smile :)    40,29
Бежевая 2,8кг Эмаль ПФ-115  Smile :)    116,16
Белая 0,47кг Эмаль ПФ-115  Smile :)    29,04

Короче выводит так, папки номенклатуры "PREMIUM" и "SNANDART(Smile :))" , мне без цен группах папок номенклатуры надо...
   Gen833
 
5 - 12.04.18 - 11:25
в группах номенклатуры цены не должно быть*
   Gen833
 
6 - 12.04.18 - 11:27
Может где-то условие попробовать на "этогруппа", тогда пустое значение?
   Gen833
 
7 - 12.04.18 - 11:37
Короче у меня реализовано через общие итоги, и цена как ресурс. Поэтому и в группах номенклатуры выводится цена (максимльная- как указана в запросе) из элементов группы. Как выйти из это ситуации? Буду рад если кто-то подскажет...

Если убрать итоги, тогда и цена не выводится...
   Gen833
 
8 - 12.04.18 - 14:08
Вот решение, может кто-то столкнется с такой же проблемой:

Процедура СформироватьОтчет(ТабличныйДокумент) Экспорт
    
    // Перед формирование отчета можно установить необходимые параметры универсального отчета.

    УниверсальныйОтчет.СформироватьОтчет(ТабличныйДокумент);
    
    НомерКолонки = 0;
    Для а = 1 по ТабличныйДокумент.ВысотаТаблицы Цикл
        Для б = 1 по ТабличныйДокумент.ШиринаТаблицы Цикл
            текстЯчейка = ТабличныйДокумент.Область("R"+а+"C"+б).Текст;
            Если текстЯчейка = "Артикул" Тогда
                НомерКолонки = б;
                Прервать;
            КонецЕсли;
        КонецЦикла;
        Если НомерКолонки > 0 Тогда
            Прервать;
        КонецЕсли;
    КонецЦикла;
    
    Если НомерКолонки > 0 Тогда
        Для а = 8 по ТабличныйДокумент.ВысотаТаблицы Цикл
            Если Строка(ТабличныйДокумент.Область("R"+СтрЗаменить(а, Символы.НПП, "")+"C" + НомерКолонки).ЦветФона)="стиль: Фон кнопки" И
                 ТабличныйДокумент.Область("R"+СтрЗаменить(а, Символы.НПП, "")+"C" + НомерКолонки).Текст <> "Артикул" Тогда
                ТабличныйДокумент.Область("R"+СтрЗаменить(а, Символы.НПП, "")+"C" + НомерКолонки).Текст="";
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
    //нс


КонецПроцедуры// СформироватьОтчет()



Очищает поля груп...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует