Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

Как поймать запись объекта через план обмена?

Как поймать запись объекта через план обмена?
Я
   dwarfadelic
 
11.04.18 - 14:11
Обмен идет периодически через заданный план обмена. Как поймать момент перед записью и после записи объектов через этот план? Я попробовал поставить подписку на ОбработкаЗаполнения.

Процедура ОбработкаЗаполненияНоменклатурыОбработкаЗаполнения(Источник, ДанныеЗаполнения, ТекстЗаполнения, СтандартнаяОбработка) Экспорт
    // Вставить содержимое обработчика.

    // Вставить содержимое обработчика.

    Текст = Новый ТекстовыйДокумент;
    //Директория = КаталогДокументов()+"отчеты\";

    Директория = "E:\отчеты\";
    
    КаталогНаДиске = Новый Файл(Директория);
    Если не КаталогНаДиске.Существует() Тогда   
        СоздатьКаталог(Директория);
    КонецЕсли;
    
    ПолноеИмяФайла = Директория + СтрЗаменить(СтрЗаменить(Строка(ТекущаяДата()),":","-"),".","_")+".txt";
    //ФайлОтчета = Новый Файл(ПолноеИмяФайла);

    //Если ФайлОтчета.Существует() Тогда

    //    Текст.Открыть(ПолноеИмяФайла);

    //КонецЕсли;

    Текст.ДобавитьСтроку(Строка(Источник));      
    Текст.ДобавитьСтроку(Строка(ДанныеЗаполнения));
    Текст.ДобавитьСтроку(Строка(ТекстЗаполнения));

    Текст.Записать(ПолноеИмяФайла);

    
КонецПроцедуры

Попробовал. Но не удается найти сам файл.
 
 
   Cyberhawk
 
1 - 11.04.18 - 14:14
Какой-то файл и "запись через план обмена" - ахтунг
   _stay true_
 
2 - 11.04.18 - 14:15
ТС, больше информации: что за конфа, сакральный смысл сего экшена и.т.п.
   dwarfadelic
 
3 - 11.04.18 - 14:24
УПП. Нужно сделать протокол обмена. Там есть база УПП есть PLM там есть справочнег Номенклатура. И между ними происходит обмен периодически. Нужно сделать протокол обмена - то есть инфа какие свойства изменялись при изменении объектов либо добавлении новых.
   Serg_1960
 
4 - 11.04.18 - 14:26
Расходимся - это тема только для телепатов Волшебного Форума :)
   piter3
 
5 - 11.04.18 - 14:26
22
   dwarfadelic
 
6 - 11.04.18 - 14:28
Управление производственным предприятием
   dwarfadelic
 
7 - 11.04.18 - 14:29
   Cyberhawk
 
8 - 11.04.18 - 14:30
Сколько платят за решение вопроса?
   dwarfadelic
 
9 - 11.04.18 - 14:30
Задание по работе
   Йохохо
 
10 - 11.04.18 - 14:30
(4) "УПП .. там есть база УПП" автор просто начал с азов, вон и (6) уже
ЗЫ "справочнег" у Асмоди с ютф поломался фильтр удава?)
 
 Рекламное место пустует
   dwarfadelic
 
11 - 11.04.18 - 14:31
Главное - с чего начать? Через что ловить момент? Лучше чтобы не менять код
   Ёпрст
 
12 - 11.04.18 - 14:33
(0) настрой штатное версионирование объектов. Усё.
Ничего руками не трогай.
Код из (0)  выкинь на помойку.
   dwarfadelic
 
13 - 11.04.18 - 14:41
Не подойдет. Лишняя память.
   Ёпрст
 
14 - 11.04.18 - 14:43
(13) че ?
   Ёпрст
 
15 - 11.04.18 - 14:43
какая память ?
   piter3
 
16 - 11.04.18 - 14:43
33
   Ёпрст
 
17 - 11.04.18 - 14:44
тебе жалко записей в рег сведений ? Нужно винт дрюкать самодельной записью ?
   Мандалай
 
18 - 11.04.18 - 14:44
(13)Че?
   Ёпрст
 
19 - 11.04.18 - 14:44
удачи
   Serg_1960
 
20 - 11.04.18 - 14:46
(11) У планов обмена есть обработчики "ПриПолученииДанных..."  - там и лови изменения справочника Номенклатуры.
   Serg_1960
 
21 - 11.04.18 - 14:54
Штатное версионирование объектов, в принципе, можно задействовать, но нерационально. Версионирование работает через подписку на события (ВерсионированиеОбъектов_ПриЗаписиОбъекта) - можно там добавить свои хотелки, рюшечки и бантики.
   dwarfadelic
 
22 - 11.04.18 - 14:55
Нужно только когда через план обмена, а не вообще если вручную
   Serg_1960
 
23 - 11.04.18 - 14:58
+(21) Но если хочется анализировать, что именно изменяется в объекте и писать протокол изменений, - это не совсем то место, с которого можно было бы искать решение.
   Serg_1960
 
24 - 11.04.18 - 15:03
(22) Теоретически, это не сложно выявить, если анализировать "АвторВерсии" и если настроить автоматический обмен под определенным, специально для этого созданным, пользователем.
   dwarfadelic
 
25 - 11.04.18 - 16:19
Пробовал ПриПолученииДанных - не помогает
   hhhh
 
26 - 11.04.18 - 16:49
(25) это называется - обезьяна с гранатой. Там если есть кто поблизости, скажи, чтобы отошли хотя бы метров на 40.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует