Вход | Регистрация


Таблица значение перебор строк

Таблица значение перебор строк
Я
   Enot_tut
 
11.04.18 - 08:19
Есть 2 таблицы значения полностью одинаковые, есть формула.
Пробегаю по первой таблице но также надо получить значения с другой таблицы 
Для Каждого СтрокаПродаж Из ЗаказПродажиЗа14д Цикл
        Для Каждого КолонкаПродаж Из ЗаказПродажиЗа14д.Колонки Цикл
            Если КолонкаПродаж.Имя = "Товар" тогда 
            иначе
                СтрокаПродаж[КолонкаПродаж.Имя]; 
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
 
 
   catena
 
1 - 11.04.18 - 08:22
Вопрос-то в чем?
   Enot_tut
 
2 - 11.04.18 - 08:23
(1) как сделать вот такой цикл ТЗ[НомерСтроки][НомерКолонки]?
   Юдо-Рептилия
 
3 - 11.04.18 - 08:25
(2) ТЗ[НомерСтроки].Получить(НомерКолонки)
   МимохожийОднако
 
4 - 11.04.18 - 08:25
(2) Опиши ВСЮ задачу, а не предполагаемое решение.
   Enot_tut
 
5 - 11.04.18 - 08:37
(4) всю не буду уж описывать на том месте где остановился опишу, есть 2 таблицызначения (в одной храниться остаток, в другой продажи, колонки по наименованию одинаковы) создал третью таблицу там есть формула( строкаПервойтаблицы"допустим мафин"/14*3*1,5-СтрокаДругойТаблицы"также мафин"

вот как заполнить 3 таблицу?
   Enot_tut
 
6 - 11.04.18 - 08:44
а все решил задачу всем спасибо
   Enot_tut
 
7 - 11.04.18 - 08:45
Для Каждого СтрокаПродаж Из ЗаказПродажиЗа14д Цикл
        Для Каждого КолонкаПродаж Из ЗаказПродажиЗа14д.Колонки Цикл
            Если КолонкаПродаж.Имя = "Товар" тогда 
                НайтиСтрока = ОстаткиНаТТбез0.Найти(СтрокаПродаж[КолонкаПродаж.Имя]);
            иначе
            тест =    СтрокаПродаж[КолонкаПродаж.Имя]; 
            тест1 = НайтиСтрока[КолонкаПродаж.Имя]; 
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;
 вот код может кому либо пригодиться
   stix2010
 
8 - 11.04.18 - 09:32
ппц, алгоритм.
- объединить 2 таблицы, свернуть по номенклатуре, и одним циклом расчитать или запросом все тоже .

Список тем форума
Рекламное место пустует  Рекламное место пустует
Чтобы обнаруживать ошибки, программист должен иметь ум, которому доставляет удовольствие находить изъяны там, где, казалось, царят красота и совершенство.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует