Вход | Регистрация


Заказ - наряд при создании программно не выводит Товары, Материалы, Зарплата

Заказ - наряд при создании программно не выводит Товары, Материалы, Зарплата
Я
   Tchudesnik
 
10.04.18 - 14:21
Делаю заказ-наряд на основание Заказа-покупателя.
При выводе заказ наряда не выводит вкладки Товары, Материалы, Зарплата, в настройках пользователя все включил. При создание нового из программы выводит все корректно, а именно с моей команды нет.
Унф 1.6.11.49
8.3.10

Кодик прилагается.

&НаСервере
Функция СоздатьЗН()
    
    СекундыВЧасе = 60 * 60;
    новыйДок = Документы.ЗаказПокупателя.СоздатьДокумент();
    новыйДок.ВидОперации = Перечисления.ВидыОперацийЗаказПокупателя.ЗаказНаряд;
    новыйДок.Запасы.Видимость = истина;
    новыйДок.МатериалыЗаказчика.Видимость = Истина;
    новыйДок.Исполнители.Видимость = истина;
    
    новыйДок.Дата = ТекущаяДата();
    новыйДок.Организация = Объект.Организация;
    новыйДок.Контрагент = Объект.Контрагент;
    новыйДок.ВидЗаказа = Справочники.ВидыЗаказНарядов.НайтиПоНаименованию("Основной");
    новыйДок.СостояниеЗаказа = Справочники.СостоянияЗаказНарядов.НайтиПоНаименованию("В работе");
    новыйДок.Договор = Объект.Договор;
    новыйДок.Старт = ТекущаяДата();
    новыйДок.Финиш = ТекущаяДата() + СекундыВЧасе;
    новыйДок.Ответственный = Объект.Ответственный;
    новыйДок.ПлатежныйКалендарь.Загрузить(Объект.ПлатежныйКалендарь.Выгрузить());
    ТабУслуг = новый ТаблицаЗначений;
    ТабУслуг.Колонки.Добавить("Номенклатура");
    ТабУслуг.Колонки.Добавить("Кратность");
    ТабУслуг.Колонки.Добавить("Коэффициент");
    ТабУслуг.Колонки.Добавить("Количество");
    ТабУслуг.Колонки.Добавить("Цена");
    ТабУслуг.Колонки.Добавить("Сумма");
    
    Для каждого СтрокаТЗ из Объект.Запасы Цикл
        Если СтрокаТЗ.Номенклатура.ТипНоменклатуры = Перечисления.ТипыНоменклатуры.Услуга Тогда
            Стр = ТабУслуг.Добавить();
            Стр.Номенклатура = СтрокаТЗ.Номенклатура;
            Стр.Цена = СтрокаТЗ.Цена;
            Стр.Сумма = СтрокаТЗ.Сумма;
            Стр.Кратность = 1;
            Стр.Коэффициент = 1;
            Стр.Количество = 1;
        КонецЕсли;
    КонецЦикла;
    
    новыйДок.Работы.Загрузить(ТабУслуг);
    новыйДок.Записать();
    Возврат новыйДок.Ссылка;
КонецФункции


&НаКлиенте
Процедура Расш1_ЗаказНарядПеред(Команда) 
    СсылкаОбъекта = СоздатьЗН();
    СсылкаДока = новый Структура ("Ключ", СсылкаОбъекта);
    ОткрытьФорму("Документ.ЗаказПокупателя.ФормаОбъекта",СсылкаДока);
КонецПроцедуры

помогите не опытному.
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует