Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Имя/идентификатор рисунка табличного документа

Имя/идентификатор рисунка табличного документа
Я
   triviumfan
 
10.04.18 - 12:31
Доброго дня!
Гуглю уже полчаса, нашёл что-то подобное - https://www.forum.mista.ru/topic.php?id=440028
Не помогает.

И все-таки почему при выводе табличного документа коллекция рисунков содержит свои имена рисунков, а не что я задал в конфигураторе? Все равно D1-Dn имена. Как с ним обращаться православно? В типовой вижу есть рисунки с именами "ШК", "Логотип" - так к ним корректное обращение в коде, а у меня имя "D", хотя я задал "ЗаголовокЛоготип"!
https://yadi.sk/i/oQ3Lv3HV3UGtJJ
https://yadi.sk/i/QvWdl4X-3UGtKW

Руки выпрямил - не помогает!
 
 
   zwei
 
1 - 10.04.18 - 12:42
1) Потому что макет и полученный по нему результат - совсем разные вещи. Совсем.
2) Потому что в результате они именуются по адресам ячеек результата. Всегда.
3) Потому что если в результате один рисунок из макета буден выведен несколько раз, то имена можешь свернуть в трубочку и засунуть. Поглубже.

Руки головой надо прямить, а не тем. Начиная с п1.
   triviumfan
 
2 - 10.04.18 - 13:49
(1) 1. Разумеется разный, но если бы вы посмотрели, к чему я обращаюсь, то увидели бы. Обращаюсь я к макету.
2. Обращение из типовой конфигурации УТ11:
Процедура ВывестиЛоготипВТабличныйДокумент(Макет, ОбластьМакета, ИмяОбласти, Организация)Экспорт
    
    ФайлКартинки = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Организация, "ФайлЛоготип");
    
    Если Не ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ОбластьМакета.Рисунки, "Логотип") Тогда
        // Картинки логотипа в этой области макета нет.

        
        Если Макет.Области.Найти(ИмяОбласти+"Логотип") <> Неопределено Тогда
            
            // Проверка картинки логотипа в области с логотипом

            ОбластьМакетаЛоготип = Макет.ПолучитьОбласть(ИмяОбласти+"Логотип");
            Если ОбщегоНазначенияУТКлиентСервер.ЕстьРеквизитОбъекта(ОбластьМакетаЛоготип.Рисунки, "Логотип") 
                И ЗначениеЗаполнено(ФайлКартинки) Тогда
                
                ОбластьМакета = ОбластьМакетаЛоготип;
            Иначе
                Возврат;
            КонецЕсли;
        Иначе
            Возврат;
        КонецЕсли;
        
    КонецЕсли;
    
    Если Не ЗначениеЗаполнено(ФайлКартинки) Тогда
        ОбластьМакета.Рисунки.Удалить(ОбластьМакета.Рисунки.Логотип);
        Возврат;
    КонецЕсли;
    
    ДвоичныеДанныеФайла = ПрисоединенныеФайлы.ПолучитьДвоичныеДанныеФайла(ФайлКартинки);
    
    Если ТипЗнч(ДвоичныеДанныеФайла) = Тип("Картинка") Тогда
        Картинка = ДвоичныеДанныеФайла;
    ИначеЕсли ТипЗнч(ДвоичныеДанныеФайла) = Тип("ДвоичныеДанные") Тогда
        Картинка = Новый Картинка(ДвоичныеДанныеФайла);
    Иначе
        Картинка = Новый Картинка;
    КонецЕсли; 
    
    ОбластьМакета.Рисунки.Логотип.Картинка = Картинка;
    
КонецПроцедуры

3. см. п1
   triviumfan
 
3 - 10.04.18 - 13:52
Обращение к именованной области именованного рисунка макета
   triviumfan
 
4 - 10.04.18 - 14:21
https://yadi.sk/i/6VJNE8-Q3UH9Gp
Никто не в курсе?) Ппц
   triviumfan
 
5 - 10.04.18 - 14:35
Отбой, оказалось, что я вообще другой макет смотрю хD

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует