Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Запись найденного элемента справочника

v7: Запись найденного элемента справочника
Я
   Denshu
 
06.04.18 - 14:11
Добрый день, есть следующий код
-------------------------------
СпрЭтапы = СоздатьОбъект("Справочник.disa_ЭтапыПриемки");
СпрЭтапы.ВыбратьЭлементы();
Пока СпрЭтапы.ПолучитьЭлемент() = 1 Цикл
   Если СпрЭтапы.ЗаказНаряд = ТекущийДокумент() Тогда
      НайденныйЭлемент = СпрЭтапы.ТекущийЭлемент();
   КонецЕсли;
КонецЦикла;

ТекСпрЭтапы = СоздатьОбъект("Справочник.disa_ЭтапыПриемки");
ТекСпрЭтапы.НайтиЭлемент(НайденныйЭлемент);
 
ТекСпрЭтапы.Состояние = "0";
ТекСпрЭтапы.Записать()
-----------------------
При этом создается новый элемент справочника, а не изменяется текущий, подскажите что делаю не так
 
 
   Масянька
 
1 - 06.04.18 - 14:13
(0) Извини, но как говорит Ёпрст - код в топку.
   Ёпрст
 
2 - 06.04.18 - 14:17
(0) при таком коде новый элемент справочника создасться не может, какая то из черепашек врЁт
   Масянька
 
3 - 06.04.18 - 14:24
(0) Для поиска в справочнике используй НайтиЭлемент() или НайтиПоРеквизиту() (если установлена сортировка).
   Kigo_Kigo
 
4 - 06.04.18 - 14:43
А так?
СпрЭтапы = СоздатьОбъект("Справочник.disa_ЭтапыПриемки");
СпрЭтапы.ВыбратьЭлементы();
Пока СпрЭтапы.ПолучитьЭлемент() = 1 Цикл
   Если СпрЭтапы.ЗаказНаряд = ТекущийДокумент() Тогда
      СпрЭтапы.Состояние = "0";
      СпрЭтапы.Записать()
   КонецЕсли;
КонецЦикла;
   Denshu
 
5 - 06.04.18 - 15:07
(4) Вроде норм

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует