Вход | Регистрация


Serv-U File Server и 1C

Serv-U File Server и 1C
Я
   Anisa8311
 
05.04.18 - 12:19
Коллеги, кто работал с Serv-U File Server как научить 1С дружить с этой передачей Ищу компетенции
 
 
   shuhard
 
1 - 05.04.18 - 12:20
(0) это же ftp сервер
   Cool_Profi
 
2 - 05.04.18 - 12:22
(0) Традиционно - позвать программиста. И не забыть заплатить ему
   shuhard
 
3 - 05.04.18 - 12:24
(2) или замотивировать иным способом =)
   g00d
 
4 - 05.04.18 - 12:29
(0) не понятно, что именно выхотите сделать? обмениваться через фтп папку? подключаться к http\https сервисам из 1с?
   shuhard
 
5 - 05.04.18 - 12:30
(4) [Род занятий:     РП]
чё ты хочешь, ТС побежала за аналитиком и архитектором
   g00d
 
6 - 05.04.18 - 12:32
(5) РП - руководитель проектов? Тогда все еще более странно, обычно люди этой профессии умеют четко формулировать задачи и мысль
   novichok79
 
7 - 05.04.18 - 12:39
Попытка
        FTPСоединение = Новый FTPСоединение(ПараметрыПрофиляНастроекЭДО.АдресСервера,
                                            ПараметрыПрофиляНастроекЭДО.Порт,
                                            ПараметрыПрофиляНастроекЭДО.Логин,
                                            ПараметрыПрофиляНастроекЭДО.Пароль,
                                            Прокси,
                                            ПараметрыПрофиляНастроекЭДО.ПассивноеСоединение,
                                            Таймаут);
    Исключение
        ШаблонРезультата = НСтр("ru = '%1
            |%2'");
        ТекстОшибки = ЭлектронноеВзаимодействиеСлужебныйПовтИсп.ПолучитьСообщениеОбОшибке("121");
        РезультатТеста = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонРезультата, ТекстОшибки,
            КраткоеПредставлениеОшибки(ИнформацияОбОшибке()));
        ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонСообщения, РезультатТеста);
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
        Возврат Неопределено;
    КонецПопытки;
    
    Если ЭтоТест Тогда
        РезультатТеста = НСтр("ru = 'Пройден успешно.'");
        ТекстСообщения = СтроковыеФункцииКлиентСервер.ПодставитьПараметрыВСтроку(ШаблонСообщения, РезультатТеста);
        ОбщегоНазначенияКлиентСервер.СообщитьПользователю(ТекстСообщения);
    КонецЕсли;
    
    Возврат FTPСоединение;



Процедура ПолучитьФайлСFTP(FTPСоединение, Источник, ИмяВыходногоФайла, ЭтоТест = Ложь, РезультатТеста = Неопределено) Экспорт
    
    Попытка
        FTPСоединение.Получить(Источник, ИмяВыходногоФайла);
    Исключение
        РезультатТеста = ЭлектронноеВзаимодействиеСлужебныйПовтИсп.ПолучитьСообщениеОбОшибке("128");
        
        Если НЕ ЭтоТест Тогда
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(РезультатТеста);
        КонецЕсли;
    КонецПопытки;
    
КонецПроцедуры
   shuhard
 
8 - 05.04.18 - 12:40
(6) РП на РП не приходиться =)
   Cool_Profi
 
9 - 05.04.18 - 12:41
Расходимся, в ветке английский террорист ))))))
   g00d
 
10 - 05.04.18 - 12:42
(7) а это что за яд?
 
 Рекламное место пустует
   novichok79
 
11 - 06.04.18 - 14:01
(10) это типовой код из ERP 2.4

Список тем форума
Рекламное место пустует  Рекламное место пустует
Читай всё полезное и впитывай, а нападки игнорируй. Здесь так принято. aka AMIGO
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует