Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Собрать один форматированный документ из двух

Собрать один форматированный документ из двух
Я
   Надмозг
 
03.04.18 - 18:56
Есть два значения типа ФорматированныйДокумент. Нужно из них составить один, немного дополнив.

Допустим, это два элемента справочника. В каждом хранится некое описание с картинками.

Надо выбрать эти два элемента, и составить один форматированный документ, который будет содержать

1. Наименование элемента
описание с картинками
2. Наименование элемента
описание с картинками

Я так понимаю, элементы в виде дерева. Первым элементом идет ПараграфФорматированногоДокумента.
Нужно все элементы дерева обходить или есть другой вариант?
 
 
   Надмозг
 
1 - 04.04.18 - 10:20
Утро вечера мудренее
   Надмозг
 
2 - 04.04.18 - 16:42
// серверная функция, где формирую форматированный документ

    
    // тут получаю массив строк с выделенными элементами

    Если МассивСтрок.Количество() Тогда
        ФорматированныйДокумент = Новый ФорматированныйДокумент;
        
        Для Каждого ЭлементМассива Из МассивСтрок Цикл
            
            ТекстФД = ЭлементМассива.ХранилищеТекста.Получить();// из хранилища значений получается форматированный документ

            МассивЭлементов = ТекстФД.СформироватьЭлементы();
            Для Каждого ЭлементФормДок Из МассивЭлементов Цикл
                ФорматированныйДокумент.Добавить(ЭлементФормДок); 
            КонецЦикла;    
        
        КонецЦикла;

        Возврат ФорматированныйДокумент;
        
    КонецЕсли;
    

// передаем документ на клиент и записывает в ПДФ 

    ФорматированныйДокумент.Записать("C:\Users\Username\Desktop\FormatDoc.pdf", ТипФайлаФорматированногоДокумента.PDF);
    
    В итоге получается ПДФ с текстом 
    "ТекстФорматированногоДокумента КартинкаФорматированногоДокумента ТекстФорматированногоДокумента
КартинкаФорматированногоДокумента"

Должны быть картинки и текст
   Надмозг
 
3 - 04.04.18 - 16:43
Где в предыдущем косяк?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует