Вход | Регистрация


Итератор для значения не определен , не могу понять где ошибка...

Итератор для значения не определен , не могу понять где ошибка...
Я
   Gen833
 
03.04.18 - 12:41
Отбор = Новый Структура();
    Отбор.Вставить("КлючОбъекта", ИмяФормы);
    Отбор.Вставить("КлючНастрек", "Основная"); 
    Отбор.Вставить("Пользователь", ПользователиИнформационнойБазы.ТекущийПользователь().Имя);
    Настройки = ХранилищеНастроекДанныхФорм.Выбрать(Отбор);
    Если Настройки.Следующий() Тогда
        Для Каждого стр из Настройки.Настройки Цикл
            Выполнить(стр.Ключ + " = стр.Значение");
        КонецЦикла;
    КонецЕсли;
 
 
   Defender aka LINN
 
1 - 03.04.18 - 12:45
А посмотреть, что в Настройки.Настройки вам религия не позволяет?
   Gen833
 
2 - 03.04.18 - 12:47
Блин,точно! Настройки = непоределено.
   Сияющий в темноте
 
3 - 03.04.18 - 12:49
Миста-лучший отладчик
   Gen833
 
4 - 03.04.18 - 12:59
КомпоновщикНастроек = Новый КомпоновщикНастроекКомпоновкиДанных();
    Настройки = КомпоновщикНастроек.Настройки;
    Отбор = Новый Структура();
    Отбор.Вставить("КлючОбъекта", ИмяФормы);
    Отбор.Вставить("КлючНастрек", "Основная"); 
    Отбор.Вставить("Пользователь", ПользователиИнформационнойБазы.ТекущийПользователь().Имя);
    Настройки = ХранилищеНастроекДанныхФорм.Выбрать(Отбор);
    Если Настройки.Следующий() Тогда
        Для Каждого стр из Настройки.Настройки Цикл
            Выполнить(стр.Ключ + " = стр.Значение");
        КонецЦикла;
    КонецЕсли;
 И так ошибка, блин как же обойти настройки?
   Gen833
 
5 - 03.04.18 - 13:02
Все-все понял, где ошибка... )))

Список тем форума
Рекламное место пустует  Рекламное место пустует
Пользователь не знает, чего он хочет, пока не увидит то, что он получил.
Э. Йодан
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует