Вход | Регистрация


Аутентификация операционной системы при использовании веб-сервера Apache 2.4

Аутентификация операционной системы при использовании веб-сервера Apache 2.4
Я
   ВикторП
 
03.04.18 - 09:25
Кто реализовывал для информационных баз 1с?
 
 
   ВикторП
 
1 - 03.04.18 - 13:22
.
   Casey1984
 
2 - 03.04.18 - 13:30
   ВикторП
 
3 - 03.04.18 - 14:39
это про 2.2
   ВикторП
 
4 - 04.04.18 - 09:19
.
   g00d
 
5 - 04.04.18 - 09:30
стандартно поддерживается только в ИИС, но и там жестко глючит в виду повторных авторизаций при обращениям к файлам.
Делайте авторизацию через клиентские сертификаты.
   ВикторП
 
6 - 04.04.18 - 14:28
поддерживается не только в ИИС , откуда такое мнение
   g00d
 
7 - 04.04.18 - 16:52
(6) в параметрах публикации базы в самом внизу есть флаг "Использовать ауентификацию операционной системы"
Это флаг доступен только при использовании IIS, при смене на апач, флаг исчезает.
Безусловно вы можете сделать эту авторизацию средствами апач https://its.1c.ru/db/v8311doc#bookmark:adm:TI000000059, но для это должен быть настроен модуль mod_auth_sppi и быть доступе PDC.
В общем сделать можно, но проще поставить IIS, благо он есть даже не на серверных ОС
   etc
 
8 - 04.04.18 - 23:32
Дополню (7)
Учитывая что mod_auth_sppi есть только для apache 2.2 и альтернатив ему можно сказать нет то можете забыть о аутентификации ОС.
   zwei
 
9 - 05.04.18 - 00:15
google://mod_authnz_sspi
   ВикторП
 
10 - 05.04.18 - 10:02
(8) вопрос с самого начала про 2.4
 
 Рекламное место пустует
   g00d
 
11 - 05.04.18 - 10:25
(10) с апачем есть смысл замарачиваться только если у вас  веб сервер на линуксе

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует