Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Cерверные вызовы при завершении работы запрещены 1с

Cерверные вызовы при завершении работы запрещены 1с
Я
   SavageRoman
 
02.04.18 - 17:54
У меня есть модуль управляемого приложение :

Процедура ПередЗавершениемРаботыСистемы(Отказ, ТекстПредупреждения)
        Результат = СерверныеПроцедуры.ПрочитатьКонстантуПідтвердженняЗакриття();
        Если Результат = Истина Тогда
            Если Вопрос("Завершити роботу програми?",РежимДиалогаВопрос.ДаНет,,,"Увага",) = КодВозвратаДиалога.Нет Тогда
                Отказ = Истина;
            КонецЕсли;
        КонецЕсли;    
    КонецПроцедуры

_________________________________________________
Создана константа (Булево)
______________________________________________
Общий модуль 

Функция ПрочитатьКонстантуПідтвердженняЗакриття() Экспорт 
    Результат = Константы.ПідтвердженняЗакриття.Получить();
    Возврат(Результат);
КонецФункции
______________________________________________
Режим использование модальности - Использовать 
Но есть ошыбка.
 
 
   Defender aka LINN
 
1 - 02.04.18 - 18:02
(0) Да
   SavageRoman
 
2 - 03.04.18 - 14:09
?
   H A D G E H O G s
 
3 - 03.04.18 - 14:10
(2) Cерверные вызовы при завершении работы запрещены 1с.
   Волшебник
 
4 - 03.04.18 - 14:19
(3)+ Присоединяюсь к мнению.
   aleks_default
 
5 - 03.04.18 - 14:27
ошибка в ошибке
   Митяйский
 
6 - 03.04.18 - 14:41
(0) http://programmist1s.ru/parametryi-seansa-1s/

И не трiгай серверные вызiвы
   SavageRoman
 
7 - 07.04.18 - 20:12
мне просто нужно чтобы при завершении программы был вопрос Закрыть программу? Да/нет ) И я ваш язык не искажал ) спасибо
   Остап Сулейманович
 
8 - 07.04.18 - 20:38

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует