Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 8 общая

УПП требует 8.3 или можно остаться на 8.2?

УПП требует 8.3 или можно остаться на 8.2?
Я
   Флориан
 
02.04.18 - 15:53
Для полноценного формирования отчетности в ПФ РФ по формам СЗВ-М, СЗВ-СТАЖ, СЗВ-КОРР, ОДВ-1 и СЗВ-ИСХ требуется использовать платформу 1С:Предприятие версии не ниже 8.3.9.1818.
https://releases.1c.ru/version_files?nick=Enterprise13&ver=1.3.105.2

Здесь написано
Вообще, есть вариант без обновления платформы, но там потребуется сменить кодировку файлов.
http://blogs.klerk.ru/users/1943154/post170542/

И на какую сменить, кто вкурсе?
 
 
   shuhard
 
1 - 02.04.18 - 15:58
(0) в ReadMe.txt к 1.3.105.2 этого требования пока нет
   Быдло замкадное
 
2 - 02.04.18 - 16:02
(1) Управление производственным предприятием, редакция 1.3, версия 1.3.105.2

Внимание! Текущий релиз конфигурации "Управление производственным предприятием" предназначен для использования с версией системы 1С:Предприятие 8 не ниже 8.2.19.130, а также может использоваться с версией 8.3.3.687(и выше)в режиме совместимости "Версия 8.2.13".
При работе с операционной системой Microsoft Windows 10 необходимо использовать версию 8.3 платформы "1С:Предприятие".
Для полноценного формирования отчетности в ПФ РФ по формам СЗВ-М, СЗВ-СТАЖ, СЗВ-КОРР, ОДВ-1 и СЗВ-ИСХ требуется использовать платформу 1С:Предприятие версии не ниже 8.3.9.1818.
   shuhard
 
3 - 02.04.18 - 16:02
(2) на сайте есть, в файлике нету
   Быдло замкадное
 
4 - 02.04.18 - 16:03
у нас 1С:Предприятие 8.3 (8.3.10.2561), полет нормальный, на 1.3.105.2 обновились.
   Флориан
 
5 - 02.04.18 - 16:04
При записи в файл СЗВ-М выдает 
Для записи файла "СЗВ-М" требуется использование технологической платформы 8.3.9.1818 или более поздней. Сохраненный сейчас файл может быть отклонен ПФ РФ

https://i.gyazo.com/03589259d679a0e6d50d127a59493e27.png
   shuhard
 
6 - 02.04.18 - 16:05
(5) ОК то нажимается =)
   rbcvg
 
7 - 02.04.18 - 16:06
1С:Предприятие 8.3 (8.3.11.3034) в субботу обновился на 1.3.105.2.
   shuhard
 
8 - 02.04.18 - 16:11
(7) с 8.2 слезать сооовсем не хочется на старых проектах
   Флориан
 
9 - 02.04.18 - 16:20
http://downloads.v8.1c.ru/content//Enterprise/1_3_105_2/news.htm
файлы сохраняются на диске и отправляются через 1С-Отчетность в кодировке UTF-8 без сигнатуры BOM; - есть вариант эту сигнатуру прописать на платформе 8.2?
   Джинн
 
10 - 02.04.18 - 16:21
(8) В режиме совместимости совершенно нормально работает на свежих движках.
 
 Рекламное место пустует
   Флориан
 
11 - 02.04.18 - 16:22
https://www.forum.mista.ru/topic.php?id=627086#5
тут вроде решение буду пробовать
   Быдло замкадное
 
12 - 02.04.18 - 16:33
а вы не ищите простых путей
   spectre1978
 
13 - 02.04.18 - 16:48
(8) под Win10 с 8.2 есть проблемы. Поле ХТМЛ падает, поэтому нельзя нормально вызвать синтакс-помощник и даже запустить обновление; и в толстом клиенте иногда глюки с печатью - не встают задания на печать, при попытке печати тупо ничего не происходит.
   spectre1978
 
14 - 02.04.18 - 16:50
поэтому на самом деле все хорошо ровно до тех пор, пока стоят пожилые компы с Win7. А дальше уже все не столь хорошо как хотелось бы.
   Базис
 
15 - 02.04.18 - 16:52
(14) Не холивара ради, но только для понимания. Вы для работы используете Win10? Можно узнать отношение количества админов на количество сотрудников?
   Флориан
 
16 - 02.04.18 - 17:00
это не подходит т.к. под 8.3 с режимом совместимости с 8.2

ЗТ = Новый ЗаписьТекста(ИмяФайла, КодировкаТекста.ANSI); 
ЗТ.Закрыть(); 
ЗТ = Новый ЗаписьТекста(ИмяФайла,,, Истина, Символы.ПС); 
ЗТ.Записать(Данные); 
ЗТ.Закрыть();
   shuhard
 
17 - 02.04.18 - 17:23
(10) дык проблема не в УПП, она в режиме совместимости
проблема в древней серверной группировке, коей лет 10 и на которой 8.3 ляжет
   spectre1978
 
18 - 02.04.18 - 22:05
(15) А зачем там особо много админов? Поставил - она и работает. Как и семерка, как и XP до нее. Не вижу разницы.
   tesseract
 
19 - 02.04.18 - 22:13
(13) В какой конкретно версии? Сколько работали - не падало. Толстый клиент давно заброшен. С ним с каждым апдейтом куча проблем.

(17) 8.3.11 быстрее 8.3.10 даже на глаз.
   spectre1978
 
20 - 02.04.18 - 22:45
(19) Крайняя. 8.2.19.130. Забросить толстого клиента нереально, потому что - см. сабж - речь про УПП. Проблема с синтакс-помощником воспроизводится легко и выглядит вот так https://imgur.com/a/TrC9V. С печатью сложнее, потому что бывает не всегда и, возможно, не со всеми драйверами принтера, тут не знаю.
   ILM
 
21 - 03.04.18 - 06:03
(20) Из бывших саперов или летчиков? Или боевиков насмотрелись, опять со своим "крайним" лезут.
Последняя 8.2.19.130 - последняя!!!
Больше не будет. Совсем не будет.
   rphosts
 
22 - 03.04.18 - 06:12
Какая такая УПП?
А. ну да, ее ещё 4 недели продавать будут.
https://www.forum.mista.ru/topic.php?id=816392
   Флориан
 
23 - 04.04.18 - 16:28
//следующий метод, который меняет кодировку в уже готовом, ранее сформированном файле .csv


////создаем сам файл

СписокЭкспорт = Новый ТекстовыйДокумент;
СписокЭкспорт.ДобавитьСтроку(ПерваяСтрокаФайла);  ////в цикле добавляем все что надо

СписокЭкспорт.Записать(ИмяФайлаЭкспортаCSV,КодировкаТекста.UTF8);  //// Где "ИмяФайлаЭкспортаCSV" полный путь к файлу


////меняем в готовом файле кодировку "с BOM" на "без BOM"

КонвертируемыйФайл = Новый ДвоичныеДанные(ИмяФайлаЭкспортаCSV);
Строка64=Base64Строка(КонвертируемыйФайл);
Строка64=Прав(Строка64,СтрДлина(Строка64)-4);
ДляЗаписиВФайл=Base64Значение(Строка64);
ДляЗаписиВФайл.Записать(ИмяФайлаЭкспортаCSV);
   Флориан
 
24 - 04.04.18 - 17:13
Самое оптимальное на мой взгляд, что бы не ставить 8.3.Может кому пригодится (позже кто сюда из яндекса прилетит), можно ставить в тему РЕШЕНО
в процедуре
ПроцедурыПерсонифицированногоУчета.ЗаписатьФайлДокументаНаДискету
заменил на текст
    Если Не ДобавлятьBOM И ТипКодировки = "UTF8" Тогда
        //Если Не ЕстьПоддержкаУправленияBOM() Тогда

        //    ДобавлятьBOM = Истина;

        //    СокращенноеИмяДокумента = Сред(ИмяФайла, Найти(ИмяФайла, "СЗВ-"));

        //    СокращенноеИмяДокумента = Лев(СокращенноеИмяДокумента, Найти(СокращенноеИмяДокумента, "_")-1);

        //    Предупреждение("Для записи файла """ + СокращенноеИмяДокумента + """ в соответствии с правилами ПФ РФ требуется использование технологической платформы ""1С:Предприятие 8"" версии 8.3.9.1818 или более поздней.

        //    |Сохраненный сейчас файл может быть отклонен ПФ РФ.", 20, "Внимание");

        //КонецЕсли;

    Иначе
        ДобавлятьBOM = Истина;
    КонецЕсли;
    
    Если ВыбиратьКаталог  Тогда
        Длг = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.ВыборКаталога);
        Длг.Каталог = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(ТекущийПользователь,"ОсновнойКаталогФайлов");
        Длг.Заголовок = "Укажите каталог";
        Если Длг.Выбрать() Тогда
            ИмяФайла = Длг.Каталог+"\" + ИмяФайла;
            Если ДобавлятьBOM Тогда
                ТекстовыйДокумент = Новый ТекстовыйДокумент;
                ТекстовыйДокумент.УстановитьТекст(ТекстФайла); 
                ТекстовыйДокумент.Записать(ИмяФайла, КодировкаФайла);
            Иначе
                Если ТипКодировки = "UTF8" Тогда
                    ЗТ = Новый ЗаписьТекста(ИмяФайла, КодировкаТекста.ANSI); 
                    ЗТ.Закрыть(); 
                    ЗТ = Новый ЗаписьТекста(ИмяФайла,,, Истина, Символы.ПС); 
                    ЗТ.Записать(ТекстФайла); 
                    ЗТ.Закрыть();                    
                Иначе
                    Запись = Новый ЗаписьXML;
                    Запись.ОткрытьФайл(ИмяФайла, ТипКодировки, Ложь);
                    Запись.ЗаписатьБезОбработки(ТекстФайла);
                    Запись.Закрыть();                    
                КонецЕсли;
            КонецЕсли;
            Если Не ЗначениеЗаполнено(ТекстОповещения) Тогда
                ТекстОповещения = "Файл записан под именем: "
            КонецЕсли;
            Предупреждение(ТекстОповещения + ИмяФайла);
        КонецЕсли;
    Иначе
        Если ДобавлятьBOM Тогда
            ТекстовыйДокумент = Новый ТекстовыйДокумент;
            ТекстовыйДокумент.УстановитьТекст(ТекстФайла); 
            ТекстовыйДокумент.Записать(ИмяФайла,КодировкаФайла);
        Иначе
            Если ТипКодировки = "UTF8" Тогда
                ЗТ = Новый ЗаписьТекста(ИмяФайла, КодировкаТекста.ANSI); 
                ЗТ.Закрыть(); 
                ЗТ = Новый ЗаписьТекста(ИмяФайла,,, Истина, Символы.ПС); 
                ЗТ.Записать(ТекстФайла); 
                ЗТ.Закрыть();                    
            Иначе            
                Запись = Новый ЗаписьXML;
                Запись.ОткрытьФайл(ИмяФайла, ТипКодировки, Ложь);
                Запись.ЗаписатьБезОбработки(ТекстФайла);
                Запись.Закрыть();
            КонецЕсли;
        КонецЕсли;
    КонецЕсли;
   vis_tmp
 
25 - 04.04.18 - 18:08
Можно и просто внешнюю обработку сделать для обработки файла, как в (23).
Я сегодня проверял - удаляется BOM.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует