Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Почему не создается штрих-код

Почему не создается штрих-код
Я
   sidalexsandr
 
02.04.18 - 11:09
У меня УТ 10.3 Вот текст процедуры:
Функция ПечатьУниверсальногоПередаточногоДокумента(ДанныеДокумента, СчетФактураТребуется, СтруктураОтбораСчетаФактуры = Неопределено, ТабДокумент = Неопределено)
    
    ДатаДокумента = ДанныеДокумента.Дата;
    Если ДатаДокумента >= Дата(2017, 10, 1) Тогда
    
        мВерсияПостановления = 2;
        ИмяМакета    = "УниверсальныйПередаточныйДокумент981";        
    ИначеЕсли ДатаДокумента >= Дата(2017, 7, 1) Тогда
        мВерсияПостановления = 1;
        ИмяМакета    = "УниверсальныйПередаточныйДокумент";        
    Иначе
        мВерсияПостановления = 0;
        ИмяМакета    = "УниверсальныйПередаточныйДокумент";
    КонецЕсли;
    Макет = ЭтотОбъект.ПолучитьМакет(ИмяМакета);
    
    
    Если СтруктураОтбораСчетаФактуры = Неопределено Тогда
        СчетФактура = НайтиПодчиненныйСчетФактуру(ДанныеДокумента.ДокументСсылка, "СчетФактураВыданный");
    Иначе
        СчетФактура = НайтиПодчиненныйСчетФактуру(ДанныеДокумента.ДокументСсылка, "СчетФактураВыданный", СтруктураОтбораСчетаФактуры);
    КонецЕсли;
    
    Если ТабДокумент = Неопределено Тогда
        ТабДокумент = Новый ТабличныйДокумент;
        // Устанавливаем параметры печати и колонтитулы

        ТабДокумент.ОриентацияСтраницы     = ОриентацияСтраницы.Ландшафт;
        ТабДокумент.ПолеСверху             = 12;
        ТабДокумент.ПолеСлева              = 0;
        ТабДокумент.ПолеСнизу              = 0;
        ТабДокумент.ПолеСправа             = 0;
        ТабДокумент.АвтоМасштаб         = Истина;
        ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_УниверсальныйПередаточныйДокумент";
    КонецЕсли;
    
    
    ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
    ШтрихкодированиеПечатныхФорм.ВывестиШтрихкодВТабличныйДокумент(ТабДокумент, Макет, ОбластьМакета, ДанныеДокумента.Ссылка)//artfa.a@yandex.ru
 
 

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует