Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Вывод печатной формы после записи Чека ККМ

Вывод печатной формы после записи Чека ККМ
Я
   yrs
 
02.04.18 - 10:54
Добрый день! Прошу помочь в решении возникшей проблемы. Не могу толку дать. Мы используем конфигурацию Управление торговлей 11.3.
После записи (пробития) чека ККМ необходимо, чтобы выходила печатная форма договора продажи. Делаю я это следующим образом.
В модуле формы "ФормаДокументаРМК" в процедуре ПослеЗаписиНаСервере() вызываю процедуру Печать().

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)
    
ПараметрыУказанияСерий = Новый ФиксированнаяСтруктура(НоменклатураСервер.ПараметрыУказанияСерий( ТекущийОбъект, Документы.ЧекККМ));
    
ЗаполнитьСлужебныеРеквизитыПоНоменклатуре();
    
Если Объект.Статус = Перечисления.СтатусыЧековККМ.Пробит Тогда
Если ЕстьОграниченноГодныеТовары() Тогда
            
МассивОбъектов = Новый Массив;
МассивОбъектов.Добавить(Объект.Ссылка);
ПараметрыПечати = Новый Структура;
            ПараметрыПечати.Вставить("ДополнитьКомплектВнешнимиПечатнымиФормами", Ложь);
            КоллекцияПечатныхФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм("ПФ_MXL_ДоговорПродажиОграниченноГодногоТовара");
            ОбъектыПечати = Новый СписокЗначений;
//            ОбъектыПечати.Добавить(Объект.Ссылка);

            ПараметрыВывода = Новый Структура;
            ПараметрыВывода.Вставить("ДоступнаПечатьПоКомплектно", Ложь);
            
//            

Документы.ЧекККМ.Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);

КонецЕсли;
КонецЕсли;
    
КонецПроцедуры


Сама процедура Печать() прописана в модуле менеджера Чека  ККМ. В результате печатная форма договора не выходит, при этом программа никаких ошибок не выдает. Добавлю, что процедура Печать() точно запускается. Подскажите, где копать?
 
 
   hhhh
 
1 - 02.04.18 - 11:14
(0) так сбегать на сервер, посмотреть, может там форма вылезает.
   yrs
 
2 - 02.04.18 - 11:22
не вылезает
   Галахад
 
3 - 02.04.18 - 11:35
(2) До сервера добежал?
   yrs
 
4 - 02.04.18 - 11:40
Зашел на сервер по RDP. Там и проверил.
   hhhh
 
5 - 02.04.18 - 11:51
(4) это не то. Надо бежать.
   yrs
 
6 - 02.04.18 - 12:35
Посмотрел на сервере. Нет печатной формы.
   yrs
 
7 - 02.04.18 - 15:30
Может быть, бесполезно ожидать вывода печатной формы, когда вызов печати происходит в серверной процедуре? Есть какие мысли?
   Chameleon1980
 
8 - 02.04.18 - 15:47
Не просто печать нужно ИМХО а типа СформироватьПечатнуюФорму яего-то там
   Chameleon1980
 
9 - 02.04.18 - 15:48
это типа функция - вернет софрмированный Печдок
   Chameleon1980
 
10 - 02.04.18 - 15:52
вы бы хоть заглянули в модуль менеджера документа
у меня, например для ЧекаККМ
в УТ 11.3.2.199

процедура Печать вот такая:

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
КонецПроцедуры


все...
пусто
 
 Рекламное место пустует
   yrs
 
11 - 02.04.18 - 15:56
Да, в типоповом варианте у меня тоже эта процедура пустая. Поэтому пришлось заполнить ее. Вот ее код
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
    КоллекцияПечатныхФорм,
    "ПФ_MXL_ДоговорПродажиОграниченноГодногоТовара",
    НСтр("ru='Договор продажи ограниченно годного товара'"),
    СформироватьПечатнуюФормуДоговораПродажиОграниченноГодногоТовара(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода),
    ,
    "Документ.ЧекККМ.ПФ_MXL_ДоговорПродажиОграниченноГодногоТовара");
    
КонецПроцедуры
   yrs
 
12 - 02.04.18 - 16:01
Может, этот способ реализации, в корне не верен? Может бесполезно пытаться получить печатную форму (в идеале вообще хотелось бы, чтобы печатная форма уходила на принтер), обращаясь к процедуре Печать() из серверной процедуры?
   Chameleon1980
 
13 - 02.04.18 - 16:21
ТД=СформироватьПечатнуюФормуДоговораПродажиОграниченноГодногоТовара(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода);

ТД.ПЕчать();

Не???
   yrs
 
14 - 02.04.18 - 16:28
А в каком конкретном месте прописывать эти строчки? Неужели в процедуре Печать()?
   yrs
 
15 - 02.04.18 - 16:31
Если то так, то не прокатило. Печатная форма не вышла?
   yrs
 
16 - 02.04.18 - 16:38
По ошибке знак вопроса поставил. Это утверждение:
Печатная форма на вышла.
   yrs
 
17 - 02.04.18 - 16:45
Не было бы проблемы, если бы я мог вызывать печать в клиентской процедуре ПослеЗаписи(). Но этот обработчик событий не срабатывает, когда чек пробивается в форме "ФормаДокументаРМК". Может, быть есть какие другие решения реализации?
   yrs
 
18 - 02.04.18 - 17:03
Немного запутался. Попробовал проверить предложенный вариант, но при этом строчку вызова печати оставил закомментированной. Поправил, теперь в ошибку улетает.
   Chameleon1980
 
19 - 02.04.18 - 17:51
Иногда тут задают вопрос:

Сколько платят за решение задачи?
   yrs
 
20 - 02.04.18 - 20:26
Спасибо, разобрался сам и бесплатно.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует