Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заполнение поля "Вид контрагента"

Заполнение поля "Вид контрагента"
Я
   eg2801
 
01.04.18 - 20:06
Создаю нового контрагента в модуле Управление Торговлей 11.3. После следующих действий на форме этого контрагента поле "Вид Контрагента" остается пустым.

Контрагент = Справочники.Контрагенты.СоздатьЭлемент();
Контрагент.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо;
Контрагент.ЮридическоеФизическоеЛицо = Перечисления.ЮридическоеФизическоеЛицо.ЮридическоеЛицо;

Партнер = Справочники.Партнеры.СоздатьЭлемент();
Партнер.ЮрФизЛицо = Перечисления.КомпанияЧастноеЛицо.Компания;

Партнер.Записать();
Контрагент.Партнер = Партнер;
Контрагент.Записать();

(Наименования я указал, просто не стал приводить код сюда). Каким образом это поле можно заполнить?
 
 
   shuhard
 
1 - 01.04.18 - 20:30
(0)код под формой примитивный, позырь отладчиком
Процедура ПриСозданииИЧтенииНаСервере()
    
    НастройкиПодключенияКСервисуИППЗаданы = ПартнерыИКонтрагенты.НастройкиПодключенияКСервисуИППЗаданы();
    ПравоИзмененияОбъекта = ПравоДоступа("Изменение", Метаданные.Справочники.Партнеры);
    
    Если ОбособленноеПодразделение Тогда
        ВидКонтрагента = "ОбособленноеПодразделение";
    ИначеЕсли ЗначениеЗаполнено(ЮрФизЛицо) Тогда
        ВидКонтрагента = ОбщегоНазначения.ИмяЗначенияПеречисления(ЮрФизЛицо);
    КонецЕсли;
    
    УправлениеДоступностью();
    УстановитьЗаголовок();
    
КонецПроцедуры
   shuhard
 
2 - 01.04.18 - 20:43
(1) +1
ЮрФизЛицо- реквизит формы, заполняется здесь
Процедура ПриЧтенииНаСервере(ТекущийОбъект)
    
    ПартнерыИКонтрагенты.ЗаполнитьДанныеКонтрагентаПартнера(ЭтотОбъект, ТекущийОбъект.Ссылка);



Запрос = Новый Запрос;
    Запрос.Текст = "
    |ВЫБРАТЬ ПЕРВЫЕ 1
    |    Контрагенты.Ссылка КАК КонтрагентПартнера,
    |    Контрагенты.ЮрФизЛицо КАК ЮрФизЛицо,
    |    Контрагенты.ЮридическоеФизическоеЛицо КАК ЮридическоеФизическоеЛицо,
    |    Контрагенты.ИНН                       КАК ИНН,
    |    Контрагенты.КПП                       КАК КПП,
    |    Контрагенты.НДСпоСтавкам4и2           КАК НДСпоСтавкам4и2,
    |    Контрагенты.КодПоОКПО                 КАК КодПоОКПО,
    |    Контрагенты.ОбособленноеПодразделение КАК ОбособленноеПодразделение,
    |    Контрагенты.ГоловнойКонтрагент        КАК ГоловнойКонтрагент,
    |    Контрагенты.СтранаРегистрации         КАК СтранаРегистрации,
    |    Контрагенты.РегистрационныйНомер      КАК РегистрационныйНомер,
    |    Контрагенты.НалоговыйНомер            КАК НалоговыйНомер,
    |    Контрагенты.ИсторияКПП.(
    |        Период КАК Период,
    |        КПП КАК КПП
    |    )                                    КАК ИсторияКПП,
    |    Контрагенты.ИсторияНаименований.(
    |        Период КАК Период,
    |        НаименованиеПолное               КАК НаименованиеПолное
    |    ) КАК ИсторияНаименований
    |ИЗ
    |    Справочник.Контрагенты КАК Контрагенты
    |ГДЕ
    |    Контрагенты.Партнер = &Партнер";
    
    Запрос.УстановитьПараметр("Партнер",Партнер);
    
    Выборка = Запрос.Выполнить().Выбрать();

    Если Выборка.Следующий() Тогда
    
        ЗаполнитьЗначенияСвойств(Приемник, Выборка,,"ИсторияКПП, ИсторияНаименований");
        Если СИсторическимиДанными Тогда
            Приемник.ИсторияКПП.Загрузить(Выборка.ИсторияКПП.Выгрузить());
            Приемник.ИсторияНаименований.Загрузить(Выборка.ИсторияНаименований.Выгрузить());
        КонецЕсли;
    
    КонецЕсли;
   eg2801
 
3 - 01.04.18 - 21:02
Дело в том, что создание происходит во внешней обработке, связанной с созданием новых контрагентов. У меня есть только что созданный объект типа Справочники.Контрагенты. Как мне установить значение ВидаКонтрагента на форме данного контрагента из модуля внешней обработки? Полагаю там одна-две строки кода. Возможно что-то связанное с ПолучитьФорму.
   Cyberhawk
 
4 - 01.04.18 - 21:03
Сколько платят за решение вопроса?
   eg2801
 
5 - 01.04.18 - 21:04
(4) Я только учусь. Это тестовое задание стажера
   Darych
 
6 - 01.04.18 - 21:04
ПолучитьФорму не то
   shuhard
 
7 - 01.04.18 - 21:10
(3) [Полагаю там одна-две строки кода]
там нет  кода
вид контрагента не храниться в учетной системе
всё, что тебе нужно разжёвано в (1) и (2)

(5) ну так учись пользоваться отладчиком
   Cyberhawk
 
8 - 01.04.18 - 21:21
(5) Стажером во франч?
   eg2801
 
9 - 01.04.18 - 21:54
(8) Я не знаю толком что такое франчайзи, компания занимается автоматизацией бизнеса
   Darych
 
10 - 01.04.18 - 22:00
(9) тебя тоже с 1 апреля
 
 Рекламное место пустует
   eg2801
 
11 - 01.04.18 - 22:01
(10) Что не так?
   Darych
 
12 - 01.04.18 - 22:03
(11) все нормально: автоматизируй автоматизаторов
   hhhh
 
13 - 02.04.18 - 02:13
(0) Контрагент.Партнер = Партнер.Ссылка;

с тебя 500 рублей
   eg2801
 
14 - 02.04.18 - 12:53
(13) Спасибо огромное, приятель!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует