Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

УТ 11.4, "Книга продаж": есть ли все-таки в типовой отбор по контрагентам?

УТ 11.4,  "Книга продаж": есть ли все-таки в типовой отбор по контрагентам?
Я
   DenYuliya
 
30.03.18 - 18:34
Добрый всем вечер!
Что-то я искала-искала в настройках, но так и не нашла: куда делся отбор по контрагентам? В 11.1 абсолютно точно была такая возможность, а сейчас в упор не вижу(((.
В коде полазила, вроде упоминается этот отбор, но я не смогла его найти.
То ли лыжи не едут, то ли :(.
 
 
   shuhard
 
1 - 30.03.18 - 18:35
(0) ты в коде смотрела ?
   DenYuliya
 
2 - 30.03.18 - 18:44
(2)  я в строке 3 своего сообщения (1) об этом говорила))).

Да, в коде смотрела, упоминание о наличие этого отбора есть, но в пользовательском режиме не нашла, куда нажать, чтобы до данной возможности "достучаться", потратила реально часа 2.

Так вот вопрос к знающим: есть смысл рыть дальше и я слепая, или нету этого отбора в новом релизе?
   Вафель
 
3 - 30.03.18 - 18:45
под полными правам попробуй поискать
   DenYuliya
 
4 - 30.03.18 - 18:45
(3) естественно у меня полные права :)
   shuhard
 
5 - 30.03.18 - 18:46
(2) не заметил твой ответ
да, слепая
смотрю в ERP 2.4.2.144
Настройки - вторая снизу галка
   DenYuliya
 
6 - 30.03.18 - 18:47
(3) это гадания из серии "а провод ты точно в разетку включила?", или вы утверждаете, что лично этот отбор в указанной редакции видели? Если да, слезно прошу - скиньте скрин, или хоть описание, где "всея 1С" его запрятала?!
   shuhard
 
7 - 30.03.18 - 18:47
(5) + 1
УТ 11.4.2.132
аналогично

Отчет "Книга продаж"

Отчет предназначен для формирования книги продаж.

Для контроля правильности ведения книги продаж параметры формирования отчета можно изменить на панели Настройки.

Контрагент для отбора - при указании контрагента (или группы контрагентов) отражаются счета-фактуры, выданные покупателю или группе покупателей.
Группировать по контрагентам - список счетов-фактур группируется по контрагентам.
Выводить продавцов по счетам-фактурам на выданные авансы - в графе "Наименование покупателя" вместо реквизитов покупателей можно вывести реквизиты продавца по счетам-фактурам на выданные авансы.
Формирование дополнительных листов книги продаж

При формировании книги продаж вместе с основным разделом можно вывести дополнительные листы книги (флажок Формировать дополнительные листы).

Дополнительные листы формируются отдельными бланками для каждого налогового периода. Дополнительные листы можно сформировать отдельно от книги продаж, для этого нужно установить флажок Выводить только дополнительные листы.

Можно использовать два режима формирования дополнительных листов:

за текущий период - дополнительные листы формируются за период формирования книги продаж с корректировками, внесенными в последующих налоговых периодах;
за корректируемый период - дополнительные листы формируются за все предыдущие налоговые периоды, в которые внесены изменения в текущем налоговом периоде (периоде формирования книги продаж).
   shuhard
 
8 - 30.03.18 - 18:48
(6) описание скинул - слезы высохли ?
   DenYuliya
 
9 - 30.03.18 - 18:53
(8) если бы(((
Тяжело живется слепошарикам...
http://dropmefiles.com/DlJfn

Хде? Куда тыкать-то?
   shuhard
 
10 - 30.03.18 - 18:54
 
 Рекламное место пустует
   Cyberhawk
 
11 - 30.03.18 - 18:56
Пади ФО какая-нибудь скрывает
   shuhard
 
12 - 30.03.18 - 18:57
(9) https://pastenow.ru/2V45Q
УТ 11.4.2.132
   shuhard
 
13 - 30.03.18 - 18:59
(11) ТС кодировать умеет, ей было важно,что у всех это есть и нет у неё
   DenYuliya
 
14 - 30.03.18 - 19:03
(10) вот нету такого интерфейса в этой базе)).
Бухи требуют переписать "шобы было", а меня гложат смутные сомнения: это "лыжи не едут", и надо поискать получше, или все-же "Всея 1С" снова все поменяла, а я не успела узнать об этом.

Спасибо всем! Теперь понятно, что  "так как у меня - не нормально, кныпочка отбора должна быть".

(13) да, именно :)!

Буду искать.
   shuhard
 
15 - 30.03.18 - 19:08
(14) ни на какие мысли не наводит ?
Процедура НастроитьСовместныйВыборКонтрагентовОрганизаций(Элемент, Контрагент = Null) Экспорт

    Если ПолучитьФункциональнуюОпцию("ИспользоватьПередачиТоваровМеждуОрганизациями") Тогда
        Если Контрагент = Неопределено Тогда
            Контрагент = Справочники.Контрагенты.ПустаяСсылка();
        КонецЕсли;
        НовыйМассив = Новый Массив();
        НовыйМассив.Добавить(Новый ПараметрВыбора("ВыборКонтрагентовИОрганизаций", Истина));
        Элемент.ПараметрыВыбора = Новый ФиксированныйМассив(НовыйМассив);
     Иначе
        Элемент.ОграничениеТипа = Новый ОписаниеТипов("СправочникСсылка.Контрагенты");    
        Элемент.ВыбиратьТип = Ложь;
    КонецЕсли;
    
КонецПроцедуры
   shuhard
 
16 - 30.03.18 - 19:20
(15) не то

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует