Вход | Регистрация


Как получить итог по колонке на форме 8.3 УФ

Как получить итог по колонке на форме 8.3 УФ
Я
   Обфускация
 
30.03.18 - 12:22
Как получить итог по колонке на форме? Итог нужен на сервере, в объекте колонки нет.
 
 
   Cyberhawk
 
1 - 30.03.18 - 12:24
Смешно
   DmitrO
 
2 - 30.03.18 - 12:24
Ну форма-то же есть на сервере. В чем проблема-то ПередЗаписьюНаСервере.
   Обфускация
 
3 - 30.03.18 - 12:33
Вот что у меня не так написано, пишет что итератор не определен

&НаКлиенте
Процедура Тест1(Команда)
    Тест1НаСервере();
    
        для каждого стр из этаформа.Элементы.Товары цикл
        сообщить(стр.разница);
    конеццикла;    

КонецПроцедуры
   DmitrO
 
4 - 30.03.18 - 12:41
для каждого стр из Объект.Товары цикл
   DmitrO
 
5 - 30.03.18 - 12:46
Предлагаю так:
КакКакаяРазницаОдинЛюбитДругойДразнится = Объект.Товары.Итог("разница");
   Обфускация
 
6 - 30.03.18 - 12:48
(5)
в объекте нет реквизита "разница", на форме в правом окне тоже нет, он добавлен в левом окне. Не понятно, как на такие реквизиты ссылаться.
   DmitrO
 
7 - 30.03.18 - 12:51
Тогда это называется не реквизит, а элемент управления, что у него написано в ПутьКДанным.
   hhhh
 
8 - 30.03.18 - 12:53
(6) так добавьте в Объект этот реквизит. Все добавляют без проблем.
   Обфускация
 
9 - 30.03.18 - 12:53
(7)
там написано "КоличествоРазница" . Такой реквизит на форме нашелся. А как сейчас эту таблицу формы на сервер отправить и там обработать?
   DmitrO
 
10 - 30.03.18 - 12:55
Надо заставить себя сделать серверный вызов формы. Это всего лишь организовать вызов процедуры с директивой компилляции &НаСервере.
 
 Рекламное место пустует
   DmitrO
 
11 - 30.03.18 - 12:57
и в этой процедуре сделать (5).
   Обфускация
 
12 - 30.03.18 - 12:58
(10)
Ну вот на форме есть таблица "Товары". В объекте ее нет. Там есть реквизит "КоличествоРазница". Как получить по нему итог по таблице?
   DmitrO
 
13 - 30.03.18 - 12:59
&НаКлиенте
Процедура Тест1(Команда)
    Тест1НаСервере();
КонецПроцедуры

&НаСервере
Процедура Тест1НаСервере()
    КакКакаяРазницаОдинЛюбитДругойДразнится = Объект.Товары.Итог("КоличествоРазница");
КонецПроцедуры
   Обфускация
 
14 - 30.03.18 - 13:02
(13)
получилось, спасибо )))
   Обфускация
 
15 - 30.03.18 - 13:03
(13)
может еще подскажете, как эту сумму в подвал таблицы вставить? )
   DmitrO
 
16 - 30.03.18 - 13:08
Конечно подскажу, я же для этого сюда и хожу, для самоутверждения.

У таблицы включить флажок Подвал.
У колонки указать ПутьКДаннымПодвала Объект.Товары.ИтогКоличествоРазница.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует