Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Не проводится документ

Не проводится документ
Я
   Erik
 
30.03.18 - 00:03
Программно провожу документ при нажатии на кнопку, но документ не проводится. При этом ошибок никаких не выскакивает. Что не так? Подскажите(((
 
 
   Erik
 
1 - 30.03.18 - 00:03
(0) Вот код:

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Для Каждого Строка Из ТабличноеПоле1 Цикл
        Строка.Ссылка.ПолучитьОбъект().Записать(РежимЗаписиДокумента.Проведение);
    КонецЦикла;
КонецПроцедуры
   Aleksandr N
 
2 - 30.03.18 - 00:05
(0) RTFM.
   Erik
 
3 - 30.03.18 - 00:11
(2) Ну по инструкции вроде все правильно. Программа их проводит, но при обновлении списка новые изменения не сохраняются
   igorPetrov
 
4 - 30.03.18 - 04:42
(3) см. (2)
   shadow_sw
 
5 - 30.03.18 - 04:46
т.е. ты думаешь написав, перебор строк и запись(проведение) в цикле, сделает тебе движения? :)))
   riks05
 
6 - 30.03.18 - 05:14
&НаСервере 
Процедура ПровестиРеализацииНаСервере() Экспорт 

//Этот код вызывается только на сервере 

Выборка = Документы.РеализацияТоваровУслуг.Выбрать(); 
Пока Выборка.Следующий() Цикл 
ОбъектДокумента = Выборка.ПолучитьОбъект(); 
ОбъектДокумента.РеализацияТоваровУслуг.Записать(РежимЗаписиДокумента.Проведение, РежимПроведенияДокумента.Неоперативный);; 
КонецЦикла; 

КонецПроцедуры
   Галахад
 
7 - 30.03.18 - 05:16
ОбъектДокумента.РеализацияТоваровУслуг.Записать...
Эта штука "РеализацияТоваровУслуг" тут зачем?
   riks05
 
8 - 30.03.18 - 05:17
(7) честно хз, сам в своё время гуглил эту тему, у меня работало.
   shadow_sw
 
9 - 30.03.18 - 05:33
какие изменения ты хочешь сохранить? реквизиты есть? в регистры писать? че надо вам, батенька?
   Jonny_Khomich
 
10 - 30.03.18 - 05:52
ты начал транзакцию и не зафиксировал её.
 
 Рекламное место пустует
   Chameleon1980
 
11 - 30.03.18 - 09:37
(1) супер код

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует