Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Как запомнить переменную?

↓ [Волшебник, 29.03.18 - 14:50]
Как запомнить переменную?
Я
   antihacker
 
29.03.18 - 14:47
Вот код

&НаКлиенте
Перем ТекФКР;

&НаСервере 
Функция ФТЧФКРПередУдалениемНаСервере(вхФКР)
    
    
ggg =вхФКР    ;
    //-----Проверяем есть ли     

    Отбор = Новый Структура();
    Отбор.Вставить("ФКР",вхФКР);
        
    НайденноеЗначение = Объект.ТЧРасходыПоОбязательствам.НайтиСтроки(Отбор);
    
    ввв =  НайденноеЗначение.Количество();

    
        
        Для Каждого ТекСтрока Из НайденноеЗначение Цикл
            ТекСтрока.ФКР = вхФКР;
        КонецЦикла;    
        

    
 Возврат  НайденноеЗначение.Количество();
    
КонецФункции

&НаКлиенте
Процедура ФТЧФКРПередУдалением(Элемент, Отказ)
    

        Если ФТЧФКРПередУдалениемНаСервере(Элемент.ТекущиеДанные.ФКР)<>0 Тогда
             сообщить("Существуют  расходы по объязательствам  !");    
             Отказ = Истина;    
        КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ФТЧФКРПередНачаломИзменения(Элемент, Отказ)

        ТекФКР = Элемент.ТекущиеДанные.ФКР;
        
КонецПроцедуры

Вроде как ТекФКР  должен вернуть старое значение. Но он отладка показывает, что новое. Мн нужно как то где то запомнить старое значение.
 
 
   antihacker
 
1 - 29.03.18 - 14:49
Ой забыл

&НаКлиенте
Процедура ФТЧФКРПриИзменении(Элемент)
    // Вставить содержимое обработчика.

    
     ФТЧФКРПередУдалениемНаСервере(ТекФКР);
    
КонецПроцедуры
   Волшебник
 
2 - 29.03.18 - 14:50
Запомни старое значение в переменной СтарФКР
   antihacker
 
3 - 29.03.18 - 14:51
И сделать


вот  так ?

&НаКлиенте
Процедура ФТЧФКРПриИзменении(Элемент)
    // Вставить содержимое обработчика.


    
     ФТЧФКРПередУдалениемНаСервере(СтарФКР);
    
КонецПроцедуры

А какая разница ?
   antihacker
 
4 - 29.03.18 - 14:52
Я думал, так. Перед началом изменения запомнить и передать при изменения.
   antihacker
 
5 - 30.03.18 - 12:21
Тема закрыта поймать СтарФКР надо было во время активизации строки.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует