Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Почему в этом участке поиск зависает?

Почему в этом участке поиск зависает?
Я
   мистер игрек
 
29.03.18 - 11:58
ОчиститьОтборыКлиент(Истина);
    
    ПоискССозданиемСписков = Истина;
    ВидПоискаКраткий = СтрЗаменить(ВидПоиска, "_ПолноеСоответствие", "");
    
    ПоискПоПолномуСоответствию = Найти(ВидПоиска, "_ПолноеСоответствие") > 0;
    
    Если НЕ ПустаяСтрока(ПолеПоиска) Тогда
        
        Если ВидПоискаКраткий = "Везде" Тогда
            ВыполнитьПоискВезде();
        ИначеЕсли ВидПоискаКраткий = "Штрихкод" Тогда
            ВыполнитьПоискПоШтрихкоду();
        ИначеЕсли ВидПоискаКраткий = "SKU" Тогда
            
            Попытка
                
                ПолеПоискаЧисло = Число(ПолеПоиска);
                ВыполнитьПоискПоSKU(ПолеПоискаЧисло);
                
            Исключение
                
                ПоискССозданиемСписков = Ложь;
                
            КонецПопытки;
            
        Иначе
            
            ЭлементОтбора = Товары.КомпоновщикНастроек.Настройки.Отбор.ПолучитьОбъектПоИдентификатору(СтруктураВидовПоискаИЭлементовОтбора[ВидПоиска]);
            //вот здесь и зависает

            Если ЭлементОтбора <> Неопределено Тогда                
                ЭлементОтбора.Использование  = Истина;
                ЭлементОтбора.ПравоеЗначение = ПолеПоиска;
                ПоискССозданиемСписков = Ложь;                      
            КонецЕсли;
            
        КонецЕсли;
        
    КонецЕсли;


"Товары" это реквизит управляемой формы с динамическим списком
 
 
   lodger
 
1 - 29.03.18 - 12:01
значит ДС криво отдает ПолучитьОбъектПоИдентификатору()
или в СтруктураВидовПоискаИЭлементовОтбора[ВидПоиска] бурда какая-то.
разделите на две строки и посмотрите в отладчике.
   мистер игрек
 
2 - 29.03.18 - 12:04
нет, зависание идет после этого кода
   мистер игрек
 
3 - 29.03.18 - 12:26
Если еще детализировать тогда здесь зависает

ЭлементОтбора.ПравоеЗначение = ПолеПоиска;
   lodger
 
4 - 29.03.18 - 12:55
(3) попробуй делать это не на клиенте, а на сервере, возможно даже с контекстом.
   мистер игрек
 
5 - 29.03.18 - 13:17
(4) Пробовал. Та же фигня
   мистер игрек
 
6 - 29.03.18 - 13:17
может это фича платформы?
   George Wheels
 
7 - 29.03.18 - 13:38
Попробуй запихнуть в Попытка .. Исключение и посмотреть что происходит.
   мистер игрек
 
8 - 29.03.18 - 13:41
(7) но там же не происходит исключение

Список тем форума
Рекламное место пустует  Рекламное место пустует
Программист всегда исправляет последнюю ошибку.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует