Вход | Регистрация


1С:Предприятие :: 1С:Предприятие 7.7 и ранее

v7: Проблемка нарисовалась в 1с77, в списке на печать не могу найти функцию.

v7: Проблемка нарисовалась в 1с77, в списке на печать не могу найти функцию.
Я
   Босечка
 
28.03.18 - 14:20
В документе есть функция ПечатьПоВыбору. Там есть пункт "УПД". Нигде не могу найти функцию, которая вызывается на УПД. В ПечатьПоВыбору такого слова нет. Может кто знает что делать в это случае. Заранее спасибо.
 
 
   Cool_Profi
 
1 - 28.03.18 - 14:22
Может, внешняя?
   dk
 
2 - 28.03.18 - 14:31
отладчик в зубы и включить замер производительности
   aka AMIGO
 
3 - 28.03.18 - 14:35
Хорошо-бы скрин.. Или код, в небольшом объёме..
   aka AMIGO
 
4 - 28.03.18 - 14:36
"Пункт "УПД""  - что за пункт?
   Gantosha
 
5 - 28.03.18 - 14:37
скорее всего из какого нибудь счета фактуры дергается .. причем где нибудь в глобальном модуле .. отладчик поможет.
Проще искать в обратную сторону - найти ее в конфигураторе и смотреть кто ее дергает ..благо это семерка.
   Масянька
 
6 - 28.03.18 - 14:40
(3) Поддержу - код функции ПечатьПоВыбору.
   Босечка
 
7 - 28.03.18 - 14:51
В конфигураторе ее нет.
   Масянька
 
8 - 28.03.18 - 14:52
(7) А где есть?
   Босечка
 
9 - 28.03.18 - 14:54
Понятия не имею.
   Босечка
 
10 - 28.03.18 - 14:54
Процедура ПечатьПоВыбору()
    //Если (Итог("Недогруз")<>0) Или (Итог("КоличВ")<>0) Или (Итог("Бой")<>0) Или (Итог("Недовоз")<>0) Тогда

    Если (Проведен()=1) или (ИмяПользователя() = "Антон") Тогда
        //Если ((Печать=0) ИЛИ (Пров=0)) И (Блок=1) и (ДатаДок = ТекущаяДата()) Тогда

        //    Сообщить("Клиенту установлен Стоп-Лист. Накладная не распечатана");

        //    Возврат;

        //КонецЕсли; 

        
        //Если ((Печать=0) ИЛИ (Пров=0)) И ((Клиент.Запрет=1) или (Клиент.ЗапретПревышениеЛимитаОтгрузки=1))   и (КлиентВПокупателях()=1) и (ДатаДок = ТекущаяДата()) и (НазваниеИнтерфейса()<>"Сертификаты")  Тогда

        //    Сообщить("Клиенту установлен запрет на продажу. Накладная не распечатана");

        //    Возврат;

        //КонецЕсли;

        
        Если (СостояниеЗаказа = Перечисление.СостоянияЗаказа.НеСогласовано) и (ПровКл = 0)  Тогда
            Предупреждение("На данном заказе установлен запрет. Печать документа запрещена!");
                           Если Клиент.Предоплата = 1 Тогда
                    СписокПараметров = СоздатьОбъект("СписокЗначений");
                    СписокПараметров.ВставитьЗначение(1,"ПечатьСчфакт");
                    СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                    ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                    
                    СписокПараметров = СоздатьОбъект("СписокЗначений");
                    СписокПараметров.ВставитьЗначение(1,"ПечатьСкл");
                    СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                    ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                КонецЕсли;
            Возврат;
        КонецЕсли;
        
        Если (НазваниеИнтерфейса()="Руководитель") или (НазваниеИнтерфейса()="Сертификаты") и (ДатаДок = ТекущаяДата()) Тогда
        Иначе
            Если ЗапретНаПечать=0 Тогда
                Если ВПост=0 Тогда
                    //Если (РасчетНаценкиТекДокум(ТекущийДокумент())<Агент.ГруппаФинансовогоКонтроля.МинимальнаяНаценка) и (Клиент.Код <> "102452") Тогда

                    //    Предупреждение("Наценка по накладной меньше 10!

                    //    |Печать невозможна!");

                    //    Возврат;

                    //КонецЕсли;

                    
                    //Если (Итог("МинКол")>0) Тогда

                    //    Предупреждение("В заказе есть строки с количеством меньше минимального для данного товара!

                    //    |Печать невозможна!"); 

                    //    Возврат;

                    //КонецЕсли;

                    //

                    //Если (Итог("МинЦена")>0)  Тогда

                    //    Предупреждение("В заказе есть строки с ценой меньше минимальной оптовой для данного товара!

                    //    |Печать невозможна!"); 

                    //    Возврат;

                    //КонецЕсли;

                    
                    
                    //Если ((Итог("СуммР")<Константа.МинСуммаЗаказа) и (Агент.Родитель.Родитель.Родитель.Код <> "423") И (Агент.Родитель.Родитель.Код <> "210") И (Агент.Родитель.Код <> "826") И (Агент.Родитель.Родитель.Код <> "826")И (Агент.Родитель.Код <> "995"))  Тогда

                    
                    //Если (Итог("СуммР") < МинРазрешСумма) Тогда

                    //    Предупреждение("Заказ выписан на меньшую сумму чем минимальная сумма заказа!

                    //    |Печать невозможна!");

                    //    Возврат;

                    //КонецЕсли;

                    
                    
                    //КонецЕсли;

                    Если Константа.ВозможностьПечати=0 Тогда
                        Если (ПустоеЗначение(АдресПоставки.Город)=1) или (ПустоеЗначение(АдресПоставки.Район)=1) или (ПустаяСтрока(АдресПоставки.Адрес)=1) или (ПустоеЗначение(АдресПоставки.Формат)=1)  Тогда
                            Предупреждение("В заказе не полность заполнен адрес поставки!
                            |Печать невозможна!");
                            Возврат;
                        КонецЕсли;    
                    КонецЕсли; 
                КонецЕсли;
            КонецЕсли; 
            
            Если ВПост=0 Тогда 
                    //Временно отключил Антон

                //Если  (Лицензия.НаименованиеКон<ДатаП)  и (Клиент.БезАлкагольные=0) Тогда  

                //    Предупреждение("У клиента просрочена лицензия!

                //    |Печать невозможна!");

                //    Возврат;    

                //КонецЕсли;                            

                
                //Если (Блок>0) Тогда  

                //    Предупреждение("У клиента стоит СТОП-ЛИСТ!

                //    |Печать невозможна!");

                //    Возврат;    

                //КонецЕсли; 

                
                //Если ((Клиент.Запрет=1) или (Клиент.ЗапретПревышениеЛимитаОтгрузки=1))  и (КлиентВПокупателях()=1) и (НазваниеИнтерфейса()<>"Сертификаты") Тогда  

                //    Предупреждение("У клиента стоит запрет на продажу!

                //    |Печать невозможна!");

                //    Возврат;    

                //КонецЕсли; 

            КонецЕсли;
        КонецЕсли;
        
        
        
        СписокЗнПеч = СоздатьОбъект("СписокЗначений");
        //Заполним список действий по кнопке "Печать Скидок"

        СписокЗнПеч.УдалитьВсе();
        СписокЗнПеч.ДобавитьЗначение("Расходная накладная");
        СписокЗнПеч.ДобавитьЗначение("ТТН");
        СписокЗнПеч.ДобавитьЗначение("Счёт-фактура");
        СписокЗнПеч.ДобавитьЗначение("Складская накладная"); 
        //СписокЗнПеч.ДобавитьЗначение("Комплект для МЕТРО"); 

        //СписокЗнПеч.ДобавитьЗначение("Комплект для Гепард");

        //СписокЗнПеч.ДобавитьЗначение("Комплект для Копейки");

        //СписокЗнПеч.ДобавитьЗначение("Справка Б");

        СписокЗнПеч.ДобавитьЗначение("Торг12"); 
        //СписокЗнПеч.ДобавитьЗначение("Комплект ""Сладкая жизнь""");

        //СписокЗнПеч.ДобавитьЗначение("ТТН для Трио");

        //СписокЗнПеч.ДобавитьЗначение("Счет-фактура без скидки");

        //СписокЗнПеч.ДобавитьЗначение("Винотека Акт приема передачи");

        //СписокЗнПеч.ДобавитьЗначение("Винотека рекомендуемые розничные цены");

        //СписокЗнПеч.ДобавитьЗначение("Счет для Винотеки");

        СписокЗнПеч.ДобавитьЗначение("ЕГАИС"); 
        ЧтоПечатать = "";
        
        Если Найти(НРег(КаталогИБ()), "vitrina") = 0 Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПоВыбору");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
        ИначеЕсли СписокЗнПеч.ВыбратьЗначение(ЧтоПечатать, "Что печатать?",,,0) > 0 Тогда
            Если ЧтоПечатать = "Расходная накладная" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"РасходнаяНакладная");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьРасходнойНакл(1);

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1; 
                    КонецЕсли; 
                //КонецЕсли; 

                
            ИначеЕсли ЧтоПечатать = "ТТН" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьТТН");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьТТН(1); 

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1; 
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Счет для Винотеки" Тогда
                ПечатьСчетНаПредоплату(1); 
                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1; 
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Счёт-фактура" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьСчфакт");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьСчфакт(1);

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Складская накладная" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьСкл");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьСкл(1);

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Комплект для МЕТРО" Тогда  
                ПечатьСкл(0);
                ПечатьРасходнойНакл(0);
                ПечатьТТНМетро(0);
                ПечатьСчФактМетро(0);
                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Комплект для Гепард" Тогда      
                ПечатьДляГепарда(1);
                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Комплект для Копейки" Тогда  
                //ПечатьСкл(0);

                ПечатьТТНКопейка(0);
                ПечатьСчФактКопейка(0);
                ПечатьТТНКопейка1(0);
                ПечатьРасходнойНакл1(0);
                ПечатьСправБ();
                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;    

            ИначеЕсли ЧтоПечатать = "Справка Б" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьСправБ");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьСправБ();

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли;
                //КонецЕсли;

                
            ИначеЕсли ЧтоПечатать = "Торг12" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьТорг12");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьТорг12(1);

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;

            ИначеЕсли ЧтоПечатать = "Комплект ""Сладкая жизнь""" Тогда 
                //ПечатьСкл(1);

                //ПечатьРасходнойНакл(1);

                ПечатьТорг12Ск(1,0);;
                ПечатьТТН(1);
                ПечатьСчФактСладкаяЖизнь(1);
                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;    

            ИначеЕсли ЧтоПечатать = "ТТН для Трио" Тогда
                ПечатьТрио(1);  
            ИначеЕсли ЧтоПечатать = "Счет-фактура без скидки" Тогда
                СписокПараметров = СоздатьОбъект("СписокЗначений");
                СписокПараметров.ВставитьЗначение(1,"ПечатьСчет");
                СписокПараметров.ВставитьЗначение(2,ТекущийДокумент());
                ОткрытьФорму("Отчет",СписокПараметров,КаталогИБ() + "ERT\Сертификаты\ПечатьСертификатов.ert");
                //ПечатьСчет();

                //Если НазваниеИнтерфейса()="Выписка" Тогда

                    Если Печать=0 Тогда
                        ФПечать=1;  
                    КонецЕсли; 
                //КонецЕсли;    

            ИначеЕсли ЧтоПечатать = "Винотека Акт приема передачи" Тогда
                ВинотекаАкт(0);
            ИначеЕсли ЧтоПечатать = "Винотека рекомендуемые розничные цены" Тогда
                ВинотекаРознЦены(0);
            ИначеЕсли ЧтоПечатать = "ЕГАИС" Тогда
                ОткрытьФорму("Отчет",ТекущийДокумент(),КаталогИБ() + "PrnForms\ПечатьЕГАИС.ert");
            КонецЕсли;
        КонецЕсли; 
        //Форма.КодТовара.Доступность(0);

        //Форма.Товар.Доступность(0); 

        //Форма.КМ.Доступность(0);

        //Форма.Колич.Доступность(0);

        //Форма.Скид.Доступность(0);

        //Форма.ЦенаР.Доступность(0);

        //

        //Форма.КодКлиента.Доступность(0);

        //Форма.Клиент.Доступность(0); 

        //Форма.АдресПоставки.Доступность(0);

        //Форма.Склад.Доступность(0);

        //Форма.Агент.Доступность(0);

        //Форма.НомерДок.Доступность(0);

        //Форма.ДатаП.Доступность(0);

        //Форма.Скидка.Доступность(0);

        //Форма.ДатаДок.Доступность(0);

    Иначе
        Предупреждение("Сначала запишите заказ!");
    КонецЕсли;
    //КонецЕсли;   

    Если (ФПечать = 1) И (Печать = 0) Тогда
        Печать = 1;
        Записать();
    КонецЕсли;
    //отмечаем печать в любом случае 

    Печать =1; 
    //Сообщить("Флаг печати установлен ");

    Записать();
КонецПроцедуры
 
 Рекламное место пустует
   Масянька
 
11 - 28.03.18 - 14:56
(9) (10) Так... Спокойно...
Чего нет в конфигураторе?
   Босечка
 
12 - 28.03.18 - 15:01
УПД
   Босечка
 
13 - 28.03.18 - 15:01
этой строки
   Босечка
 
14 - 28.03.18 - 15:02
Это 1с77 самописная , не типовая, так что это нормально
   Масянька
 
15 - 28.03.18 - 15:02
(12) Имеется ввиду нет строки "ЧтоПечатать = "УПД""?
   Масянька
 
16 - 28.03.18 - 15:03
(12) (13) (14) С Вами все в порядке?
   Franchiser
 
17 - 28.03.18 - 15:06
внешняя печатная форма
   Gantosha
 
18 - 28.03.18 - 15:06
она печатается ?
Если печатается , то перехватите номер выбираемой печатной формы .. но вообще даже в 7 ке уже были пополняемые списки стандартными формами ... поэтому она или есть в конфигураторе или просто имеет другое название и вам надо найти ее во внешних печатных формах ..где одно слово заменено словом упд.
   Масянька
 
19 - 28.03.18 - 15:08
(17) (18) Вангую - УПД не печатается.
А почему?
А потому (опять вангую) - во те лохматые времена УПД еще не было.
PS И, да, со мной все норм.
   Gantosha
 
20 - 28.03.18 - 15:10
(19) у нее написано что есть пункт. Про печать не написано.
   Масянька
 
21 - 28.03.18 - 15:13
(20) А в коде в (10) не увидела. Я.
И по бажу - мне (лично) не понятно. Ничего.
   aka AMIGO
 
22 - 28.03.18 - 15:15
   vladko
 
23 - 28.03.18 - 15:16
(10) а отладчик что показывает? или не пробовала им пользоваться?
   aka AMIGO
 
24 - 28.03.18 - 15:20
(21) И я. Не увидел.
Пункт УПД-то где? В диалоге? Что это за элемент метаданных, "пункт"?
   Босечка
 
25 - 28.03.18 - 15:21
в списке выбора перед печатью
   Масянька
 
26 - 28.03.18 - 15:22
(25) А Вы можете четко описать ситуацию?
   Босечка
 
27 - 28.03.18 - 15:23
В списке выбора перед печатью есть пункт "УПД", которого нигде нет.
   aka AMIGO
 
28 - 28.03.18 - 15:24
(25) Послушайся (25), воспользуйся отладчиком.
Или.. Есть TeamViewer?
   aka AMIGO
 
29 - 28.03.18 - 15:24
Если хочешь - пришли мне на мыло ИД и пароль
   Масянька
 
30 - 28.03.18 - 15:25
(27) УПД - печатает?
   oslokot
 
31 - 28.03.18 - 15:25
(27) Смотри здесь: сервис -> дополнительно -> внешние печформы

ну или как там у клюшек
   Масянька
 
32 - 28.03.18 - 15:26
Опять вагану:
в док-те есть кнопка. по кнопке вываливается список, в этом списке есть "УПД".
Дальше пока затрудняюсь...
   Gantosha
 
33 - 28.03.18 - 15:30
так всегда и было. Подмена названия. Но у них там код такой что подмена может быть где угодно. К какой форме УПД ближе в семерке ?
 
 
   aka AMIGO
 
34 - 28.03.18 - 15:31
(32) + а эелемент списка должен быть отловлен в приведенной процедуре 10, поскольку (так думаю) других входов и нет.
Вот тут и посмотреть, куда попадаем, что требует, как реагирует..
   Масянька
 
35 - 28.03.18 - 15:31
(33) А это что (кусок кода из (10)):
      СписокЗнПеч = СоздатьОбъект("СписокЗначений");
        //Заполним список действий по кнопке "Печать Скидок"


        СписокЗнПеч.УдалитьВсе();
        СписокЗнПеч.ДобавитьЗначение("Расходная накладная");
        СписокЗнПеч.ДобавитьЗначение("ТТН");
        СписокЗнПеч.ДобавитьЗначение("Счёт-фактура");
        СписокЗнПеч.ДобавитьЗначение("Складская накладная"); 
        //СписокЗнПеч.ДобавитьЗначение("Комплект для МЕТРО"); 


        //СписокЗнПеч.ДобавитьЗначение("Комплект для Гепард");


        //СписокЗнПеч.ДобавитьЗначение("Комплект для Копейки");


        //СписокЗнПеч.ДобавитьЗначение("Справка Б");


        СписокЗнПеч.ДобавитьЗначение("Торг12"); 
        //СписокЗнПеч.ДобавитьЗначение("Комплект ""Сладкая жизнь""");


        //СписокЗнПеч.ДобавитьЗначение("ТТН для Трио");


        //СписокЗнПеч.ДобавитьЗначение("Счет-фактура без скидки");


        //СписокЗнПеч.ДобавитьЗначение("Винотека Акт приема передачи");


        //СписокЗнПеч.ДобавитьЗначение("Винотека рекомендуемые розничные цены");


        //СписокЗнПеч.ДобавитьЗначение("Счет для Винотеки");


        СписокЗнПеч.ДобавитьЗначение("ЕГАИС");
   Масянька
 
36 - 28.03.18 - 15:31
(34) Я, все-таки, ведьма?
   aka AMIGO
 
37 - 28.03.18 - 15:32
(36) Сомневалась? :)
   aka AMIGO
 
38 - 28.03.18 - 15:34
На форме посмотреть имя СЗ (или ТЗ, что там...) и найти, где в модуле эта СЗ формируется. Не просто так УПД эта попадает в список-то.
   Gantosha
 
39 - 28.03.18 - 15:34
(35) это свои формы добавляются , но должна где то еще добавляться внешние формы и формы из глобального модуля.
В общем найти в 7 ке все достаточно просто ..
берешь кусок текста из формы и глобальным поиском по всему компу .. где нибудь найдется..
   Масянька
 
40 - 28.03.18 - 15:37
(39) А если на кнопке висит (10)?
(37) Совсем чуть-чуть.
   aka AMIGO
 
41 - 28.03.18 - 15:38
(36) А ты имела дела с УПД-то?

Там еще какой-то Антон поминается, у него-б и спросить, откуда что есть пошло.

ЗЫ. Ладно..
   Масянька
 
42 - 28.03.18 - 15:39
(41) У себя в ТиСе нарисовала... Даже печатается... Только клиенты требуют СФ...
   aka AMIGO
 
43 - 28.03.18 - 15:40
(40) На кнопке, к.м.к., однозначно висит 10.
А СЗ спрятана в модуле.
10-ка пользует этот СЗ, и.. вот тут отладчик-бы помог.
   Масянька
 
44 - 28.03.18 - 15:40
+ (42) И это - чего там иметь-то? Для зайца с интеллектом :)
   aka AMIGO
 
45 - 28.03.18 - 15:40
(42) Ааа.. вот оно что..

(44) понятно :)
   Масянька
 
46 - 28.03.18 - 15:41
(43) А внешняя просто зарегана для док-та.
И - усё... Приплыли...
   aka AMIGO
 
47 - 28.03.18 - 15:42
Усё! Получается, для меня это высшие материи :)
   Масянька
 
48 - 28.03.18 - 15:43
(47) Ой, да, ладно... Для человека, который умеет пользоваться семерочным отладчиком...
   aka AMIGO
 
49 - 28.03.18 - 15:45
@Босечка молчит.. И в списке под топиком её нет..
 
 Рекламное место пустует
   Gantosha
 
50 - 28.03.18 - 15:47
(48) с таким кодом упд может быть где угодно .. например за вызовом какой нибудь торг 12 или счета фаткруры дальше будет переадрисация .
Самое простое это вбить "универсальный передаточ..." и искать везде .. потом в обратную сторону.
Особенно если он печатается.
   Попытка1С
 
51 - 28.03.18 - 15:48
в PrnForms наверняка лежит
   aka AMIGO
 
52 - 28.03.18 - 15:57
И еще одно.. Где ищется эта УПД? В рабочей базе? или в локальной, созданной типа для отладки, на другом компе..
   Ёпрст
 
53 - 28.03.18 - 15:57
(0) сымотри зарегистрированную внешнюю печатную форму у документа.
В сервис - регистрация внеш. печ форм.
   Ёпрст
 
54 - 28.03.18 - 15:58
ЗЫ: твой список, что в (0) дополняется еще внешними печ формами, только и всего лишь
   Босечка
 
55 - 28.03.18 - 16:09
нашла вроде, кошмар.....внешний оказался в не типовом месте
   aka AMIGO
 
56 - 28.03.18 - 16:10
(55) Место-то какое? PrnForms?
   Cool_Profi
 
57 - 28.03.18 - 16:18
Традиция. Правильный ответ был дан в самом начале ветки, а потом началось унижение топик-стартера
   KRV
 
58 - 28.03.18 - 16:29
(57) Самолюбование + фалломорфирование с целью повышения длины, чтобы было чем брякнуть об стол)))
   Gantosha
 
59 - 28.03.18 - 16:34
а что тут унижать ..видно что там в коде не один программист валялся .. там чего угодно нйти можно ..
я вот ужа давно матом пишу в конфигураторе .. там матофильтра нет и все работает.
   Босечка
 
60 - 28.03.18 - 16:38
До меня здесь работало 5 или 6 программистов. Это было не в папке каталога ИБ, в другом  каталоге (другой ИБ). Не смешно на самом деле. Там многие отчеты лежат, как мне системщик наш сказал.
   Босечка
 
61 - 28.03.18 - 16:38
папка ERT
   Босечка
 
62 - 28.03.18 - 16:41
Здесь такой форум, хамить любят....
   aka AMIGO
 
63 - 28.03.18 - 16:47
(60) Никто вроде и не смеялся..
Информации было более, чем мало, потому и вопросы сыпались, понятно, что неудобные.

ЗЫ. Где-то в середине ветки показалось, что ТС или не читает, что пишут, или игнорирует вопросы.
Ну, нашла - и хорошо.
   Масянька
 
64 - 28.03.18 - 16:49
(62) На сколько вопросов из заданных в ветке Вы ответили?
(63) Я тоже не заметила хамства.
Вот и помогай после этого людям...
Еще про "активную гражданскую позицию" выслушивай...
   Босечка
 
65 - 28.03.18 - 17:04
Я сказала вообще, а не конктретно в этой теме.
   Босечка
 
66 - 28.03.18 - 17:04
Всем спасибо за помощь!


Список тем форума
Рекламное место пустует  Рекламное место пустует
Проблемы невозможно решaть нa том же уровне компетентности, нa котором они возникaют. Альберт Эйнштейн
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует