Вход | Регистрация



Есть счет. Есть Субконто. Как узнать возможные типы Субконто ?

Есть счет. Есть Субконто. Как узнать возможные типы Субконто ?
Я
   Grekos2
 
27.03.18 - 15:01
8.х
   Есть счет. Есть Субконто. Как узнать возможные типы Субконто ?
  
   Как узнать какого типа справочники и документы могут принимать значене Субконто.
 
 
   zak555
 
1 - 27.03.18 - 15:04
типы ПВХ
   Grekos2
 
2 - 27.03.18 - 15:12
(1) Не совсем понял. Нельзя ли поподробнее ?
   sidalexsandr
 
3 - 27.03.18 - 15:24
(2) Вроде  правила вида характеристик
   1Сергей
 
4 - 27.03.18 - 15:26
(3) планы
   unregistered
 
5 - 27.03.18 - 15:27
Для первого субконто как-то так:
Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения
   Grekos2
 
6 - 27.03.18 - 15:33
(5) Это я уже сделал
    В дебагере показывает, что там описание типов.

   Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()

 то получаем массив.

  Как отсюда узнать, что тип значениея - справочник.номенклатура например ?
   Kondarat
 
7 - 27.03.18 - 15:35
МассивТипов = Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()
Если МассивТипов.Найти(ТипЗнч("СправочникСсылка.Номенклатура"))<>НЕопределено Тогда
      Сообщить("Это номенклатура");
КонецЕсли;
   Grekos2
 
8 - 27.03.18 - 15:38
(7) Это если я хочу проверить какой то тип в описании.
    Мне нужно знать все типы которые там.
  
    Есть ли способ кроме перебора всех справочников и докуметов ?
   Kondarat
 
9 - 27.03.18 - 15:40
Перебери МассивТипов и узнай. Что за задача, то?
   Evgenchik
 
10 - 27.03.18 - 15:44
ты же массив типов получил, чего тебе еще надо?
 
 Рекламное место пустует
   Grekos2
 
11 - 27.03.18 - 15:52
Получить что то типа строки(строк) 
  "Справочник.Номенклатура"


  Вот по этому элементу массива Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0] достаточно трудно определить документ - справочник это или перечисление.
   Grekos2
 
12 - 27.03.18 - 15:54
Конечно же 
 Тип("СправочникССылка.Номенклатура") = Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.Типы()[0]

  Истина.
  
  Но так придется все справочники перебирать
   Grekos2
 
13 - 27.03.18 - 15:55
Хотя если подумать то сойдет и так.
   Evgenchik
 
14 - 27.03.18 - 16:14
а так?
Счет.ВидыСубконто[0].ВидСубконто.ТипЗначения.СодержитТип(Тип("СправочникСсылка.Номенклатура"))
   Kondarat
 
15 - 27.03.18 - 16:16
МасиивТипов = Новый Массив();
    МасиивТипов.Добавить(Тип("СправочникСсылка.Номенклатура"));
    МасиивТипов.Добавить(Тип("ДокументСсылка.ПоступлениеТоваровУслуг"));
    МасиивТипов.Добавить(Тип("ПеречислениеСсылка.ВидыБизнесПроцессов"));
    
    ДЛя Каждого ТипОбъекта ИЗ МасиивТипов Цикл
        
        МетаданныеТипа = Метаданные.НайтиПоТипу(ТипОбъекта);
        
        Если Метаданные.Справочники.Содержит(МетаданныеТипа) Тогда
            Сообщить(МетаданныеТипа.ПолноеИмя());
        ИначеЕсли Метаданные.Документы.Содержит(МетаданныеТипа) Тогда    
            Сообщить(МетаданныеТипа.ПолноеИмя());
        ИначеЕсли Метаданные.Перечисления.Содержит(МетаданныеТипа) Тогда    
            Сообщить(МетаданныеТипа.ПолноеИмя());
        КонецЕсли;    
        
    КонецЦикла;
   eenvo
 
16 - 27.03.18 - 16:21
> МетаданныеТипа = Метаданные.НайтиПоТипу(ТипОбъекта);
> Если Метаданные.Справочники.Содержит(МетаданныеТипа)
Извращенец.

Справочники.ТипВсеСсылки.Содержит(...)
   unregistered
 
17 - 27.03.18 - 16:22
(11) >> Получить что то типа строки(строк) "Справочник.Номенклатура"

Зачем?....
Бред какой-то....

(15) Мусье знает толк в извращениях.

В (14) правильный ответ на (6)
В (5) ответ на вопрос из (0)

(16) О. Ещё один маньяк...
   Kondarat
 
18 - 27.03.18 - 16:34
(16) Да, точно совсем забыл.
(17) Автор поста относится к тем участникам форума, которые совершенно точно знают что, кому, зачем и почему нужно...
   unregistered
 
19 - 27.03.18 - 16:48
(18) >> Автор поста относится к тем участникам форума, которые совершенно точно знают...

Хмммм... Не исключено. Мне определенно нравится эта мысль. Вселяет уверенность в себе и приятно ласкает ЧСВ.
   Kondarat
 
20 - 27.03.18 - 16:53
(19) Ну, тогда
Получить что то типа строки(строк) 
  "Справочник.Номенклатура"

Просто без Зачем?, Бред какой-то...
Ваше решение?
   unregistered
 
21 - 27.03.18 - 17:26
(20) >> Ваше решение?

Ветку пересмотри внимательно.
Ответ на вопрос из (0) я дал в (5).
Ответ на вопрос из (6) был дан другим автором в посте (14). О чем я упомянул в (17).

Какие вопросы - такие и ответы.
Автор ветки не захотел описывать свою задачу. Сначала он спрашивал об одном (как узнать тип значения субконто), потом о другом (как узнать конкретный тип значения).
Потом возник идиотский вопрос "Получить что то типа строки".

Исходя из этих метаний автора ветки становится понятным, что перед ним стоит задача проверки вхождения или соответствия типов. Для этого явно не нужно получать "что-то типа строки". Именно поэтому я и написал в (17), что это бред.

Другой вопрос, для какой цели он проверяет соответствие типов. Вполне возможно, что речь идет об элементе какой-нибудь формы, где проверку можно сделать указав связь по типу и никакой код писать вовсе не нужно. Ну да фиг его знает - что там у автора в башке...
   Ц_У
 
22 - 27.03.18 - 18:38
(21) Ветку утопить, автора забанить!
Или наоборот...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует