Вход | Регистрация


1С:Предприятие ::

Метки: 

v7: Разделить виды оплаты в 7.7 под ФФД 1.05

Я
   FormatC
 
26.03.18 - 22:51
Под 1.0 это делалось в этом блоке        
XMLPayments    = XMLCheckPackage.СоздатьПодчиненныйЭлемент("Payments");
        Атрибут(XMLPayments, "Cash", Макс(СуммаНаличные, СуммаНаличные)); 

под новый ффд что-то не пойму как сделать.
В обработке под 7.7 ни намека как это сделать
 
 
   FormatC
 
1 - 26.03.18 - 23:13
https://its.1c.ru/db/metod8dev#content:4829:hdoc:chapter270

на ИТС тоже только описание для ФФД 1.0
где под 1.05 подсмотреть?
   Злопчинский
 
Ведущий
2 - 27.03.18 - 01:38
   Aleksey
 
3 - 27.03.18 - 02:30
(2) я так понимаю комиссия не поддерживается?
   Злопчинский
 
Ведущий
4 - 27.03.18 - 13:15
(3) в смысле?1
   FormatC
 
5 - 27.03.18 - 16:20
виды оплаты я разделил...
теперь другая канитель - стандартная обработка для ТИС 7.7
при попытке указания скидки(Объект.PercentsDiscount()) драйвер выдает сообщение, что данная операция не применима на данной версии оборудования... это может быть связано с тем, что фискальный накопитель старый (будет меняться в ближайшее время)?
   FormatC
 
6 - 27.03.18 - 16:20
дрова последние стоят, прошивка последняя на Атол 11Ф
   Garykom
 
7 - 27.03.18 - 16:50
(5) Дрова бери последние (10-е лучше всего)

Блин ну раз речь в сабже про XML то это обозначает кривую обертку по стандарту 1С поверх родных дров от АТОЛ.

Выкиньте и юзайте правильные драйвера или откажитесь от любых "нестандартных пробивок".
   Garykom
 
8 - 27.03.18 - 16:51
(7)+  10-е это "Программное обеспечение\ДТО\10.x\10.1.0.zip"
   FormatC
 
9 - 27.03.18 - 16:55
в том то и дело что все стандартно... я взял сегодня последнюю типовую ТИС и попробовал.
Кстати, в последней обработке обслуживания вообще все по другомe,нет ни слова про xml, сразу юзаются методы из dll
   Garykom
 
10 - 27.03.18 - 18:07
(9) Для начала попробуй сделать эту "операция не применима на данной версии оборудования" вручную через "тест драйвера ккм".

Если прокатит то дело в прокладке, если нет то дрова или оборудование не то.
 
  Рекламное место пустует
   Сияющий в темноте
 
11 - 27.03.18 - 18:58
В онлайн кассах после версии 1.0 скидок как таковых нет,можно задать скидку,но она не вычитается из итога.
поэтому,ответ драйвера правильный,передавайте все без скидки,то есть с включением скидки в цену,ну и все косяки округления вылазят очень даже хорошо.единственное
,что осталось от скидок,это возможность отбросить копейки от итога чека
   FormatC
 
12 - 27.03.18 - 19:33
хм... будем копаться, спасибо
   Злопчинский
 
Ведущий
13 - 28.03.18 - 00:13
(11) все косяки округдения решаются разбиением строки на две по правилу 1 коп. У Виктуана решено (вроде)
   Сияющий в темноте
 
14 - 28.03.18 - 09:19
(13) разбиение,не панацея,т.к.покупатель будет задавать вопросы-что это за фигня.

потом,в рознице не может быть несколько цен на один и тот же товар,а в случае разбивки мы имеет документальное подтверждение данного нарушения
   Garykom
 
15 - 28.03.18 - 12:34
(14) "в рознице не может быть несколько цен на один и тот же товар"

ШТА? Ты откуда упал что может и не может быть в рознице.

Если установлен ценник на товар, то нельзя не продавать по этой цене. Можно продавать дешевле, дороже только с согласия покупателя.

В одном чеке нельзя один и тот же товар по разной цене - покупатель спросит: Почему вы мне только 1 штуку дешевле сделали, сделайте все дешевле!
   monsterZE
 
16 - 02.04.18 - 17:57
искал по теме.. хер что найдешь.
    Если ВерсияФФД > 0 Тогд// Атрибуты с ФФД 1.0.5 


        Если Не ПустаяСтрока(ОбщиеПараметры.КассирИНН) Тогда 
            ЗаписьXML.ЗаписатьАтрибут("CashierVATIN", XMLСтрока(ОбщиеПараметры.КассирИНН));
        КонецЕсли;
        Если Не ПустаяСтрока(ОбщиеПараметры.ОтправительEmail) Тогда
            ЗаписьXML.ЗаписатьАтрибут("SenderEmail", XMLСтрока(ОбщиеПараметры.ОтправительEmail));
        КонецЕсли;

    Если ВерсияФФД > 0 Тогд// Атрибуты с ФФД 1.0.5

                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными));
                ЗаписьXML.ЗаписатьАтрибут("Credit"           , XMLСтрока(СуммаПостоплатой));
                ЗаписьXML.ЗаписатьАтрибут("AdvancePayment"   , XMLСтрока(СуммаПредоплатой));
                ЗаписьXML.ЗаписатьАтрибут("CashProvision"    , XMLСтрока(СуммаПредоставлением));
            Иначе
                ЗаписьXML.ЗаписатьАтрибут("Cash"             , XMLСтрока(СуммаНаличными));
                ЗаписьXML.ЗаписатьАтрибут("ElectronicPayment", XMLСтрока(СуммаЭлектронными + СуммаПостоплатой + СуммаПредоплатой + СуммаПредоставлением));
            КонецЕсли;
            ЗаписьXML.ЗаписатьКонецЭлемента();
        КонецЕсли;
   monsterZE
 
17 - 02.04.18 - 17:58
<?xml version="1.0" encoding="UTF-8"?>
<CheckPackage>
    <Parameters PaymentType="1" TaxVariant="3" CashierName="Консультант - эксперт Яценко" CustomerEmail="" CustomerPhone=""/>
    <Positions>
        <FiscalString Name="Омыватель стекол &quot;ZIMA&quot; -30*С (5 л)(шт)" Quantity="1" PriceWithDiscount="130" SumWithDiscount="130" DiscountSum="" Department="2" Tax="none" SignMethodCalculation="6" SignCalculationObject="1" TaxSum=""/>
    </Positions>
    <Payments Cash="0" ElectronicPayment="130" Credit="0" AdvancePayment="0" CashProvision="0"/>
</CheckPackage>
   monsterZE
 
18 - 02.04.18 - 17:59
SignMethodCalculation (Признак способа расчета) - 2: "ПРЕДОПЛАТА (Частичная предварительная оплата до момента передачи предмета расчета)"
SignCalculationObject (Признак предмета расчета) - 1: "ТОВАР (наименование и иные сведения, описывающие товар)"
   monsterZE
 
19 - 02.04.18 - 18:03
в SignMethodCalculation и SignCalculationObject 
передаются номера согласно табличкам в ккм
   FormatC
 
20 - 02.04.18 - 18:04
я пока откатился назад, вот ФН поменяют через неделю, опять полезу
   monsterZE
 
21 - 02.04.18 - 18:04
Сам пока на 1.0 но скоро буду переползать.. видимо
   FormatC
 
22 - 02.04.18 - 18:05
пока непонятно почему новая длл от 1c глючит, возможно из-за старого ФНа
   monsterZE
 
23 - 02.04.18 - 18:08
=) врятли. везде ставь новые драйвера, новую длл и переписывай формирование ХМЛ пакета



Список тем форума
  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Рекламное место пустует