Вход | Регистрация

1С:Предприятие :: 1С:Предприятие 8 общая

Заменить счет 68.01 на 68.01.01,68.01.02,68.01.03

↓ [Волшебник, 26.03.18 - 10:54]
Заменить счет 68.01 на 68.01.01,68.01.02,68.01.03
Я
   Raideres
 
26.03.18 - 09:31
НаборПроводок         = ОтражениеЗВБ.Движения.Хозрасчетный;
     НаборПроводок.Отбор.Регистратор.Установить()
     НаборПроводок.Прочитать();
     
     Для Каждого Проводка Из НаборПроводок Цикл
        Если Проводка.Организация = ОрганизацияСсылка тогда
            Если Проводка.Содержание = "Удержан НДФЛ" тогда
                Если Проводка.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("68.01")Тогда
    
                КонецЕсли;
            КонецЕсли;
        КонецЕсли;
    КонецЦикла;
 
 
   hhhh
 
1 - 26.03.18 - 09:34
(0) ну так
Проводка.СчетКт = ПланыСчетов.Хозрасчетный.НайтиПоКоду("68.01.01")
   Raideres
 
2 - 26.03.18 - 09:39
Ребят немогу составить условие для изменения проводок 
проводки берутся из документа отражение зарплаты в ОтражениеЗарплатыВБухучете

в каждой проводке есть табличная часть
Проводка.Регистратор.НачисленныйНДФЛ
в ней 3 строчки в которых 3 строки с суммами и КодНалоговогоОргана
нужно разделить 68.01 по КодНалоговогоОргана
68.01.01 5803
68.01.02 7201
68.01.03 5806
http://prntscr.com/iwe80c
http://prntscr.com/iwe89w
http://prntscr.com/iwe8lh
   Raideres
 
3 - 26.03.18 - 09:45
(1) не правильно вопрос задал я как разделить эти строчки по КодНалоговогоОргана просто если отбор по сумме сделать то суммы же могут быть и равными
   shuhard
 
4 - 26.03.18 - 09:46
(3) запятые расставь
   Raideres
 
5 - 26.03.18 - 09:54
не правильно вопрос задал
Как разделить эти строчки по КодНалоговогоОргана, если отбор по сумме сделать, то суммы могут быть равными
   elisabet
 
6 - 26.03.18 - 10:53
Извиняюсь конечно, а нахрена ломать конфу, если код налогового органа пишется в регистре?
   shuhard
 
7 - 26.03.18 - 11:40
(6) а это дебильные бухи плодят субсчета
   Raideres
 
8 - 26.03.18 - 11:49
(6) несколько кодов
   El_Duke
 
9 - 26.03.18 - 11:51
(6) Это требования какого то умника, хочет раскидать НДФЛ по подразделениям, каждому подразделению соответствует субсчет.
Автор, гони этого типа в шею, это идиотизм

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует