Вход | Регистрация

1С:Предприятие ::

Метки: 

Установка параметра даты в обработке с отбором СКД

Я
   falselight
 
26.03.18 - 05:08
Есть обработка. В ней задан макет схема компоновки данных.
Там есть параметр КонДата. Мне нужно ему присвоить КонецДня(ТекущаяДата()).
Пробовал сделать при создании на сервере, но идет ошибка "Значение не является значением объектного типа

как и где задать значение параметра КонДата ?

//

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    СхемаКомпоновки           = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МАКЕТ_ВыводКорректировка");
    АдресВоВременномХранилище = ПоместитьВоВременноеХранилище(СхемаКомпоновки, Новый УникальныйИдентификатор);
    ИсточникНастроек          = Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресВоВременномХранилище);
    КомпоновщикНастроек.Настройки.ПараметрыДанных.Элементы.Найти("КонДата").Значение      = КонецДня(ТекущаяДата());
    КомпоновщикНастроек.Инициализировать(ИсточникНастроек);
    КомпоновщикНастроек.ЗагрузитьНастройки(СхемаКомпоновки.НастройкиПоУмолчанию);       
    //

КонецПроцедуры
//

&НаСервере
Процедура СФОРМИРОВАТЬ_ТЧНаСервере()
    СКД                 = РеквизитФормыВЗначение("Объект").ПолучитьМакет("МАКЕТ_ВыводКорректировка");
    НастройкиКомпоновки = КомпоновщикНастроек.ПолучитьНастройки();
    КомпоновщикМакета   = Новый КомпоновщикМакетаКомпоновкиДанных;
    МакетКомпоновки     = КомпоновщикМакета.Выполнить(СКД, НастройкиКомпоновки, , , Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));  
    ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
    ПроцессорКомпоновки.Инициализировать(МакетКомпоновки);
    ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
    ТЗ              = Новый ТаблицаЗначений;
    ПроцессорВывода.УстановитьОбъект(ТЗ);
    ПроцессорВывода.Вывести(ПроцессорКомпоновки);
    //

    НоменклатураСРеквизитами.Очистить();
    Для каждого СтрокаТз Из Тз Цикл
        НоваяСтрока                   = НоменклатураСРеквизитами.Добавить();
        НоваяСтрока.Номенклатура      = СтрокаТз.Товар;
        НоваяСтрока.ЕдиницаИзмерения  = СтрокаТз.Упаковка;
        НоваяСтрока.ЦенаПрайс         = СтрокаТз.Цена;
        НоваяСтрока.Вес               = СтрокаТз.Вес1Шт;         
        НоваяСтрока.ВесПогонногоМетра = СтрокаТз.ВесПогонногоМетра;
        НоваяСтрока.Длина             = СтрокаТз.Длина;
        НоваяСтрока.НаличиеНаСкладе   = СтрокаТз.ВНаличииОстаток;
    КонецЦикла;
КонецПроцедуры
//
 
 
   falselight
 
1 - 26.03.18 - 05:19
Разобрался, не правильно параметр назвал ( Извините!
   falselight
 
2 - 26.03.18 - 06:00
Хотя на запрос это не повлияло. Или я в этих данных не разбираюсь.


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует