Вход | Регистрация

1С:Предприятие ::

Метки: 

Программно проверить на существование отбора СКД

Я
   _Дайвер_
 
23.03.18 - 16:23
Программно проверить на существование отбора по определенным значениям отбора в ПриКомпоновкеРезультата, и если его нет то добавить определенный отбор. Просто добавить отбор проблем нет, просто когда заново формируешь добавляется такой же отбор, очищать настройки вроде такого не пойдет:
ЭтотОбъект.КомпоновщикНастроек.Настройки.Отбор.Элементы.Очистить();
Как мне найти поле отбора по условиям левого значения, сравнения и правого значения?
 
 
   _Дайвер_
 
1 - 23.03.18 - 16:30
нашел пример, всем спасибо

Для каждого ЭлементОтбора Из Отбор.Элементы Цикл
    Если ТолькоПоЛевомуЗначению Тогда
        НайденныйОтбор = ЭлементОтбора;
        Прервать;
    Иначе
        Если (ЭлементОтбора.ЛевоеЗначение = сЛевоеЗначение)
            И (ЭлементОтбора.ВидСравнения = сВидСравнения)
            И (ЭлементОтбора.Использование = сИспользование) Тогда
            НайденныйОтбор = ЭлементОтбора;
            Прервать;
        КонецЕсли;
    КонецЕсли;
КонецЦикла;

Если НайденныйОтбор <> Неопределено Тогда
    НайденныйОтбор.ЛевоеЗначение  = нПоле;
    НайденныйОтбор.Использование  = нИспользование;
    НайденныйОтбор.ВидСравнения   = нВидСравнения;
    НайденныйОтбор.ПравоеЗначение = нЗначение;
КонецЕсли;


Список тем форума
Рекламное место пустует   Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует