Вход | Регистрация


отладка обработки подключаемой к документу

отладка обработки подключаемой к документу
Я
   falselight
 
23.03.18 - 07:33
Делаю внешнюю обработку заполнения тч документа.
Нужно отлаживать её. Забыл как делают это.
Подскажите кому не трудно!!!!
 
 
   МимохожийОднако
 
1 - 23.03.18 - 07:36
(0) Добавь в обработку форму для отладки, которая запускает процедуры по заполнению ТЧ. Ваш КЭП
   Lexey_
 
2 - 23.03.18 - 07:40
(0) что, опять нехилый тупняк?
   falselight
 
3 - 23.03.18 - 07:49
(1) А как правильно передать что бы ошибки не было?
Подскажите пожалуйста?

//
&НаСервере
Функция ЗаполнитьОбъект(НовыйОбъект)
    Если ТипЗнч(НовыйОбъект) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
        Сообщить("123");    
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура Тестировать(Команда)
    ЗаполнитьОбъект(Элементы.ДокументОбъект);
КонецПроцедуры
//
   falselight
 
4 - 23.03.18 - 07:51
(3+)

Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'param':
    форма: Элемент
    имя: {http://v8.1c.ru/8.2/managed-application/modules}param
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ПолеФормы'
   Mankubus
 
5 - 23.03.18 - 07:53
(4) передавай не элемент, а его значение
   falselight
 
6 - 23.03.18 - 08:01
Так вот сделал, сработало. Правильно?

//

&НаСервере
Функция ЗаполнитьОбъект(НовыйОбъект)
    Если ТипЗнч(НовыйОбъект) = Тип("ДокументСсылка.ЗаказКлиента") Тогда
        Сообщить("123");    
    КонецЕсли;
КонецФункции

&НаКлиенте
Процедура Тестировать(Команда)
        ЗаполнитьОбъект(ЭтотОбъект.ДокументОбъект);
КонецПроцедуры
//
   igorPetrov
 
7 - 23.03.18 - 08:34
(6) Ты достал с тупняком.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
Тема не обновлялась длительное время, и была помечена как архивная. Добавление сообщений невозможно.
Но вы можете создать новую ветку и вам обязательно ответят!
Каждый час на Волшебном форуме бывает более 2000 человек.
Рекламное место пустует